Results 1 to 6 of 6

Environment: Dedicated box for BES on secured WEB layer firewall open on ports to database ... Server Admins forum

  1. #1
    chindian's Avatar
    chindian no está en línea Stack level 1
    Join Date
    Jun 2007
    PIN/ID
    2051646B
    Posts
    7

    Running into error during Remote SQL part of 4.1.4 install.

    Advertisement



    Environment:
    Dedicated box for BES on secured WEB layer
    firewall open on ports to database layer (1433, 25)
    SQL servers clustered, using virtual name during BES install


    This is the error I get: Database connection attemp failed after it has been successfully created. see setup logs...

    Here's what I found in the log:

    [30000] (11/14 11:42:37.043):{0x149C} [PIPTOOL]: There are 38081MB space available on the disk of the data directory locates.
    [20000] (11/14 11:42:37.043):{0x149C} SQL Error Message from CBESDBInstaller::Connect: SQLSTATE: IM002 Native error: 0 Message: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
    [20000] (11/14 11:42:37.043):{0x149C} Terminating because of connection failure. Connect string: DRIVER={SQL Server};SERVER="virtualsqlservername";Trusted_Conn ection=yes
    [20000] (11/14 11:42:37.043):{0x149C} SQL Error Message from CBESDBInstaller::Connect: SQLSTATE: IM002 Native error: 0 Message: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
    [20000] (11/14 11:42:37.043):{0x149C} Terminating because of connection failure. Connect string: DRIVER={SQL Server};SERVER="virtualsqlservername";Trusted_Conn ection=yes
    [40000] (11/14 11:42:37.059):{0x149C} ConnectionPool: Created pool of 20 connections
    [30000] (11/14 11:42:37.059):{0x149C} [ENV] [DB] Connection String = Server="virtualsqlservername";Database=BESMgmt;Tru sted_Connection=Yes
    [30000] (11/14 11:42:37.059):{0x149C} [ENV] [DB] DBMS Name = Microsoft SQL Server; DBMS Version = 08.00.2039; Provider Name = sqloledb.dll; Provider Friendly Name = Microsoft OLE DB Provider for SQL Server; OLE DB Version = 02.70; Provider Version = 08.10.3959
    [25000] (11/14 11:42:37.059):{0x149C}
    [20000] (11/14 11:42:37.059):{0x149C} SQL Error Message from CBESDBInstaller::Connect: SQLSTATE: IM002 Native error: 0 Message: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
    [20000] (11/14 11:42:37.059):{0x149C} Terminating because of connection failure. Connect string: DRIVER={SQL Server};SERVER="virtualservername";Trusted_Connect ion=yes


    I've created DSN ODBC entries under SYSTEM named: "bes_enterprise", not sure if that's right?
    Last edited by chindian; 11-14-2007 at 02:00 PM. Reason: adding error message

  2. #2
    tlowe's Avatar
    tlowe no está en línea BES Pro
    Join Date
    Oct 2007
    Posts
    66

    Re: Running into error during Remote SQL part of 4.1.4 install.

    I think it is supposed to be a differet name. Also did you create the bes user for the database?

  3. #3
    chindian's Avatar
    chindian no está en línea Stack level 1
    Join Date
    Jun 2007
    PIN/ID
    2051646B
    Posts
    7

    Re: Running into error during Remote SQL part of 4.1.4 install.

    Do you mean creating tables within teh db? If so, no I haven't.
    As for the DSN name in ODBC, I've never had to create these before with previous installations

  4. #4
    tlowe's Avatar
    tlowe no está en línea BES Pro
    Join Date
    Oct 2007
    Posts
    66

    Re: Running into error during Remote SQL part of 4.1.4 install.

    Not the tables but does the besadmin account have permission to create the database and tables?

  5. #5
    chindian's Avatar
    chindian no está en línea Stack level 1
    Join Date
    Jun 2007
    PIN/ID
    2051646B
    Posts
    7

    Re: Running into error during Remote SQL part of 4.1.4 install.

    I've asked the sys admin to confirm and she insists that besadmin account does.

  6. #6
    chindian's Avatar
    chindian no está en línea Stack level 1
    Join Date
    Jun 2007
    PIN/ID
    2051646B
    Posts
    7

    Re: Running into error during Remote SQL part of 4.1.4 install.

    i've now uninstalled, trying a reinstall using local msde, run into this error, found in system logs:
    Microsoft SQL Server Desktop Engine -- Setup failed to configure the server. Refer to the server error logs and setup error logs for more information.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •