Results 1 to 13 of 13

Hello hope someone can help me out here. I think it may be a fairly ... Server Admins forum

  1. #1
    zerodayz's Avatar
    zerodayz no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    14

    Question Google Maps firewall Policy

    Advertisement



    Hello hope someone can help me out here. I think it may be a fairly common problem seen some posts however, none seem to fix the problem when on BES. Let me explain:

    Phone: 8100 Pearl
    OS: 4.2.1.101
    Google Maps: 1.5.3
    Data Plan.
    TomTom GPS MkII Bluetooth receiver.

    BES v4.0.0.18
    (Lotus Domino)

    Senario:
    I can get Google maps working fine on my device, (I'm kinda a novice BES admin) however as soon as I try to enable the GPS functionality I receive the following error:

    "The application gmaps8100_v4_1_L1 has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT Policy"

    Being the BES admin, I have a blank IT policy, that is, there are no restrictions.

    Why is it denying me access to the GPS receiver. In contrast, Blackberry Maps works fine, and connects to the GPS device.

    Settings>Advanced>GPS>[my gps device] is set correctly.

    I also receive the same error when using another mapping application (Telmap).

    There are no Software configurations set on the BES server. Not sure how to, to be honest!

    Other threads that are similar to this all say to wipe the IT Policy, the old "blackberry.ig3.net" trick. Well, yes that works. I can then use Google Maps and GPS. Great! BUT, as soon as I Enterprise Activate, it kills it. (above error)

    What Policy option do I need to remove/add to enable access to the bluetooth GPS device?

    Thanks for reading this far!!

    Thanks in advance.

    zerodayz.

  2. #2
    jdellasala's Avatar
    jdellasala no está en línea Device Pro
    Join Date
    Mar 2006
    Posts
    1,573

    Re: Google Maps firewall Policy

    Try this. On your BlackBerry, go to ( Settings/Tools --> ) Options --> Security Options --> Application Permissions. Scroll down to Google Maps, hit the Menu button and select Edit Permissions. Make sure Connections, Interactions and User Data are all set to Allow. If they're not, hit [Space] to expand each, and scroll down to the item that's NOT set to Allow and hit [Space] to change it to Allow. Save the settings when done.
    .
    JerryD

  3. #3
    zerodayz's Avatar
    zerodayz no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    14

    Re: Google Maps firewall Policy

    Sorry, forgot to mention, I had checked that.

    All settings are set to Allow.

    Thanks anyway!

  4. #4
    zeyrah's Avatar
    zeyrah no está en línea Stack level 3
    Join Date
    Dec 2006
    Posts
    162

    Re: Google Maps firewall Policy

    I don't think you can have 3rd party apps on enterprise due to the security risk. Check the BB knowledge base and see if you can find something there! Good luck!~via BB (wap.pinstack.com)~

  5. #5
    takeshi's Avatar
    takeshi no está en línea Stack level 7
    Join Date
    Aug 2005
    Posts
    2,305

    Re: Google Maps firewall Policy

    That's definitely not true. I have 2 8800's on hosted BES with Google Maps (and plenty of other 3rd party apps) running just fine. The BES admin can disallow 3rd party apps but that doesn't seem to be the case here according the what zerodayz is saying.

  6. #6
    Rcbjr's Avatar
    Rcbjr no está en línea Stack Pro
    Join Date
    May 2006
    PIN/ID
    PM - Ask
    Posts
    14,848

    Re: Google Maps firewall Policy

    I'm not the BES expert at all but I seem to remember that the default IT policy or Blank policy has Bluetooth turned off and you need to allow it for some applications. Not sure about all this but give it a try

    Hope this helps.
    Rcbjr
    ~via My BB Curve (wap.pinstack.com)~

  7. #7
    zerodayz's Avatar
    zerodayz no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    14

    Thumbs up Re: Google Maps firewall Policy

    Fixed!

    Right, managed answer my own question. Thanks for all the tips by the way.

    Turns out, a 'blank' IT policy is still too restrictive. I went through it, line by line and found the offending rule:

    Security Policy Group: "Allow Split-Pipe Connections" (Default=False)

    This disables applications to open Internal and External connections simultaneously. Hence blocking my BT connection as it is an external connection. Made this rule True, now works.

    Thanks once again.

    zerodayz

  8. #8
    jdellasala's Avatar
    jdellasala no está en línea Device Pro
    Join Date
    Mar 2006
    Posts
    1,573

    Re: Google Maps firewall Policy

    Quote Originally Posted by zerodayz
    Fixed!

    Right, managed answer my own question. Thanks for all the tips by the way.

    Turns out, a 'blank' IT policy is still too restrictive. I went through it, line by line and found the offending rule:

    Security Policy Group: "Allow Split-Pipe Connections" (Default=False)

    This disables applications to open Internal and External connections simultaneously. Hence blocking my BT connection as it is an external connection. Made this rule True, now works.

    Thanks once again.

    zerodayz
    Nice work zerodayz!

    Have you been able to track down where the setting is on the BlackBerry?

    What I don't get is why this hasn't been a problem for more people!
    .
    JerryD

  9. #9
    zerodayz's Avatar
    zerodayz no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    14

    Lightbulb Re: Google Maps firewall Policy

    I'm not sure it's configurable on the Blackberry.
    I've been through every setting twice, trying to fix this for the last few weeks!

    *If* it is configurable on the handset, (which it may well not) it will be somewhere in the firewall settings, of which are locked for me. Not sure what options you get when this is not locked (red padlock symbol) It may either just be a on/off setting or more granular whereby it may be in there.

    Clear as mud? Good.

    zerodayz

  10. #10
    hsdrggr's Avatar
    hsdrggr no está en línea Stack level 1
    Join Date
    Sep 2007
    Posts
    1

    Re: Google Maps firewall Policy

    Quote Originally Posted by zerodayz
    Fixed!

    Right, managed answer my own question. Thanks for all the tips by the way.

    Turns out, a 'blank' IT policy is still too restrictive. I went through it, line by line and found the offending rule:

    Security Policy Group: "Allow Split-Pipe Connections" (Default=False)

    This disables applications to open Internal and External connections simultaneously. Hence blocking my BT connection as it is an external connection. Made this rule True, now works.

    Thanks once again.

    zerodayz
    zerodayz,

    I have the exact same problem with my 8700r and the identical TomTom BT puck. I am unable to find an editor for the policy.bin file. Based on searching the web it looks like I am looking for itpolicy.exe which can edit policy.inf files and create policy.bin files. Any idea where I can find this program. It appears that it comes on an OEM Enterprise CD, but I do not have one, and I would really like to get google maps to work on my berry.

    Thank you,

    hsdrggr

  11. #11
    vikjts's Avatar
    vikjts no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    4

    Re: Google Maps firewall Policy

    Quote Originally Posted by zerodayz View Post
    Fixed!

    Right, managed answer my own question. Thanks for all the tips by the way.

    Turns out, a 'blank' IT policy is still too restrictive. I went through it, line by line and found the offending rule:

    Security Policy Group: "Allow Split-Pipe Connections" (Default=False)

    This disables applications to open Internal and External connections simultaneously. Hence blocking my BT connection as it is an external connection. Made this rule True, now works.

    Thanks once again.

    zerodayz
    ZeroDayz, How do you edit the policy file? Thanks.

  12. #12
    becsta's Avatar
    becsta no está en línea Stack level 2
    Join Date
    Mar 2007
    Posts
    77

    Re: Google Maps firewall Policy

    ~via BB (wap.pinstack.com)~ive got the same problem. Would love to be able to fix it. I'm not on BES.

  13. #13
    vikjts's Avatar
    vikjts no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    4

    Re: Google Maps firewall Policy

    Hey, can you email me the blank(less restrictive) policy file at vikjts@gmail.com. Thanks.


    Quote Originally Posted by zerodayz View Post
    Fixed!

    Right, managed answer my own question. Thanks for all the tips by the way.

    Turns out, a 'blank' IT policy is still too restrictive. I went through it, line by line and found the offending rule:

    Security Policy Group: "Allow Split-Pipe Connections" (Default=False)

    This disables applications to open Internal and External connections simultaneously. Hence blocking my BT connection as it is an external connection. Made this rule True, now works.

    Thanks once again.

    zerodayz

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •