Starts then stops!

I get an error in the log with failure to connect to db.

[WARN ][2008-01-02 12:38:15,055][ProxyInitMgr]net.rim.wica.ag.base.util.ErrorCode@b57e9a
net.rim.wica.ag.services.admin.AdminException: Database access error.
at net.rim.wica.ag.services.admin.AdminServiceImpl.ge tAllHttpProxies(AdminServiceImpl.java:1565)
at net.rim.wica.ag.services.httpproxy.ProxyInitMgr.re freshProxies(ProxyInitMgr.java:67)
at net.rim.wica.ag.services.httpproxy.ProxyInitMgr.in it(ProxyInitMgr.java:49)
at net.rim.wica.ag.base.BaseMgr.handleStart(BaseMgr.j ava:72)
at net.rim.wica.ag.base.util.AbstractManagedService.s tart(AbstractManagedService.java:53)
at net.rim.wica.ag.base.util.AbstractManagedService.s tart(AbstractManagedService.java:35)
at net.rim.wica.ag.application.admin.AdminUtil.initSe rver(AdminUtil.java:118)
at net.rim.wica.ag.application.listener.CompactListen er.init(CompactListener.java:62)
at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1091)
at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:925)
at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3857)
at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4118)
at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:683)
at org.apache.catalina.startup.Catalina.start(Catalin a.java:537)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:271)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:409)
Caused by: java.sql.SQLException: JDBCMgr could not connect to the data source.
at net.rim.wica.ag.services.admin.depot.AdminDepot.ge tConnection(AdminDepot.java:1431)
at net.rim.wica.ag.services.admin.depot.AdminDepot.ge tAllHttpProxies(AdminDepot.java:1445)
at net.rim.wica.ag.services.admin.AdminServiceImpl.ge tAllHttpProxies(AdminServiceImpl.java:1561)

I checked my server.xml and username and password are ok. Also made sure I could log in to the DB through sql server management with that user and I can.. Is the jdbc driver messed up? Has anyone experienced this?