Results 1 to 9 of 9

I'm on my second 8100, having had a 7100 before that and I've noticed a ... General Blackberry forum

  1. #1
    ITD's Avatar
    ITD
    ITD no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    10

    Keylock not engaging properly

    Advertisement



    I'm on my second 8100, having had a 7100 before that and I've noticed a problem with this one that I haven't seen before.

    I keep my Pearl in my top shirt pocket all the time, so I'm in the habit of putting the key lock on automatically before putting it away. This was fine with the old one, but with this new one around 50% of the time despite the lock appearing to have come on, when I take it out again later I find that the lock is off. This has led to all sorts of nonsense e-mails or random phone calls.

    At first I thought I'd just been clumsy, but its happening all the time and since I owned another Pearl for a year before getting this one I know how it should be working. just to stress, I've been a BB user and administrator for several years now, so I know what I'm doing!

    What's more, I've just had one of my users complain that the same thing is happening on thier Curve as well! (hence I've posted here rather than in a model specific forum).

    The only difference I can see between my new Pearl and the old one is the carrier. I was on Orange (UK) at my old company, where as we use O2 here. We had about 50 BBs of various models at the old place and never had a single complaint like this, whereas here I've got two dodgy ones (that I know of) out of 15 here. As quite a few of them use holsters (8800) I suspect they would be immune to the problem though.

    Anyone have any ideas? It's driving me absolutely nuts!

  2. #2
    Sci-Tek's Avatar
    Sci-Tek no está en línea Stack level 4
    Join Date
    Dec 2007
    Posts
    849

    Re: Keylock not engaging properly

    Autolock at http://www.geekandproud.net/ , is a nice tool for auto keyboard lock. works fine here.

    Dunno if that will solve your problem tho, but when I take away the pearl I always hold the * key for 2 sec (at idle screen) and it will lock. Maybe this is something you can use also?

  3. #3
    ITD's Avatar
    ITD
    ITD no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    10

    Re: Keylock not engaging properly

    Quote Originally Posted by Sci-Tek View Post
    Autolock at http://www.geekandproud.net/ , is a nice tool for auto keyboard lock. works fine here.

    Dunno if that will solve your problem tho, but when I take away the pearl I always hold the * key for 2 sec (at idle screen) and it will lock. Maybe this is something you can use also?
    I use the menu icon at the moment, but have it arranged so that icon is in the 'short menu' of the Dimension Zen theme which I've always used.

    Trying the * shortcut the visible effect on screen is identical to when I use the icon, so I suspect it wont make any difference.

    I've seen the thing apparently go into lock, but then being suspicious as I am now I wiggle the trackball or press a key and it bounces back to the menu again.

    It's a bit like when you have a windows screen saver lock, if you wiggle the mouse within two seconds of the screensaver going on it cancels without engaging the lock, but I've never had my BB behave like that before and don't want it to!

    Essentially if I forget to check that the lock is on, I've a 50/50 chance it'll be doing random rubbish in my pocket! I musy put it in and out of lock 30 or 40 times a day, so its a real nuisance!

  4. #4
    Sci-Tek's Avatar
    Sci-Tek no está en línea Stack level 4
    Join Date
    Dec 2007
    Posts
    849

    Re: Keylock not engaging properly

    lets just clarrify something here, do I understand you correctly that your keylock does not lock the keys? or just that it unlocks itself? could it be that it scrolls the wheel and click "unlock", then somewhat manages to press * and green answer button?! that sounds really sci-fi...

    But you might want to add a password for keylock if that is the case.. dont set defcon level 1 security so it will wipe your phone ;p

  5. #5
    ITD's Avatar
    ITD
    ITD no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    10

    Re: Keylock not engaging properly

    Quote Originally Posted by Sci-Tek View Post
    lets just clarrify something here, do I understand you correctly that your keylock does not lock the keys? or just that it unlocks itself? could it be that it scrolls the wheel and click "unlock", then somewhat manages to press * and green answer button?! that sounds really sci-fi...

    But you might want to add a password for keylock if that is the case.. dont set defcon level 1 security so it will wipe your phone ;p
    It looks like keylock has gone on, but if I press a key or wiggle the trackball it sometimes comes off again. It's not unlocking itself with the key combination.

    I'm pretty sure it only happens in the first few seconds after I've pressed the key to put the keylock on. Certainly if the 'press green and * to unlock' window comes up, the lock is on properly and will stay on.

    It seems like there is some sort of 2-3 second pause between it starting the locking process and the lock actually going on, and if there is a user input in that time it cancels the lock.

    So every time I lock the thing I have to wait several seconds to confirm its actually worked before I put it away, which sounds like a small thing but when you're locking and unlocking it all day long it gets old real quick. I doubt a password would help as the problem seems more related to it not engaging in the first place, not how secure the unlock process is.

    As I said at the top, this is my second 8100 and the previous one never had this issue despite me using it in exactly the same way.

  6. #6
    Join Date
    Jun 2007
    Posts
    5,737

    Re: Keylock not engaging properly

    I say try a battery pull to cold boot the device (pull batt, count to 30, reinsert). If that doesnt do it, it may be a hardware problem. I'm with Sci Tek, if the cold boot doesn't fix it then password it.

  7. #7
    ITD's Avatar
    ITD
    ITD no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    10

    Re: Keylock not engaging properly

    Quote Originally Posted by Mark Stone View Post
    I say try a battery pull to cold boot the device (pull batt, count to 30, reinsert). If that doesnt do it, it may be a hardware problem. I'm with Sci Tek, if the cold boot doesn't fix it then password it.
    I've not specifically battery pulled for this problem, but for various reasons have done so since I got the new 8100 in October and the problem has been there consistently. At first I just thought I was being careless, but over time I know I'm not that careless to miss out the lock this frequently, especially as I've had the same handset for a year before getting this one.

    It doesn't 'feel' like a hardware issue, more software. As I said above it reminds me most of the way a PC screen saver with password enabled will cancel without locking if you wobble the mouse or hit a key within a second or two of it engaging.

    I'm loathe to enable the password as I lock and unlock the phone all the time and don't want to be faffing about with passcodes every five mins. I'll maybe try it for a couple of days and see if it makes a difference, just as a troubleshooting measure. I'm not convinced it'll make a difference though as it seems more like it isn't engaging in the first place rather than unlocking itself once locked.

  8. #8
    aswanideep's Avatar
    aswanideep no está en línea Stack level 4
    Join Date
    Oct 2007
    Posts
    512

    Re: Keylock not engaging properly

    I will suggest you to use "Stand-by mode". The volume key on the head of pearl. When I had a pearl, I used it that way.

    It works like hibernate mode of PC.

    ~via Aswani-Berry (wap.pinstack.com)~

  9. #9
    seabirdone's Avatar
    seabirdone no está en línea Stack level 3
    Join Date
    Jun 2007
    PIN/ID
    20DE5001
    Posts
    385

    Re: Keylock not engaging properly

    ~via BB (wap.pinstack.com)~i use my right hand convenience key to lock keyboard. It may work for U better

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •