Page 1 of 2 12 LastLast
Results 1 to 15 of 24

I posted this under a different thread, OS 4.5 and US Wireless Carriers...., but thought ... RIM Handheld OS forum

  1. #1
    Richard1864's Avatar
    Richard1864 no está en línea Stack level 2
    Join Date
    Feb 2008
    Posts
    44

    OS 4.5 Release information

    Advertisement



    I posted this under a different thread, OS 4.5 and US Wireless Carriers...., but thought more might read this and thushave better idea of when 4.5 is coming out. Here we go...

    Yesterday I spent several hours takling to developers at Sprint, Verizon, AT&T, Tmobile, Telenav, and others who are preparing to release OS 4.5 in the US market.

    They plan on releasing 4.5 sometime in early July, assuming various issues all worked out.

    Some of these issues include:
    - Multiple Java and other OS related Exception messages.
    - OS update not sticking, so to speak, when BB's are updated. (No OS on the BB at all after updating...)
    - Verizon and Sprint use 5000 bit encryption for their voice communications, and the others use either 2000 or 5000 bit; OS is not completing the handshake with the carriers' networks to allow voice communication.
    - Various hardware issues, both on the various BB models and on the network side.

    There are more issues, but I promised not to release them by previously agreeing to Non-Disclosure forms.

    Just thought you guys would like the update!

    Richard

    PS Comments welcome!

  2. #2
    ma077146's Avatar
    ma077146 no está en línea Stack level 5
    Join Date
    Sep 2006
    PIN/ID
    3019F3E6
    Posts
    945
    I'm a Sprint customer; likely, we'll be last or next to last to get the OS.

  3. #3
    drozek's Avatar
    drozek no está en línea Stack level 2
    Join Date
    Jul 2007
    PIN/ID
    31B1D26F
    Posts
    77
    what version of 4.5 are they on for the CDMA side?

  4. #4
    pshift's Avatar
    pshift no está en línea Stack level 3
    Join Date
    May 2008
    Posts
    97
    8330CDMA_Public_4.5.0_rel48_4.5.0.33.exe is what is floating around.

  5. #5
    mdvreyes's Avatar
    mdvreyes no está en línea Stack level 2
    Join Date
    Sep 2007
    Posts
    21
    I gotta ask Richard, how is it that you are able to discuss such information with the various developers?
    Your stack/trust level is (per this site) is rating you as a novice.
    I don't mean any ill dispostion as I am curious, being that I too, am fairly new to this forum.
    Just asking.

    ps I think this forum/site is awesome!

  6. #6
    Richard1864's Avatar
    Richard1864 no está en línea Stack level 2
    Join Date
    Feb 2008
    Posts
    44
    Quote Originally Posted by mdvreyes View Post
    I gotta ask Richard, how is it that you are able to discuss such information with the various developers?
    Your stack/trust level is (per this site) is rating you as a novice.
    I don't mean any ill dispostion as I am curious, being that I too, am fairly new to this forum.
    Just asking.

    ps I think this forum/site is awesome!

    I am rated a novice here since I am new to the site and don't have many postings here yet. But this site is the best I have found so far dealing with all things Blackberry (even better than Crackberry.com)!

    As to my being able to talk with the developers, it is because I have, for more than three years, done beta testing for Sprint and Verizon, along with companies like Telenav, Garmin, and Opera, to name just a few. After a beta testing for an extended time with various companies, and buildng relationships with the developers, one can be involved in more than just the testing of software and hardware. However, you also have to sign Non-Disclosure Agreements when testing with those companies, which limits what you can, and can NOT say, about software and hardware being tested.

    When it comes to operating systems for mobile phones, blackberries, and other smart phones, testing by the carriers AFTER it is released to them can sometimes take months, depending on the various handsets, carriers' networks, FCC requirements, etc.

    In addition, many carriers want different things on the Blackberry OSes. 4.5 is much more customized per carrier than previous OSes. Verizon's, for example, still puts limitations on what software (like GPS) will work on their network. AT&T appears to be going the same way. Sprint and the others, by comparison, are NOT limiting what their phones can do. These limitations apparently are now included as part of the 4.5 OS, which may cause problems when trying to install one carrier's copy of 4.5 on to a BB for a totally different carrier; i.e., putting Verizon's 4.5 OS on a Sprint BB, for example.

    Another example of the above is that Vodafone's copy of the 4.5 OS released in Europe is NOT fully comaptible with BB's running on US carriers. There are encryption incompatibilities, which can cause dropped calls. They can also make the phone appear to the US carrier that the BB is roaming, even though it is NOT roaming. That is an example of course, but I have heard of this occuring for the developers.

    Any of this help?

    Richard
    Last edited by Lavagirl; 06-30-2008 at 07:24 PM. Reason: Format edit

  7. #7
    Leetneo's Avatar
    Leetneo no está en línea Stack level 4
    Join Date
    Aug 2007
    PIN/ID
    316D16C7
    Posts
    712
    I did the 8830 upgrade to 4.5 and its working fine, have had no problems at all.

  8. #8
    Gman1108's Avatar
    Gman1108 no está en línea Stack level 3
    Join Date
    Jun 2007
    PIN/ID
    Just ask
    Posts
    244
    ~via BB (wap.pinstack.com)~

    Hi all,

    I'd like to upgrade 8310 to OS 4.5.

    My OS is:4.2.2.146.

    This is, when I try to get the OS file from BB.com I actually see 4.5 listed, just numbers similar to to my current version.

    I'm in the UK on Vodafone UK.

    Can someone post a link to where I need to get this from please?

    Thanks very much.

  9. #9
    Gman1108's Avatar
    Gman1108 no está en línea Stack level 3
    Join Date
    Jun 2007
    PIN/ID
    Just ask
    Posts
    244
    Quote Originally Posted by Gman1108 View Post
    ~via BB (wap.pinstack.com)~

    Hi all,

    I'd like to upgrade 8310 to OS 4.5.

    My OS is:4.2.2.146.

    This is, when I try to get the OS file from BB.com I actually see 4.5 listed, just numbers similar to to my current version.

    I'm in the UK on Vodafone UK.

    Can someone post a link to where I need to get this from please?

    Thanks very much.
    Sorry, typo in my last post, I meant to say I DON'T actually see version 4.5.

    Thanks.

  10. #10
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164
    Quote Originally Posted by Gman1108 View Post
    ~via BB (wap.pinstack.com)~

    Hi all,

    I'd like to upgrade 8310 to OS 4.5.

    My OS is:4.2.2.146.

    This is, when I try to get the OS file from BB.com I actually see 4.5 listed, just numbers similar to to my current version.

    I'm in the UK on Vodafone UK.

    Can someone post a link to where I need to get this from please?

    Thanks very much.

    here is the 4.5.0.37 from vodafone germany
    just remember to delete the vendor.xml file before trying to load it.

  11. #11
    Gman1108's Avatar
    Gman1108 no está en línea Stack level 3
    Join Date
    Jun 2007
    PIN/ID
    Just ask
    Posts
    244
    Thanks, Cherri.

  12. #12
    hayden's Avatar
    hayden no está en línea Stack Mod
    Join Date
    Jul 2004
    PIN/ID
    ask
    Posts
    12,440
    Quote Originally Posted by Richard1864 View Post
    Oh, and please help increase my Trust level if you can - I really would appreciate it!
    Note forum rules about Trust.

    Also, not to worry we have this post marked and if what you've posted turns out to be correct, you will receive quite a bit of positive Trust from our team. If not then negative trust.

    Thanks.

  13. #13
    Richard1864's Avatar
    Richard1864 no está en línea Stack level 2
    Join Date
    Feb 2008
    Posts
    44
    Quote Originally Posted by hayden View Post
    Note forum rules about Trust.

    Also, not to worry we have this post marked and if what you've posted turns out to be correct, you will receive quite a bit of positive Trust from our team. If not then negative trust.

    Thanks.

    Thanks, Hayden.

    I did NOT put a specific date in my post, because I was NOT given one. I won't give a date out even if I am told what it is, because all to often the date ends up being wrong because of new bugs or persistent problems not fixed.

    In addition, for those who use Telenav, here is some information from Telenav about using their product with OS 4.5. Telenav in their Support Forum mentions some of the problems they are having with OS 4.5 in their post here .

  14. #14
    scooter1219's Avatar
    scooter1219 no está en línea Stack level 1
    Join Date
    Sep 2006
    Posts
    3
    4.5.0.33 on VZW 8830 working fine here

  15. #15
    ItsNowOrNever's Avatar
    ItsNowOrNever no está en línea Stack level 7
    Join Date
    Feb 2007
    PIN/ID
    30485184
    Posts
    2,994
    Quote Originally Posted by Richard1864 View Post
    Thanks, Hayden.

    I did NOT put a specific date in my post, because I was NOT given one. I won't give a date out even if I am told what it is, because all to often the date ends up being wrong because of new bugs or persistent problems not fixed.

    In addition, for those who use Telenav, here is some information from Telenav about using their product with OS 4.5. Telenav in their Support Forum mentions some of the problems they are having with OS 4.5 in their post here .
    4.5.0.42 running great here with telenav!!!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •