Results 1 to 8 of 8

Empower BES is not supported on OS v.4.5. It being one of my most used ... RIM Handheld OS forum

  1. #1
    liquidsense's Avatar
    liquidsense no está en línea Stack level 2
    Join Date
    Sep 2007
    Posts
    80

    Empower BES equivalent

    Advertisement



    Empower BES is not supported on OS v.4.5. It being one of my most used third-party apps, I was quite disappointed to find very little info out there about when a new compatible version would emerge.

    Just out of curiousity, does anyone know of any application that does the same thing as Empower BES, whether it is compatible with 4.5 or not? I stumbled upon Empower a long time ago, and never bothered to check if there was anything comparable out there.

    Thanks.

  2. #2
    BBEnriched's Avatar
    BBEnriched no está en línea Stack level 3
    Join Date
    Jul 2008
    Posts
    111
    The JDE for 4.5 was not released all that long ago. Have you contacted them directly to get an ETA on when they will have a new version out?
    www.bbenriched.com - Unlocks and Parts

  3. #3
    liquidsense's Avatar
    liquidsense no está en línea Stack level 2
    Join Date
    Sep 2007
    Posts
    80
    Two things:
    1) I just realized that I posted this in the wrong forum. I was looking at the 3rd party software sub-forum link on top when I posted this.

    2) Yes, I did e-mail them to see if I could get an answer. I'll report back if I get an answer.

  4. #4
    BBEnriched's Avatar
    BBEnriched no está en línea Stack level 3
    Join Date
    Jul 2008
    Posts
    111
    I think I have a contact card for them laying around somewhere. I will also see if I can get info. ~via BB (wap.pinstack.com)~

  5. #5
    zulu1128's Avatar
    zulu1128 no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    7
    I got a response back from them about 6 weeks ago that said it was being worked on, but they had no timetable for an update. I've since sent 2 more emails over the past 2 weeks requesting updates, but have received no response.

    I too rely heavily on this program, and it's lack of update is preventing me from upgrading to OS 4.5. If there's not a clear path for an update to the program, I'm considering asking for a refund of my $20.

  6. #6
    liquidsense's Avatar
    liquidsense no está en línea Stack level 2
    Join Date
    Sep 2007
    Posts
    80
    zulu1128 -

    Thanks for the info. I emailed them about 2 weeks ago, and have not yet received a response from them. I am thinking that they may not really feel the incentive to get this out the door until 4.5 became official -- but then I realized that (at least to a certain extent), 4.5 is already official.

    Once it becomes official for my service provider, I will then contemplate asking for a refund. I agree with you, and common sense, that the product that we paid for should upgrade with os upgrades.

  7. #7
    zulu1128's Avatar
    zulu1128 no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    7
    I received this response from Empower yesterday:

    BES MailBox works partially with 4.5 OS. There are some bugs in the OS that are causing issues.

    Our team is working with RIM support to find a roundabout solution to the bug in the OS but our tech team hasn't given a date commitment yet.

    Thanks & Regards,
    Team Empower
    I'm not holding my breath.

  8. #8
    jdellasala's Avatar
    jdellasala no está en línea Device Pro
    Join Date
    Mar 2006
    Posts
    1,573
    It's been updated for the Bold & Storm now. Should work on OS 4.5 too.
    Check here for info.
    .
    JerryD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •