So I have a MyTouch4g and i send ALOT of texts. and when i hit send, i hit home, and it saves the message as a draft and the text of the last message i sent will stay there until i delete it.

My question is, is there any way to turn off drafts all together, they get in the way.

help is greatly appreciated