Results 1 to 12 of 12

I've been having issues trying to fix the device error 400 that my 7290 been ... Blackberry 7700/7200 & older forum

  1. #1
    deafcyclist's Avatar
    deafcyclist no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    243F42A5
    Posts
    138

    BB7290 Device Error 400



    I've been having issues trying to fix the device error 400 that my 7290 been afflicted with after trying out some of the newer 7290 themes.

    It been a while since the last time I've attempted to fix the error and I remember that many of the common solutions didn't work. I can't remember which one. Either way, I wonder if anyb0dy here knows of any good guides/info on how to repair this? I already have the latest 7290 BBOS on my PC ready for this process.

  2. #2
    deafcyclist's Avatar
    deafcyclist no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    243F42A5
    Posts
    138
    I've tried fixing it again to pinpoint the exact area that I'm having issue with and it is...

    DM can see the USB PIN but still say disconnected. Can't even use the app loader and similar functions of the DM. I've also tried the JL_cmdr thing and it basically behaves the same. can see the BB USB PIN but can't actually do anything to the BB itself. I haven't seen any real solution to this particular aspect of my problem on the forum :-/

  3. #3
    Mark Stone's Avatar
    Mark Stone no está en línea Stack Professional
    Join Date
    Jun 2007
    Posts
    5,736
    Blog Entries
    23
    Try this:

    How To: ReInstall OS When Computer Won't Recognize The Device Is Connected

    Unfortunately what you're experiencing is not too uncommon. Follow the instructions exactly, you should get your 7290 back
    Sammy Galaxy S3, Android 4.3
    Giggle Nexus 7 Tab, Android 4.4 KitKat
    Asus X55A Notebook w/Win8.1
    Come visit the old man! http://markstone.org

  4. #4
    deafcyclist's Avatar
    deafcyclist no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    243F42A5
    Posts
    138
    I've tried that procedure and couldn't get past step 6-7. The DM would recognize the USB PIN inside the connection menu but the main screen still says disconnected. I've tried to just go ahead and clicked on the app loader and all I saw was that there was no software for my device even though it couldn't connect to my device in the first place :-/

  5. #5
    deafcyclist's Avatar
    deafcyclist no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    243F42A5
    Posts
    138
    maybe it possible that I got the wrong OS? I've just been deleting various programs and only found the 7250 OS, not the 7290 OS installed on my PC. Could this be te reason?

    Could someone point me to the best latest 7290 OS? just to see if I can fix it?

  6. #6
    RedNightHawk's Avatar
    RedNightHawk no está en línea Stack level 3
    Join Date
    Jun 2008
    Posts
    422
    According to this...

    http://blackberryforums.pinstack.com...ll_models.html


    it's 4.2.0.377

    if you're on tmo look here

    http://www.t-mobile.com/bbupgrade/

    or grab one of the other ones in the 7290 list on the first link.

    If that doesn't fix it, was it for sure a theme that killed it, and does it at least come up with a spinning hourglass or anything before showing the error screen?

  7. #7
    moderncowboy's Avatar
    moderncowboy no está en línea Stack Moderator
    Join Date
    May 2008
    PIN/ID
    AskMe
    Posts
    7,297
    Blog Entries
    8
    Quote Originally Posted by deafcyclist View Post
    maybe it possible that I got the wrong OS? I've just been deleting various programs and only found the 7250 OS, not the 7290 OS installed on my PC. Could this be te reason?

    Could someone point me to the best latest 7290 OS? just to see if I can fix it?
    I would say thats the problem. You can not load another devices software. Follow the link given by RedHawk and give it a try.

  8. #8
    deafcyclist's Avatar
    deafcyclist no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    243F42A5
    Posts
    138
    Thanks, i'll try that later on. I'm going on a few days trip with a friend then when I come back, i'll be going on a week trip with my family so i'll be very very busy lol.

    It was defidently a theme that bricked the 7290. I was checking out various themes from the free theme section for the 7290.

    I can't remember how it behaved right before it bricked though, been a few months. I think that I restarted the phone for the theme installation and it simply started up with that error 400 screen.

    ~via BB (wap.pinstack.com)~

  9. #9
    RedNightHawk's Avatar
    RedNightHawk no está en línea Stack level 3
    Join Date
    Jun 2008
    Posts
    422
    The reason I asked was cause I had a theme that got my 8100 in an endless loop of having to reset only to see a error 205 screen with the only option being to choose reset. I managed to get it off using CrackUtil (vs wiping the phone), but the phone would take a while to get to the error 205 screen and I was able to connect with CrackUtil in that period of time to get a filelist off of the phone and remove the theme file. Everything is fine now and I didn't lose any data. Not sure if you'd be able to use the same method to save yourself some time.

  10. #10
    deafcyclist's Avatar
    deafcyclist no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    243F42A5
    Posts
    138
    Haven't heard of crackutil myself. Any links so I can look at it?

    ~via BB (wap.pinstack.com)~

  11. #11
    RedNightHawk's Avatar
    RedNightHawk no está en línea Stack level 3
    Join Date
    Jun 2008
    Posts
    422
    It's from a 'competing' forum which I can't post a link to on here without getting the post deleted. I'll PM you the link.

  12. #12
    Mark Stone's Avatar
    Mark Stone no está en línea Stack Professional
    Join Date
    Jun 2007
    Posts
    5,736
    Blog Entries
    23
    Quote Originally Posted by RedNightHawk View Post
    . . .it's 4.2.0.377. . .
    You of course meant 4.1.0.377, which is indeed the "newest" (although not as useful) OS for the 7290 . . .
    Sammy Galaxy S3, Android 4.3
    Giggle Nexus 7 Tab, Android 4.4 KitKat
    Asus X55A Notebook w/Win8.1
    Come visit the old man! http://markstone.org

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •