As of today I've installed Office 2008 and entourage copied the identity over from 04 to 08 without any problems. HOWEVER, PocketMAC will not recognize teh 2008 version in order for me to update it properly. There is however a function in 08 that lets you sync it with iCal and Addressbook so you could do a 5 way sync till PocketMAC fixes this. I've looked in all the areas I can. Or if anyone knows how to make PocketMAC look at 2008 instead of 2004.