Page 1 of 2 12 LastLast
Results 1 to 15 of 19

I have a 7130e (Verizon) that I have been synching with, most recently, the desktop ... RIM Desktop Software forum

  1. #1
    userdd6767's Avatar
    userdd6767 no está en línea Stack level 1
    Join Date
    Mar 2007
    Posts
    3

    Question Sync trouble "No available message stores"

    Advertisement



    I have a 7130e (Verizon) that I have been synching with, most recently, the desktop 4.2 software for a year and a half. I have been synching with my office's Exchange 2003 calendar/contact/task stuff, and use BIS for email (both work and Yahoo).

    However, perhaps around the time I upgraded Exchange to 2007 last month, I suddenly stopped being able to sync, while my email still flows nicely. I get most of the way through the synching, then I get a Microsoft Outlook Connector Error box stating "No availabe message stores" and the sync never happens.

    I have looked all over the web for a solution but find little information on this. When I check my sync log, it states that I have an "Internal Error #4238" but I found no good fixes that work. I have tried upgrading the desktop software to 4.3 from Blackberry's site, but that didn't help either.

    Any solutions would be GREATLY appreciated!

  2. #2
    Rcbjr's Avatar
    Rcbjr no está en línea Stack Pro
    Join Date
    May 2006
    PIN/ID
    PM - Ask
    Posts
    14,848

    Re: Sync trouble "No available message stores"

    You Ask, We Will Answer
    Can’t Install theme via DM?No Additional Apps Found for Your Device
    Links to Usefull KB Articles

  3. #3
    userdd6767's Avatar
    userdd6767 no está en línea Stack level 1
    Join Date
    Mar 2007
    Posts
    3

    Re: Sync trouble "No available message stores"

    Thanks - however, that didn't work for me, either. I ended up reformatting my PC, and it fixed everything.

  4. #4
    blackberry user's Avatar
    blackberry user no está en línea Stack level 1
    Join Date
    Mar 2008
    Posts
    1
    I am having the same problem - how did you reformat your PC to make it work? Thanks.

  5. #5
    userdd6767's Avatar
    userdd6767 no está en línea Stack level 1
    Join Date
    Mar 2007
    Posts
    3
    I completely reinstalled the operating system, then reinstalled all of my applications. It worked fine for a while, until I recently installed a "free" FTP software package - and now I am having the same exact problem as before. I would still appreciate knowing what is going on so I can avoid this problem in the future.

    I'd hate to reformat my PC AGAIN only to keep getting this problem!

  6. #6
    WorldOfJohnboy's Avatar
    WorldOfJohnboy no está en línea Stack level 1
    Join Date
    Aug 2007
    Posts
    3
    FYI, I had the same error. I own a BB 8310 Curve, upgraded to Desktop Mgr. V 4.3, and installed Outlook 2007 with and Exchange server.

    I tried the Intellisync deletion and still the error. The MAPI fix isn't for Exchange users, so I couldn't do that one. I tried creating a new Outlook profile, still same error.

    Then I remembered how to create a new MAPI file... here's what I did:

    -Close out of Desktop Mgr and Outlook.
    -For typical Windows XP installs, browse to: c:\windows\system32
    -Locate the file called "mapi32.dll" and rename it to: "mapi32.dll.old"
    -Locate the file called "Fixmapi.exe" and double-click it.
    -Nothing appears to happen, but if you refresh your screen view, you will see a new "mapi32.dll" file

    Open Outlook, start Destop Mgr, and try to configure sync. For me, this worked and thankfully I didn't need to reimage my PC.

  7. #7
    RPCons's Avatar
    RPCons no está en línea Stack level 1
    Join Date
    Dec 2007
    Posts
    3
    I'm having issues also. I have an 8703e, and upgraded the Desktop Manager software to version 4.3.0.15, and it was all down hill from there. My first problem when I attempted sync was the error "No Available Message Stores". I deleted and reinstalled the same desktop version. Now when I attempt to configure sync, and select device application; Microsoft Outlook isn't an option to pick from. Why isn't 4.3 playing nice with Microsft Outlook? I tried what WorldOfJohnBoy suggested, but that didn't help. Should I try going back to 4.2?

  8. #8
    nickskuse's Avatar
    nickskuse no está en línea Stack level 1
    Join Date
    Jun 2008
    Posts
    2
    This worked for me! Thanks a lot!

  9. #9
    nickskuse's Avatar
    nickskuse no está en línea Stack level 1
    Join Date
    Jun 2008
    Posts
    2
    Quote Originally Posted by WorldOfJohnboy View Post
    FYI, I had the same error. I own a BB 8310 Curve, upgraded to Desktop Mgr. V 4.3, and installed Outlook 2007 with and Exchange server.

    I tried the Intellisync deletion and still the error. The MAPI fix isn't for Exchange users, so I couldn't do that one. I tried creating a new Outlook profile, still same error.

    Then I remembered how to create a new MAPI file... here's what I did:

    -Close out of Desktop Mgr and Outlook.
    -For typical Windows XP installs, browse to: c:\windows\system32
    -Locate the file called "mapi32.dll" and rename it to: "mapi32.dll.old"
    -Locate the file called "Fixmapi.exe" and double-click it.
    -Nothing appears to happen, but if you refresh your screen view, you will see a new "mapi32.dll" file

    Open Outlook, start Destop Mgr, and try to configure sync. For me, this worked and thankfully I didn't need to reimage my PC.


    This worked for me! Thanks!

  10. #10
    websurfr's Avatar
    websurfr no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    1

    Thumbs up worked for me...

    Quote Originally Posted by WorldOfJohnboy View Post
    FYI, I had the same error. I own a BB 8310 Curve, upgraded to Desktop Mgr. V 4.3, and installed Outlook 2007 with and Exchange server.

    I tried the Intellisync deletion and still the error. The MAPI fix isn't for Exchange users, so I couldn't do that one. I tried creating a new Outlook profile, still same error.

    Then I remembered how to create a new MAPI file... here's what I did:

    -Close out of Desktop Mgr and Outlook.
    -For typical Windows XP installs, browse to: c:\windows\system32
    -Locate the file called "mapi32.dll" and rename it to: "mapi32.dll.old"
    -Locate the file called "Fixmapi.exe" and double-click it.
    -Nothing appears to happen, but if you refresh your screen view, you will see a new "mapi32.dll" file

    Open Outlook, start Destop Mgr, and try to configure sync. For me, this worked and thankfully I didn't need to reimage my PC.

    This worked for me - everything had been working fine until I installed the exchange tools (to admin exchange) then I got the "no available message stores" - I had just reloaded my system and didn't wanna have to do that again - this fix WORKED !!!!

    Thanks for the help !!

  11. #11
    xpo's Avatar
    xpo
    xpo no está en línea Stack level 1
    Join Date
    Jul 2008
    Posts
    1

    Thumbs up WorldOfJohnboy's fix

    Just wanting to thank the man for solving my problem. I'm an old man who knows little about computers. Was nervous about messing around with dll's and other operating system files but the suggested fix solved the sync problem with my 8703e. I now have version 4.5 of the desktop manager and it works fine.
    Last edited by xpo; 07-13-2008 at 11:59 AM.

  12. #12
    kranitz's Avatar
    kranitz no está en línea Stack level 1
    Join Date
    Jul 2008
    Posts
    1
    Worked Perfectly - Thank you so very much!

  13. #13
    dakelly1956's Avatar
    dakelly1956 no está en línea Stack level 1
    Join Date
    Aug 2008
    Posts
    1

    worked wonderful

    Thank you, i was a little nervous about messing with the dll files but i followed your instructions and it all worked out fine for me. i had been having the problem ever since i installed 2007, i thought i was going to have to uninstall it until i found your webpage and solution. i have now added the page to my favorites.

    Thanks.

  14. #14
    redberry1973's Avatar
    redberry1973 no está en línea Stack level 1
    Join Date
    Oct 2008
    Posts
    1

    Thumbs up this worked for me too

    I own a blackberry pearl 8130 (for nearly a year now), and have received the error message "Microsoft Outlook Connector Error" - "No Message Stores" when trying to set up sync for regular Outlook (no exchange or anything) and the address book in it.

    I used the mapi fix this afternoon (as mentioned above) and it has instantly fixed my synchronization error. My contacts & calendar are totally up to date on both the blackberry & Outlook. I should note, however, I run 5 different calendars on my blackberry, and had to change the default calendar on the blackberry then run synchronization after each change to capture each calendar...but this is still quicker than manually entering almost 600 entries.

    Thanks for the tip.

    Emma

  15. #15
    tajworth's Avatar
    tajworth no está en línea Stack level 1
    Join Date
    Mar 2009
    Posts
    2

    I lost all my outlook email accounts trying the fix

    I followed the instructions to rename and add the new mapi file. Then when i tried to Open Outlook I get a message "Cannot open your defauls email folders. MAPI was unable to load the information service msncon.dll. Be sure that the service is correctly installed and configured. All my email accounts are office.live email accounts and require outlook connector to be used in microsoft outlook. I believe from what I read that there is something in ms outlook connector that is causing the sinc prob with my bbery. The funny thing is that I only have the problem sincing my PS. My lap top gives me no problems at all. Any ideas?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •