Results 1 to 7 of 7

Installed dtm 4.5 today, and now I'm getting this error when I try and install ... RIM Desktop Software forum

  1. #1
    StephenGuy's Avatar
    StephenGuy no está en línea Stack level 3
    Join Date
    Dec 2007
    PIN/ID
    30636d59
    Posts
    319

    New problem with DTM 4.5

    Advertisement



    Installed dtm 4.5 today, and now I'm getting this error when I try and install any app.



    -First thing I did was backup my phone.
    -Unplugged it.
    -Then I copy/pasted the blackberry.alx and platform.alx files to remove PTT and unlock all vendor themes from a seperate folder into the 4.5 directory (in common files).
    -Plug my phone it and it says I can update 4.5 core applications.
    -When I hit next it gives me the above error.
    -Same holds true for adding/removing any application.

    8310 AT&T
    Official 4.5

    Any help is appreciated, thanks.
    -Remember, today is the tomorrow you worried about yesterday.

  2. #2
    mjwood0's Avatar
    mjwood0 no está en línea Stack level 4
    Join Date
    Jun 2007
    PIN/ID
    Ask Me!
    Posts
    907
    When you say you copy/pasted the .alx files, did you get them from another 4.5 OS? I don't believe the 4.2.xxx files will work with 4.5.

    It really looks like somehow, you didn't get the net.rim.platform.ecmascript java file on your phone. Does it exist in your installation area or is it one of the ones you moved to get rid of PTT or vendor themes?

    Just curious!
    As always, just my opinion...
    mjwood0 (at) pinstack (.) com
    Remove PTT | OS Upgrade

  3. #3
    StephenGuy's Avatar
    StephenGuy no está en línea Stack level 3
    Join Date
    Dec 2007
    PIN/ID
    30636d59
    Posts
    319
    Oh durrr. Yeah it was from 4.2, I completely spaced that.

    But I did take a looks through the java folder and that file doesn't exist, unless I'm looking in the wrong area.

    I have a bunch of net_rim_platform_im's, then net_rim_platform_resource's

    but no net_rim_platform_ecmascript

    the 2 alx files are placed in a seperat folder so I don't believe they had something to with the deletion of that file (if that's the case).

    Hmmph.
    -Remember, today is the tomorrow you worried about yesterday.

  4. #4
    mjwood0's Avatar
    mjwood0 no está en línea Stack level 4
    Join Date
    Jun 2007
    PIN/ID
    Ask Me!
    Posts
    907
    Hmm. I just checked my Java area and I do have the file in question. Perhaps reinstall the OS files? Sounds like something got messed up in the mix.

    Good luck!
    ~via BB (wap.pinstack.com)~

  5. #5
    StephenGuy's Avatar
    StephenGuy no está en línea Stack level 3
    Join Date
    Dec 2007
    PIN/ID
    30636d59
    Posts
    319
    When I put the old alx files in the error went away. Apparently there are a lot of changes in the new OS. This has however inspired me to edit them for the new release

    Thanks for your help.
    -Remember, today is the tomorrow you worried about yesterday.

  6. #6
    mjwood0's Avatar
    mjwood0 no está en línea Stack level 4
    Join Date
    Jun 2007
    PIN/ID
    Ask Me!
    Posts
    907
    No problem! I'm fighting with this too in a way. Trying to get rid of the default pictures which come with 4.5. There is really not that much memory free after I install my necessary applications.

    I think I've almost got it sorted now!
    As always, just my opinion...
    mjwood0 (at) pinstack (.) com
    Remove PTT | OS Upgrade

  7. #7
    StephenGuy's Avatar
    StephenGuy no está en línea Stack level 3
    Join Date
    Dec 2007
    PIN/ID
    30636d59
    Posts
    319
    Glad to hear. New alx files are posted
    -Remember, today is the tomorrow you worried about yesterday.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •