Results 1 to 10 of 10

I don't like the sound of this. 8100 had a white screen. Did a battery ... BlackBerry Pearl forum

  1. #1
    richmo58's Avatar
    richmo58 no está en línea Stack level 3
    Join Date
    May 2007
    Posts
    150

    White screen...then nothing

    Advertisement



    I don't like the sound of this.

    8100 had a white screen. Did a battery pull; now it won't do anything and is acting totally dead. No LED, no screen activity, nothing. Desktop Manager and computer do not recognize it. It was working fine until the screen went white.

    Any suggestions?

  2. #2
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    Rich,

    You might try these instructions or, it not that, these instructions. I don't have experience with this problem but these are procedures to get you out of it and back in business. Good luck.
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  3. #3
    richmo58's Avatar
    richmo58 no está en línea Stack level 3
    Join Date
    May 2007
    Posts
    150
    Thanks for the suggestions. Unfortunately, its totally dead. DM doesn't recognize it at all.

  4. #4
    moderncowboy's Avatar
    moderncowboy no está en línea Stack Moderator
    Join Date
    May 2008
    PIN/ID
    AskMe
    Posts
    7,297
    Do you have a blinking red light or anything along with the white screen?

  5. #5
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    If you take the battery out and then connect to the p-c do you get any sign of life?
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  6. #6
    Lavagirl's Avatar
    Lavagirl no está en línea PINStacked!
    Join Date
    May 2007
    PIN/ID
    AoleLava
    Posts
    10,877
    How new is this device? Still under warranty?

    I had this happen with my first 8100 ~ we call it WSOD (white screen of death).
    When I had the issue I was able to get DM to recognize it, but not able to ever get
    the screen to work.

    The only thing I could do, and fortunately I was still under my 30 day warranty return period - was to return it for a replacement BB.

    Check out This thread for more info on the issue. Good luck!

  7. #7
    moderncowboy's Avatar
    moderncowboy no está en línea Stack Moderator
    Join Date
    May 2008
    PIN/ID
    AskMe
    Posts
    7,297
    Quote Originally Posted by Lavagirl View Post
    How new is this device? Still under warranty?

    I had this happen with my first 8100 ~ we call it WSOD (white screen of death).
    When I had the issue I was able to get DM to recognize it, but not able to ever get
    the screen to work.

    The only thing I could do, and fortunately I was still under my 30 day warranty return period - was to return it for a replacement BB.

    Check out This thread for more info on the issue. Good luck!
    Thanks,Lava. I was trying to trouble shot but if you have experienced this and found no solution other than a replacement then I am sure that is the only choice. That's to bad.

  8. #8
    Lavagirl's Avatar
    Lavagirl no está en línea PINStacked!
    Join Date
    May 2007
    PIN/ID
    AoleLava
    Posts
    10,877
    This is the issue that first brought me to PS

    I spent days and days troubleshooting it.... cherri helped me. It's the first issue
    with a new Stacker (me) that she couldn't resolve.
    We talked about this in my first PS cast.

    It became a known issue on the forums and started occurring with the 81xx series quite frequently
    and I believe was due to some sort of defect in the production of the lcd/connection.

  9. #9
    richmo58's Avatar
    richmo58 no está en línea Stack level 3
    Join Date
    May 2007
    Posts
    150
    No, its showing no sign of life..no led or anything.

    I'm not going to sweat it too much. I upgraded myself to an 8900 recently and passed my old 8100 along. Its about 2 years old now and that line is still eligible for a new phone with a 2 yr extension, so that well may be what happens. I was just surprised that it completely failed like that.

  10. #10
    richmo58's Avatar
    richmo58 no está en línea Stack level 3
    Join Date
    May 2007
    Posts
    150
    Its not looking good...

    I charged it overnight, still nothing. Tried to connect to computer with USB, with and without the battery, still no sign of life. Of course, the Desktop Manager (nor Windows) will recognize it. I even borrowed the battery from someone's Pearl this morning to see if that would work. Still nothing.

    Also tried removing SD and SIM cards with the same result.

    The Pearl wasn't dropped or immersed in water or anything like that. Just looked at it last night. Screen was white and keys were backlit. My instinct was to pull the battery and reset it. No sign of life since.

    I appreciate your ideas so far, but its hard to do anything with it with no sign of life. If you have any other ideas, please let me know.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •