Results 1 to 12 of 12

[FONT=Arial] Hi, everybody! I have found a solution to the Opera mini browser giving the ... BlackBerry Pearl forum

  1. #1
    Attila123's Avatar
    Attila123 no está en línea Stack level 1
    Join Date
    Jan 2007
    Posts
    1

    Solution/Opera Mini/Blackberry/Failed to connect

    Advertisement



    [FONT=Arial]Hi, everybody!

    I have found a solution to the Opera mini browser giving the error of: "Failed to connect to the internet."
    I, too, started having that same problem yesterday, after the Opera mini browser was working just fine previously. I deleted and readded the APN of wap.voicestream.com, deleted and redownloaded Opera Mini, all to no avail. I even disabled the firewall, reset the settings for it as well, with no result.
    Then, it hit me: Why not look at the error log to try to find out why the browser isn't connecting. So, on my Blackberry Pearl I held down Shift (the key with the arrows on it), and while holding it down, I pressed L G L G, which brought up the error log, and in the log I found the following:

    Name: IOException
    GUID: 9c3cd62e3320b498
    Time: Jan 24, 2007 11:16:47
    Max connections opened.
    operette$2dhifi$2dus

    "Aha!", I thought. So, it's not connecting, because apparently there are too many concurrent connections open. So, how do I close them? Well, on my Pearl I went to: Options > Security Options > Firewall > hit the Menu key next to the green Dial key, then selected "Edit Default Permissions".

    Now, once you're on that screen, you'll see "Custom" next to where it says Connections. So, I highlighted "Custom", pressed down on the trackball and chose "Deny", which will change all the permissions under Connections to Deny. Now, after you hit the back key, it will of course ask you whether or not you'd like to save the changes. Once you hit Yes, it will ask you to "reset" your device. Don't worry, it's not a master clear, it doesn't wipe the handheld, nothing is lost. The device will restart. Once it's restarted, go back to Options > Security Options > Firewall > hit the Menu key next to the green Dial key, then selected "Edit Default Permissions", and now all connections need to be reset to the way they were before:

    Connections: Allow (will automatically change to Custom once any of the options below are changed)
    USB: Allow
    Bluetooth: Allow
    Phone: Prompt
    Location (GPS): Allow
    Company Network: Prompt
    Carrier Internet: Prompt

    (Please note: After you select "Allow" for Connections, and change any of the ones below it, Allow for Connections will change to "Custom")

    Once that's done, hit the back key and save. Try connecting via Opera Mini again, and it should work. It worked for me.

    Now, I don't exactly know what caused the connections opened by Opera Mini to not be closed after a session. I would be in a current browsing session, and if I would want to exit, I'd hit the Menu key and select Close. Maybe by doing so, it doesn't close the current connection. So, from now on, I'll try to select Menu from the options in the browser, and then Exit, so see if that makes a difference. I don't think it will, because when I exit my Blackberry browser, I see the two arrows in the upper right hand corner of the screen flashing, which most likely indicates that the connection is being terminated. Now, when I close the Opera Mini browser, I don't see any errors. So, we may need to follow the steps I outlined above every so often. Which is not a big deal to me, to be honest with you. I love Opera Mini. It seems like it just needs to be maintained a little differently than the BB browser. It's just like doing an oil change on a car. No big deal.

    You all have a wonderful day, and enjoy your Blackberry!

    Attila

    [/FONT]

  2. #2
    dasupaman23's Avatar
    dasupaman23 no está en línea Stack level 6
    Join Date
    Nov 2005
    Posts
    2,362

    Re: Solution/Opera Mini/Blackberry/Failed to connect

    Glad to know. I was having problems with it yesterday. Not getting thru the verification steps. But When I tried this morning it was working (faster than the built in browser too!) and I didn't even change or mess with any settings. Glad to have these steps just in case it doesn't work next time.

  3. #3
    peterbabiy's Avatar
    peterbabiy no está en línea Stack level 5
    Join Date
    Dec 2006
    PIN/ID
    23DE41AA
    Posts
    1,926

    Re: Solution/Opera Mini/Blackberry/Failed to connect

    Attila, Thanks so much for the info and your time

    Glad to have you here, Welcome

  4. #4
    Blukrystlz's Avatar
    Blukrystlz no está en línea Stack level 8
    Join Date
    Oct 2006
    PIN/ID
    Askme4it
    Posts
    5,250
    Thanx for the info!

  5. #5
    stormyone's Avatar
    stormyone no está en línea Stack level 2
    Join Date
    Oct 2006
    Posts
    63

    Re: Solution/Opera Mini/Blackberry/Failed to connect

    Quote Originally Posted by Attila123
    [FONT=Arial]Hi, everybody!

    I have found a solution to the Opera mini browser giving the error of: "Failed to connect to the internet."
    I, too, started having that same problem yesterday, after the Opera mini browser was working just fine previously. I deleted and readded the APN of wap.voicestream.com, deleted and redownloaded Opera Mini, all to no avail. I even disabled the firewall, reset the settings for it as well, with no result.
    Then, it hit me: Why not look at the error log to try to find out why the browser isn't connecting. So, on my Blackberry Pearl I held down Shift (the key with the arrows on it), and while holding it down, I pressed L G L G, which brought up the error log, and in the log I found the following:

    Name: IOException
    GUID: 9c3cd62e3320b498
    Time: Jan 24, 2007 11:16:47
    Max connections opened.
    operette$2dhifi$2dus

    "Aha!", I thought. So, it's not connecting, because apparently there are too many concurrent connections open. So, how do I close them? Well, on my Pearl I went to: Options > Security Options > Firewall > hit the Menu key next to the green Dial key, then selected "Edit Default Permissions".

    Now, once you're on that screen, you'll see "Custom" next to where it says Connections. So, I highlighted "Custom", pressed down on the trackball and chose "Deny", which will change all the permissions under Connections to Deny. Now, after you hit the back key, it will of course ask you whether or not you'd like to save the changes. Once you hit Yes, it will ask you to "reset" your device. Don't worry, it's not a master clear, it doesn't wipe the handheld, nothing is lost. The device will restart. Once it's restarted, go back to Options > Security Options > Firewall > hit the Menu key next to the green Dial key, then selected "Edit Default Permissions", and now all connections need to be reset to the way they were before:

    Connections: Allow (will automatically change to Custom once any of the options below are changed)
    USB: Allow
    Bluetooth: Allow
    Phone: Prompt
    Location (GPS): Allow
    Company Network: Prompt
    Carrier Internet: Prompt

    (Please note: After you select "Allow" for Connections, and change any of the ones below it, Allow for Connections will change to "Custom")

    Once that's done, hit the back key and save. Try connecting via Opera Mini again, and it should work. It worked for me.

    Now, I don't exactly know what caused the connections opened by Opera Mini to not be closed after a session. I would be in a current browsing session, and if I would want to exit, I'd hit the Menu key and select Close. Maybe by doing so, it doesn't close the current connection. So, from now on, I'll try to select Menu from the options in the browser, and then Exit, so see if that makes a difference. I don't think it will, because when I exit my Blackberry browser, I see the two arrows in the upper right hand corner of the screen flashing, which most likely indicates that the connection is being terminated. Now, when I close the Opera Mini browser, I don't see any errors. So, we may need to follow the steps I outlined above every so often. Which is not a big deal to me, to be honest with you. I love Opera Mini. It seems like it just needs to be maintained a little differently than the BB browser. It's just like doing an oil change on a car. No big deal.

    You all have a wonderful day, and enjoy your Blackberry!

    Attila

    [/FONT]
    tried it... didnt work for me.... oh well...

  6. #6
    tjahir's Avatar
    tjahir no está en línea Stack level 1
    Join Date
    Aug 2008
    Posts
    1

    Unlocked Blackberry 8320 Opera Mini Error

    Hey there.

    I'm a little new to these forums and new to the blackberry. Recently I purchased an unlocked blackberry 8320. It was originally with tmobile, but now I have my FIDO sim in there. I downloaded opera mini and installed it on my BB. Yesterday it was working fine, but since I got to school today, its been giving me the following error: "failed to connect to the internet". Now I checked out some forums and it said something about TCP or APN values. I'm not sure whether to use the fido, or the tmobile. Can someone please help me fix this. Thanks!

    Tanveer Jahir

  7. #7
    yeswap's Avatar
    yeswap no está en línea Stack level 1
    Join Date
    Oct 2008
    Posts
    2
    Quote Originally Posted by Attila123 View Post
    [FONT=Arial]... it's not connecting, because apparently there are too many concurrent connections open. So, how do I close them? Well, on my Pearl I went to: Options > Security Options > Firewall > hit the Menu key next to the green Dial key, then selected "Edit Default Permissions".

    Now, once you're on that screen, you'll see "Custom" next to where it says Connections. So, I highlighted "Custom", pressed down on the trackball and chose "Deny", which will change all the permissions under Connections to Deny. Now, after you hit the back key, it will of course ask you whether or not you'd like to save the changes. Once you hit Yes, it will ask you to "reset" your device. Don't worry, it's not a master clear, it doesn't wipe the handheld, nothing is lost. The device will restart. Once it's restarted, go back to Options > Security Options > Firewall > hit the Menu key next to the green Dial key, then selected "Edit Default Permissions", and now all connections need to be reset to the way they were before:

    Connections: Allow (will automatically change to Custom once any of the options below are changed)
    USB: Allow
    Bluetooth: Allow
    Phone: Prompt
    Location (GPS): Allow
    Company Network: Prompt
    Carrier Internet: Prompt

    (Please note: After you select "Allow" for Connections, and change any of the ones below it, Allow for Connections will change to "Custom")

    Once that's done, hit the back key and save. Try connecting via Opera Mini again, and it should work. It worked for me.

    Now, I don't exactly know what caused the connections opened by Opera Mini to not be closed after a session. I would be in a current browsing session, and if I would want to exit, I'd hit the Menu key and select Close. Maybe by doing so, it doesn't close the current connection. So, from now on, I'll try to select Menu from the options in the browser, and then Exit, so see if that makes a difference. I don't think it will, because when I exit my Blackberry browser, I see the two arrows in the upper right hand corner of the screen flashing, which most likely indicates that the connection is being terminated. Now, when I close the Opera Mini browser, I don't see any errors. So, we may need to follow the steps I outlined above every so often. Which is not a big deal to me, to be honest with you. I love Opera Mini. It seems like it just needs to be maintained a little differently than the BB browser. It's just like doing an oil change on a car. No big deal.

    You all have a wonderful day, and enjoy your Blackberry!

    Attila

    [/FONT]
    An easier way to close all connections, reset the device and get Opera Mini working again is to remove the battery, wait 10 seconds and replace the battery. It seems to have the same effect as changing the default connection settings plus you don't have to set them back.

    Unfortunately, both Attila123's method and the battery pull take forever, something like two minutes on my 7100i.

    There's got to be a faster way to close the connections. You would think toggling the radio on an off would do it but it doesn't seem to help when Opera Mini stops connecting.

  8. #8
    bill16's Avatar
    bill16 no está en línea Stack level 3
    Join Date
    Mar 2009
    PIN/ID
    sorry no
    Posts
    418
    Have you tried going to manage connections on your menu screen,click, then click (turn off all connections) for minute or so then click the (connections back on)?
    ~via smartphone mobile.pinstack.com~

  9. #9
    bill16's Avatar
    bill16 no está en línea Stack level 3
    Join Date
    Mar 2009
    PIN/ID
    sorry no
    Posts
    418
    Mind you that's not a reboot.It'll cut your connection.A battery pull or an app like Quick pull or soft reset will reboot.Just thought I better clarify my statement.
    ~via smartphone mobile.pinstack.com~

  10. #10
    yeswap's Avatar
    yeswap no está en línea Stack level 1
    Join Date
    Oct 2008
    Posts
    2
    Quote Originally Posted by bill16 View Post
    Have you tried going to manage connections on your menu screen,click, then click (turn off all connections) for minute or so then click the (connections back on)?
    ~via smartphone mobile.pinstack.com~
    I don't see an icon labeled "Manage Connections" on my 7100i's home screen. I have "Turn Wireless Off" and "Turn Bluetooth Off". I tried turning wireless off and back on and Opera Mini still would not connect until I did a battery pull. I didn't wait a minute before turning it back on, just until the connection status indicator turned to "x". I'll try waiting longer next time OM stops working

  11. #11
    bill16's Avatar
    bill16 no está en línea Stack level 3
    Join Date
    Mar 2009
    PIN/ID
    sorry no
    Posts
    418
    Quote Originally Posted by yeswap View Post
    I don't see an icon labeled "Manage Connections" on my 7100i's home screen. I have "Turn Wireless Off" and "Turn Bluetooth Off". I tried turning wireless off and back on and Opera Mini still would not connect until I did a battery pull. I didn't wait a minute before turning it back on, just until the connection status indicator turned to "x". I'll try waiting longer next time OM stops working
    That might make a difference, but from what you describe I doubt it.I think I'd just use the soft reset app or Quick pull and reboot now and then so to try to prevent the problem.Too bad the wireless disconnect didn't work as a quick solution.But rebooting is a blackberry unavoidable maintenance necessity I afraid.
    ~via smartphone mobile.pinstack.com~

  12. #12
    swingsingh's Avatar
    swingsingh no está en línea Stack level 1
    Join Date
    Apr 2009
    Posts
    2

    http://my.opera.com/community/forums/topic.dml?id=272450

    Attila,
    Please see the link below. I am having the same problem that you had with your BB.
    I did what you did and still no use.
    Please help!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •