Results 1 to 4 of 4

Well I recently got a text from T-Mobile saying there was a new software upgrade ... BlackBerry Pearl forum

  1. #1
    Optimus's Avatar
    Optimus no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    203

    Software upgrade confusion

    Advertisement



    Well I recently got a text from T-Mobile saying there was a new software upgrade for my pearl. I go to the site and there is nothing new about it. it's the current one I have. I then go to the RIM site and they have several upgrades for version 4.2 which includes service packs 1, 2....their latest is version 4.3. which T-mobile doesn't even have listed. I tried going through pinstack, but their link takes me back to the T-mobile site.

    Basically i want to know which version I should have? T-mobile has a tendency to be behind on most downloads so I'm not sure if i should go from their site (even though I've been getting bad reception, and dropped calls as of late).

    Should I go with ver. 4.3? or any of the service packs for 4.2? either one seems like a better upgrade to me since the one I currently have was released last summer...I hope someone can shed some light on this, thanks.

  2. #2
    jmbhbb's Avatar
    jmbhbb no está en línea Stack level 2
    Join Date
    Jan 2008
    PIN/ID
    ask
    Posts
    26
    It sounds like the upgrades on RIM's website you are talking about are for the Desktop Manager. Most current of that is 4.3

    The most current software version for the Pearl is for 4.2.xxx, depending on the carrier. Check the list at the top of this forum (8100 and 8110 discussion) for the most current for your provider

  3. #3
    Optimus's Avatar
    Optimus no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    203
    well, thanks cause evidently I do have the old desktop manager....i guess an update for the device isn't out yet, although t-mobile sent a text saying there is.

  4. #4
    scoope's Avatar
    scoope no está en línea Stack level 2
    Join Date
    May 2007
    Posts
    51
    I think it was in relation to DST and making sure everyone had the updated patch. I got that notice but I am running the most current software.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •