Results 1 to 11 of 11

Hi, I have had by first BB device for a week now and love it!. ... BlackBerry Pearl forum

  1. #1
    adamwilko007's Avatar
    adamwilko007 no está en línea Stack level 1
    Join Date
    Oct 2006
    Posts
    3

    Question SMS not showing contact names

    Advertisement



    Hi,

    I have had by first BB device for a week now and love it!. However, when certain people in my phone book send me a text (SMS) the number is displayed instead of the name. This does not happen for all of my contact? Has anyone else experienced this and is there a fix?

    Thanks in advance.

    Adam.

  2. #2
    trigga15's Avatar
    trigga15 no está en línea Stack level 5
    Join Date
    Aug 2006
    PIN/ID
    21655FFB
    Posts
    925

    Re: SMS not showing contact names

    ~via BB (wap.pinstack.com)~possibly they aren't in your phone book? Maybe you never got them off your sim? Sounds like a weird thing

  3. #3
    trigga15's Avatar
    trigga15 no está en línea Stack level 5
    Join Date
    Aug 2006
    PIN/ID
    21655FFB
    Posts
    925

    Re: SMS not showing contact names

    ~via BB (wap.pinstack.com)~i just looked go to messages>general options>show names and see if that's the problem

  4. #4
    cp6169's Avatar
    cp6169 no está en línea Device Pro
    Join Date
    Mar 2006
    PIN/ID
    3056468b
    Posts
    14,661

  5. #5
    adamwilko007's Avatar
    adamwilko007 no está en línea Stack level 1
    Join Date
    Oct 2006
    Posts
    3

    Re: SMS not showing contact names

    Hi - Thanks to all for the replies - especially trgga15 as his suggestion about the contacts being on the SIM led me to the solution. I went to address book and chose to load SIM contacts (which I thought I remembered doing when setting the device up). Anyway, this did the trick!

    Great site, keep up the good work!

  6. #6
    Pearl Handle's Avatar
    Pearl Handle no está en línea Stack level 1
    Join Date
    Apr 2007
    Posts
    12

    Re: SMS not showing contact names

    Hi, I'm new to the pearl too and I had this problem. It turned out that most of my numbers didn't have the country code in front of them, in my case +44. The number which had this prefix were recognised but the ones that didn't were not even though they dialled correctly. I have been adding +44 to each number as and when I get the chance.
    Hope this helps.
    PH

  7. #7
    avante's Avatar
    avante no está en línea Stack level 4
    Join Date
    Mar 2007
    PIN/ID
    2405C4B1
    Posts
    638

    Re: SMS not showing contact names

    I still can't get my pearl to recognize one of the names that is one of MY Faves. Her number only comes up when she texts. When she calls her name, pic and ringtone come up. Any thoughts or suggestions? The numbers all match, in the addy book, in the sms inbox and in her actual My Fave menu..........

  8. #8
    jonr's Avatar
    jonr no está en línea Stack level 1
    Join Date
    Apr 2007
    PIN/ID
    25043FAE
    Posts
    7

    Re: SMS not showing contact names

    same issue here, when someone calls it comes up as 07890 and when they text if comes up as +447890 so the BB will only show the name stored for the number lol

    I have saved 2 numbers under each one, with +44 and one with out. thats the only way i can see to get around it?

  9. #9
    gazar's Avatar
    gazar no está en línea Stack level 5
    Join Date
    Jan 2007
    Posts
    1,203

    Re: SMS not showing contact names

    You could try this thread to save you inputting +44 to numbers individually.

    http://blackberryforums.pinstack.com...tml#post108693

  10. #10
    jonr's Avatar
    jonr no está en línea Stack level 1
    Join Date
    Apr 2007
    PIN/ID
    25043FAE
    Posts
    7

    Re: SMS not showing contact names

    thanks alot guys, it works like it should do now

  11. #11
    avante's Avatar
    avante no está en línea Stack level 4
    Join Date
    Mar 2007
    PIN/ID
    2405C4B1
    Posts
    638

    Re: SMS not showing contact names

    Geez, it still isn't working for me how it should for me. I have noticed that it only doesn't work with my Faves. It works correctly with others. I am using the new 1.66 TIM OS. Anyone else have any thoughts?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •