The latest version of Mapquest requires at least that the os be 4.2 or above. If your version is older than that, you'll need to first update your os then re-download MN