Results 1 to 4 of 4

Hey all! I noticed that my emails seemed to arrive pretty much instantly from my ... BlackBerry Pearl forum

  1. #1
    int2str's Avatar
    int2str no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    21

    Thumbs up IMAP IDLE works! 4.5 upgrade or BIS upgrade to blame?

    Advertisement



    Hey all!

    I noticed that my emails seemed to arrive pretty much instantly from my personal IMAP account. First I though, no way... Then I checked the mail server logs and low and behold - the Blackberry service (not my phone, the RIM servers) is connected via IMAP IDLE! The result? Push email from an IMAP account!

    Sweet!!!

    Now, I've asked a while ago if IMAP IDLE was supported:
    http://blackberryforums.pinstack.com...ad.php?t=41678

    The answer back then was simply "No".

    What has changed since then?

    I upgraded to the 4.5 device software last week. I'm not sure if that made the difference, or if RIM changed their BIS software or policies.

    Does anybody know?

    I'm incredibly happy about this! When I first got my BB, I was sorely disappointed that IMAP IDLE didn't work!

    Thank you RIM!

  2. #2
    snipes mcgee's Avatar
    snipes mcgee no está en línea Stack level 4
    Join Date
    Apr 2008
    Posts
    555
    I think it comes from a recent minor update, because I've had OS 4.5 since about June and always noticed a delay, even after the 2.5 BIS update. But for the past couple of weeks my BB has been getting my email at least a minute before my laptop even picks it up.
    I have a BlackBerry and a WhiteApple. :)

  3. #3
    int2str's Avatar
    int2str no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    21
    You should use a mail client that supports IMAP IDLE on your laptop

  4. #4
    mikedoan's Avatar
    mikedoan no está en línea Stack level 3
    Join Date
    May 2008
    Posts
    179
    I also have been using 4.5 for sometime now and had tried to use IMAP and didn't work.

    I noticed after having read about it in the forums that my POP accounts had been converted automatically to IMAP.

    One point of interest, I have three separate accounts besides my BIS handset account that are associated with my BB. Of those one is an exchange account the the other two are POP (or now IMAP).

    With the exchange account, I had previously setup (as per one of the posts in Pinstack) a forwarder on that account to my BB account. The handset generally received the email imediately. Now using IMAP, it takes up to eight minutes for the mail to reach my handset.

    ~via BB (wap.pinstack.com)~

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •