Results 1 to 12 of 12

I had to go back to an 8120. The lagging on the 8220 was just ... BlackBerry Pearl forum

  1. #1
    li2327's Avatar
    li2327 no está en línea Stack level 5
    Join Date
    Jun 2006
    PIN/ID
    30D2E555
    Posts
    1,502

    Had to give up my 8220

    Advertisement



    I had to go back to an 8120. The lagging on the 8220 was just too much to deal with. I'm not sure if I just had a bad handset or its just the 4.6 os, but I couldn't take it anymore. Besides that. Pinstack looked horrible on my 8220. I think I made the right decision for me. Good luck to all the 8220. I really hope you have better luck than me.
    ]

  2. #2
    archer6's Avatar
    archer6 no está en línea Stack level 8
    Join Date
    Oct 2006
    Posts
    4,996
    Quote Originally Posted by li2327 View Post
    I had to go back to an 8120. The lagging on the 8220 was just too much to deal with.
    .
    My experience with my 8220 has been very good. Since I have every BlackBerry currently available I have several to compare it to and its actually faster than my 8110 or 8120. The SureType system is better & much faster as RIM upgraded the software & it has a much larger keyboard. I'm sorry to hear you had issues.
    .
    sent via BlackBerry

  3. #3
    li2327's Avatar
    li2327 no está en línea Stack level 5
    Join Date
    Jun 2006
    PIN/ID
    30D2E555
    Posts
    1,502
    I'm glad its working out well for you. Who knows what the future holds. I may try it again at another time. ~via BB (wap.pinstack.com)~

  4. #4
    Join Date
    Mar 2008
    PIN/ID
    LESS
    Posts
    1,757
    Thats so sad to hear.

  5. #5
    archer6's Avatar
    archer6 no está en línea Stack level 8
    Join Date
    Oct 2006
    Posts
    4,996
    Quote Originally Posted by li2327 View Post
    I'm glad its working out well for you. Who knows what the future holds. I may try it again at another time. ~via BB (wap.pinstack.com)~
    .
    I'm surprised your carrier didn't offer you a replacement my first Curve 8300 was defective & they took it back (@ store) and gave me a brand new one from their inventory, set it up in the store then handed it to me to test so that I would be satisfied. Did they not offer that to you?
    sent via BlackBerry

  6. #6
    Join Date
    Mar 2008
    PIN/ID
    LESS
    Posts
    1,757
    Shows a lack of customer service in part of that store you purchased it from. If it was bought from me I would have done exactly what the rep did for Archer.

  7. #7
    NOID's Avatar
    NOID no está en línea Stack level 3
    Join Date
    Aug 2007
    PIN/ID
    2423EC62
    Posts
    194
    My 8220 has started to lag less and less everyday

  8. #8
    dargewrd's Avatar
    dargewrd no está en línea Stack level 2
    Join Date
    Feb 2007
    Posts
    57
    Hmm hope u went to settings enable java script etc for internet settings
    Ryan

  9. #9
    jhall1986's Avatar
    jhall1986 no está en línea Stack level 3
    Join Date
    May 2007
    Posts
    300
    My 8220 is running nice and smooth. The only lag i had is when i first booted it up other than that it runs good. Ive also got a lot attention at my job. Love my 8220

  10. #10
    mac14x's Avatar
    mac14x no está en línea Stack level 4
    Join Date
    Oct 2007
    PIN/ID
    217a1629
    Posts
    731
    I use mine only for texting and calling tmo to tmo, But even when im txting or trying to dial a phone its lagging
    ~90 people get the swine flu and everyone is wearing face masks. Millions of people have AIDS but no one wears condoms...



  11. #11
    HeavyComponent's Avatar
    HeavyComponent no está en línea Stack level 6
    Join Date
    Feb 2008
    PIN/ID
    TP2 :D
    Posts
    2,557
    I just ordered my 8220 not to long ago. I hope I don't have any problems with it.

    ---
    T-Mobile Curve 8320 - 4.5.0.81 OS!
    [heavycomponent@tmo.blackberry.net]

    --HeavyC.


    ~via BB (wap.pinstack.com)~

  12. #12
    zantopad's Avatar
    zantopad no está en línea Stack level 3
    Join Date
    Dec 2007
    Posts
    157
    I haven't had any issues with lagging, only a little lag at first boot up like jhall mentioned... After that it is as smooth as my 8320 was.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •