Page 1 of 2 12 LastLast
Results 1 to 15 of 25

I have a privacy block on my cellular number done via Cingular so that by ... BlackBerry Pearl forum

  1. #1
    karmalaw's Avatar
    karmalaw no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    19

    Caller ID & *82 Dialing Problem

    Advertisement



    I have a privacy block on my cellular number done via Cingular so that by default my cell number is NOT transmitted when I call someone. I do not want to remove this feature (it keeps insane people from calling me at 2:00 a.m.)

    But, to enable the transmission of my number when I dial someone in my address book -- I have to dial *82 before the number.. so I save all my numbers with the *82..

    Now here's the problem: because the numbers are saved with the *82 immediately in front of the number, the BB does not recognize the number when the person calls in -- so NONE of my calls are coming through with caller ID. It's driving me insane.

    I've manually added the numbers without the *82 as an additional number for some of my contacts.. but I have hundreds of contacts and don't want to have to do it for all of them.

    Is there some setting I can use or something I can do so that the Caller ID works?

    P.s. most of the numbers were transferred to the phone with my SIM card from my old Nokia 6230 phone.
    Last edited by karmalaw; 05-24-2007 at 04:23 PM.

  2. #2
    ktorres1120's Avatar
    ktorres1120 no está en línea Stack level 4
    Join Date
    Sep 2006
    Posts
    505

    Re: Caller ID & *82 Dialing Problem

    Have you already tried, while in the Phone function, Options > General Options > Restrict My Identity "ON" ? This should work.

  3. #3
    karmalaw's Avatar
    karmalaw no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    19

    Re: Caller ID & *82 Dialing Problem

    my identity is already restricted via the cingular network .. more foolproof than a phone-based restriction (and until Cingular allows blocked calls -- I prefer staying restricted). I'm not having issues with the restriction -- my problem is that the BB is no recognizing the incoming calls as belonging to someone already in my address book.

  4. #4
    reddog187's Avatar
    reddog187 no está en línea Stack Moderator
    Join Date
    Dec 2006
    PIN/ID
    STACK
    Posts
    8,907

    Re: Caller ID & *82 Dialing Problem

    Quote Originally Posted by ktorres1120
    Have you already tried, while in the Phone function, Options > General Options > Restrict My Identity "ON" ? This should work.
    Ktorress1120 that's not his problem...he wants his caller ID to work.

    Unfortunatly, I don't think you can have a work around this. I mean, what you could do is have AT&T turn that option off and then turn on your phone restrict idenity. Then remove all the *82 from the phone numbers. That would help on the caller ID function, but then I don't know how you would get your identity through to the people you want to.

    Hope this helps a little.

  5. #5
    SokudoBlade's Avatar
    SokudoBlade no está en línea Stack level 3
    Join Date
    May 2007
    Posts
    197

    Re: Caller ID & *82 Dialing Problem

    My bad i mis read the issue, i was thinking *82 is blocking your #.. im a lil tired today lol.

    I think the only way for certain people to see your # is to have the *82 infront of their #.

    Now when they call you to make sure that you see their name and not the #, you would have to add their number without *82 in your contact as a diff number like mobile2 or home2. But thats going to take alot of time for you to add the second version of the #. But in the end i think thats the easiest way to solve your problem but the most time consuming,
    at&t Retail Sales Consultant Whitehall, PA. Data SME.

  6. #6
    reddog187's Avatar
    reddog187 no está en línea Stack Moderator
    Join Date
    Dec 2006
    PIN/ID
    STACK
    Posts
    8,907

    Re: Caller ID & *82 Dialing Problem

    Quote Originally Posted by SokudoBlade
    My bad i mis read the issue, i was thinking *82 is blocking your #.. im a lil tired today lol.

    I think the only way for certain people to see your # is to have the *82 infront of their #.

    Now when they call you to make sure that you see their name and not the #, you would have to add their number without *82 in your contact as a diff number like mobile2 or home2. But thats going to take alot of time for you to add the second version of the #. But in the end i think thats the easiest way to solve your problem but the most time consuming,
    Oh Nice thinking! didn't even occur to me! Yea nice work around. Have 2 numbers for each...Brilliant!!!

  7. #7
    teleberry's Avatar
    teleberry no está en línea Stack level 3
    Join Date
    Apr 2007
    PIN/ID
    23F8AB7F
    Posts
    92

    Re: Caller ID & *82 Dialing Problem

    Isn't there a similar number, like *67 that blocks individual calls you make? Unless you need your phone blocked all the time, try removing the call blocking feature and try to remember to block outgoing calls to potential threats individually. I am a physician and need my number block on those rare occasions that I am using my personal cell phone to call difficult patients. I used to have general blocking and unblock all my friends like you do, but now, with the bb it is easier to go into the options and turn on "restrict identity" just for those calls. I would use the *67 or whatever if I could remember what that code is for tmo.

  8. #8
    karmalaw's Avatar
    karmalaw no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    19

    Re: Caller ID & *82 Dialing Problem

    you would have to add their number without *82 in your contact as a diff number like mobile2 or home2. But thats going to take alot of time for you to add the second version of the #.
    exactly -- that's what I said in my initial post -- I know that work around but was hoping not to do it for close about 300 contacts... yikes.

    And, of course, turning off the restriction and going back to remove the *82 for 300 or so contacts is really the same amount of work -- so there's no benefit.

    for whatever it's worth my Nokia readily understood that the *82xxxxxxxxxx number in the address book was the same as the xxxxxxxxxx number dialed in to me.

    Yes, I need the restriction on all the time -- *67 does not work with certain other carriers -- meaning I dial *67 but they get to see my number anyway. been there, done that -- hate that.

    p.s. I'm no "he" (unless you know something I don't know). :-P

  9. #9
    reddog187's Avatar
    reddog187 no está en línea Stack Moderator
    Join Date
    Dec 2006
    PIN/ID
    STACK
    Posts
    8,907

    Re: Caller ID & *82 Dialing Problem

    oops my bad.

  10. #10
    I7oobie's Avatar
    I7oobie no está en línea Device Pro
    Join Date
    May 2006
    Posts
    3,563

    Re: Caller ID & *82 Dialing Problem

    ~via BB (wap.pinstack.com)~
    When dialing a number strait from the keyboard, you can hit a menu, and insert a pause. Is there a way to do the with numbers in the addy book?

  11. #11
    mikadad's Avatar
    mikadad no está en línea Stack level 5
    Join Date
    Nov 2006
    PIN/ID
    just ask
    Posts
    1,159

    Re: Caller ID & *82 Dialing Problem

    when adding the number to your addy book, click the thumbwheel and there will be the option to add pause or add wait...
    Michael


  12. #12
    reddog187's Avatar
    reddog187 no está en línea Stack Moderator
    Join Date
    Dec 2006
    PIN/ID
    STACK
    Posts
    8,907

    Re: Caller ID & *82 Dialing Problem

    Yea you can do it in the address book...I'm not sure it will help. Will the pearl still recognize the *82 when a call comes in? It's worth a try.

  13. #13
    I7oobie's Avatar
    I7oobie no está en línea Device Pro
    Join Date
    May 2006
    Posts
    3,563

    Re: Caller ID & *82 Dialing Problem

    ~via BB (wap.pinstack.com)~
    Why would you need it when a call comes in? It would only be for placing a call... I'll try to dig into it...

  14. #14
    reddog187's Avatar
    reddog187 no está en línea Stack Moderator
    Join Date
    Dec 2006
    PIN/ID
    STACK
    Posts
    8,907

    Re: Caller ID & *82 Dialing Problem

    For the Caller ID. Karmalaw wants to be able to have the Caller ID to show the caller. If the *82 is there doesn't recognize the caller. So if there is the *82 with (pause) will it still recognize the number?

  15. #15
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164

    Re: Caller ID & *82 Dialing Problem

    Quote Originally Posted by karmalaw
    exactly -- that's what I said in my initial post -- I know that work around but was hoping not to do it for close about 300 contacts... yikes.

    And, of course, turning off the restriction and going back to remove the *82 for 300 or so contacts is really the same amount of work -- so there's no benefit.

    for whatever it's worth my Nokia readily understood that the *82xxxxxxxxxx number in the address book was the same as the xxxxxxxxxx number dialed in to me.

    Yes, I need the restriction on all the time -- *67 does not work with certain other carriers -- meaning I dial *67 but they get to see my number anyway. been there, done that -- hate that.

    p.s. I'm no "he" (unless you know something I don't know). :-P
    i think everyone defaults to 'he'...i was called he/him/dude/man when i first started posting

    seriously tho...the restrict my identity should work for you just fine. i understand the 'want' to have more added security, but seriously how many people are you calling that you don't want them to have the number?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •