Results 1 to 5 of 5

Merry Christmas everyone, My Cingular-branded, unlocked Pearl (using AT&T old "blue" sim card) has completely ... BlackBerry Pearl forum

  1. #1
    ir_dizzle's Avatar
    ir_dizzle no está en línea Stack level 2
    Join Date
    Jan 2007
    Posts
    34

    Buttons do not work; I have already tried to wipe and reinstall OS

    Advertisement



    Merry Christmas everyone,

    My Cingular-branded, unlocked Pearl (using AT&T old "blue" sim card) has completely stopped responding to any buttons I push on the phone. Any button I push (including the pearl) does not work; I am able to move the "cursor" up and down (when I see it), but none of the buttons work... period. The only time I see anything on the screen is when I try to charge the phone, sync it to my PC, or when someone calls me (but I can't pick-up); these are the only ways the screen is visible; otherwise, the buttons don't work and the phone is on power-saving mode; not displaying anything.

    I have had my phone for about a year now w/ no problems until recently and have not installed any new applications or programs on the phone for quite some time - the only thing I have ugraded blackberry-related on my computer or phone is the blackberry desktop manager which was upgraded to V 4.3.

    Prior to this problem happening today, just yesterday, my keys were getting stuck (or it seemed like it b/c when I pushed certain keys like the number "9", for example, numbers "8" and "9" would be pushed instead. To remedy the situation, I kept pushing all the buttons while the phone was turned off; in a sense, trying to loosen up the buttons in case they were getting stuck due to dirt build-up.

    Now, the buttons on my phone do not work. I have tried everything: battery pulls, downgrade the OS, take out the sim card, take out the micro SD card, wipe the phone clean using JL commander and reinstalling 2 different versions of OS' - NOTHING WORKS. I have no idea what to do to fix this phone. Does anyone have a clue on what I can do to try and fix this phone? Any recommended place I can take the phone to for repair?

    Thank you and your help is greatly appreciated as I am growing restless w/ this problem!

  2. #2
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164

    Re: Buttons do not work; I have already tried to wipe and reinstall OS

    maybe something got on to the board underneath the keypad causing the keys to stick and possibly malfunctioning the rest of the board? it definately sounds like a hardware issue if you have successfully installed/wiped/reinstalled and the keys still don't work. have you tried taking it apart? i know that is kind of commando, but right now, you have nothing else to lose, right?

  3. #3
    cky1billion's Avatar
    cky1billion no está en línea Stack level 2
    Join Date
    Sep 2006
    PIN/ID
    24236b05
    Posts
    84

    Re: Buttons do not work; I have already tried to wipe and reinstall OS

    I hate to say it, but it sounds like the device got wet somehow. I had this same thing happen to me on a few 8700c's and it happened after getting wet. One of the devices was completely submerged, and the other got wet from a very strong thunderstorm while in my pocket. Once I threw 'em on the heater, in a day, or two for the submerged device, all was fine. I would say that after you open it, if it doesn't look like anything is obstructing the key presses, pull the battery out and let 'er warm up on the heater.

    Good Luck!

    Ian

  4. #4
    ir_dizzle's Avatar
    ir_dizzle no está en línea Stack level 2
    Join Date
    Jan 2007
    Posts
    34

    Re: Buttons do not work; I have already tried to wipe and reinstall OS

    Thanks for the reply guys... for the meantime, the phone is fully operational... I took the trackball apart and cleaned it per the directions on the "sticky post" for trackball removal and cleaning.

    I will keep my fingers crossed!!

    Thanks again!

  5. #5
    cky1billion's Avatar
    cky1billion no está en línea Stack level 2
    Join Date
    Sep 2006
    PIN/ID
    24236b05
    Posts
    84

    Re: Buttons do not work; I have already tried to wipe and reinstall OS

    Hey right on, glad you got it sorted out. If every any of my BB's were terminal I would cry I think.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •