Results 1 to 8 of 8

I have a BB Pearl for about a year now and just this morning it ... BlackBerry Pearl forum

  1. #1
    krazyj125's Avatar
    krazyj125 no está en línea Stack level 2
    Join Date
    Mar 2007
    Posts
    53

    BB Pearl Battery Drain Problem

    Advertisement



    I have a BB Pearl for about a year now and just this morning it began to heat up out of no where. I was just sitting in class at school and I felt into my pocket and the whole bottom part was very hot. I charged it the night before and it was working fine in the morning before school. When I checked my battery level when it was hot, it was at only 1%. Then I pulled the battery and it was hot also. I put the battery back in and tried turning it on. It started up but once it got to the home screen and message popped up saying the battery is drained and the device will shut down now. I tried charging it and turning it on but the battery is still drained. Does this mean my battery is fried or something like that? What do I need to do to fix this?

    Thank You

    If more info is needed please let me know.

  2. #2
    LaTuFu's Avatar
    LaTuFu no está en línea Stack level 9
    Join Date
    Apr 2007
    PIN/ID
    Just Ax
    Posts
    7,861
    Sounds to me like your battery pooped out on you. It should never heat up like that under normal conditions. I'd try to use a different battery (purchasing a new one at this point probably isn't a bad idea anyway, since its about a year old).

    If the problem doesn't repeat itself with the new battery, I'd recycle the old one.
    If I knew where I was going, I might already be there. -- Cross Canadian Ragweed.

  3. #3
    krazyj125's Avatar
    krazyj125 no está en línea Stack level 2
    Join Date
    Mar 2007
    Posts
    53
    ok thank you
    there is nothing else it can be?
    because it's only one year, I don't know how that can kill the battery
    I wasn't even running any extra applications

  4. #4
    krazyj125's Avatar
    krazyj125 no está en línea Stack level 2
    Join Date
    Mar 2007
    Posts
    53
    hey you guys can you tell me if this is fake or not
    check it out, it's for the new battery I'm going to buy
    http://app.infopia.com/Shop/Control/...d/0/rid/126402

  5. #5
    danesandy9's Avatar
    danesandy9 no está en línea Stack level 1
    Join Date
    Aug 2009
    Posts
    1
    I'm getting the same exact problem that you experienced ......however when I purchased a new battery it was giving the same problem ....so now I'm not sure if its a problem with the phone itself ...or I was sold another bad battery..........please help if anyone overcame this situation..thanks

  6. #6
    xscotticusx's Avatar
    xscotticusx no está en línea Stack level 2
    Join Date
    Aug 2009
    PIN/ID
    24582533
    Posts
    70
    I have had similar problem. My phone got warm while charging and and high use. Eventually it quit charging completely. I thought man my battery Sucks. But I thought and for some reason I got out my kit and opened up my BB. The battery connectors in the phone are held into place by the phone casing and simply slip out without the screws. I gently scraped the connection between the circuit board and connectors which was somehow black. I closed it up and it worked perfect. If you have never done anything of the sort be careful and if it won't move... Don't make it be logical here. Last thing you need is a voided warranty.
    BlackBerry8100/4.5.0.110 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102 UP.Link/6.3.1.20.06.3.1.20.0

  7. #7
    takadante's Avatar
    takadante no está en línea Stack level 3
    Join Date
    Jul 2007
    PIN/ID
    24B2C963
    Posts
    441
    That is going to happen under the right conditions; extreme heat, extreme cold, non-generic charger, moisture, extended use, frequent charges.

    It is destined to fail on you eventually, it is just a matter of when. There isn't an easy fix other than purcasing a new battery kit and recycling your old one.

  8. #8
    fox581's Avatar
    fox581 no está en línea Stack level 2
    Join Date
    Jan 2008
    Posts
    68
    Well it could be the pins that connect to the battery or it could just be a bad battery. Just becarefull. Also corrosion from moisture can cause that. I would go to your carrier store or something and test it out before you shell out money for a new battery, it capild be the phone.
    Opera/9.60 (J2ME/MIDP; Opera Mini/4.2.13216/554; U; en) Presto/2.2.0

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •