Results 1 to 13 of 13

I've been browsing the topics and not sure if anyone had this same problem. I've ... BlackBerry Pearl forum

  1. #1
    bbnyc's Avatar
    bbnyc no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    1

    Question BB Pearl 8100- No Audio unless with headset or speaker-help!

    Advertisement



    I've been browsing the topics and not sure if anyone had this same problem. I've had my pearl for 2 years now thru Tmobile, and no problems except now. I stopped get audio/sound. The phone will still ring and vibrate but when I answer there will be no sound whatsoever. Only when I answer the call on speaker or attach my headset that is the only way I can answer the call. Pretty annoying. If I place a call I cannot hear anything, the call will go thru but I will not hear the dialing or answer unless with headset or speaker. It just happened recently. I have also noticed the call connection/signal is often faster when it is on speaker compared to when I just call regularly. (if this is related somehow)

    I have already tried the taking the battery, resetting thing, didn't work. I am a mac user and the bb updates are not really mac compatible right? well, I used a pc to upload the update and put it on my phone (thinking this would fix the problem)
    this did not work either. Any suggestions? Tmobile doesn't seem to have a solution either and wants me to ship my phone in for a week or so and give me a loaner crap phone in the meantime. Any suggestions?? PLEASE HELP!

    is there a setting I need to check?

  2. #2
    Amigotek's Avatar
    Amigotek no está en línea Stack Professional
    Join Date
    Mar 2007
    PIN/ID
    21D7B3C6
    Posts
    1,569

    Re: BB Pearl 8100- No Audio unless with headset or speaker-help!

    You may have a speaker that has failed or an audio driver that has failed or it may be just simply dirty. Either way it sounds like it needs to be taken to a shop and be disassembled in order to diagnose the issue. Since it works on speaker phone and headset it may just simply be a failed handset speaker which are generally inexpensive to replace depending on the shop. Since you mentioned that it was two years old that means any repairs you perform on it will be out of warranty unless you use insurance and pay the deductible they ask to replace it.

    Zo

  3. #3
    nortonassembler's Avatar
    nortonassembler no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    2

    Re: BB Pearl 8100- No Audio unless with headset or speaker-help!

    I am having exactly the same problem I tried to do the same things you dis....but nothing works, T-mobile is my provider too and I am out of warranty, please let me know if You find a solution for this problem and I will do the same If I find something first...Thank you

  4. #4
    xdremel's Avatar
    xdremel no está en línea Stack level 1
    Join Date
    Nov 2006
    Posts
    4
    Same thing happened to me. Some details to narrow it down. I tried several bluetooth headsets and it does not work as well. my assumption is that it's a driver issue. Anyone know of a way to reinstall just drivers? i installed the newest update and it still didn't work. Sadly mine stopped working after i tried installing the bPhone theme.

  5. #5
    commando82's Avatar
    commando82 no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    13
    i had the same issue as well, and posted a reply to a similar thread..
    http://blackberryforums.pinstack.com...earl_help.html

  6. #6
    xdremel's Avatar
    xdremel no está en línea Stack level 1
    Join Date
    Nov 2006
    Posts
    4
    thanks man, but i'm on the same boat as them as it's way out of warranty and just trying to delay the fact that i need to buy a new phone

  7. #7
    DOCRAY's Avatar
    DOCRAY no está en línea Stack level 2
    Join Date
    Dec 2006
    Posts
    34

    Ok BB your crapberry can be fixed.

    This is a software issue, your little speaker is still there and connected!
    Now I have had this Tblowble replaced after 6 months with a second
    one which lasted 9 months and the in your ear speaker failed again.

    So what you need to do is a software reinstall (backup your stuff) and
    after you do this you will need to do a battery pull with the phone on.
    This should fix your problem. The idiots at TBLOBLE and CRAPBERRY
    should tell you this but they make big $$$$ making people buy new phones
    or pay wild repair charges for out of warrenty phones (BB repair 230)
    so it is not in thier interest to get your phone working. the link sums it up.

    http://www.mobiledia.com/phones/rim/...rry-pearl.html

  8. #8
    DOCRAY's Avatar
    DOCRAY no está en línea Stack level 2
    Join Date
    Dec 2006
    Posts
    34

    Sorry BB its broke again.

    Well it worked for one call and dopey me thought it was fixed.
    No luck. Apparently its a tstroble 8100 issue, and they wont admit it. I have the insurance plan for 110 or 120 but I am so pisseed off at bb and T that I
    want to launch a class action against them, they are retards.

  9. #9
    amandarooo324's Avatar
    amandarooo324 no está en línea Stack level 2
    Join Date
    Jul 2007
    Posts
    22
    Alfo with tmo had same problem, however battery pulls and os reinstalls did not work for me. I have read about this on this forum too many times to count. I had to have my phone replaced, luckily still for free under warranty. I tend to think it is a hardware issue, not a driver, but who knows?

    ~via BB (wap.pinstack.com)~

  10. #10
    schumacher's Avatar
    schumacher no está en línea Stack level 3
    Join Date
    Feb 2008
    PIN/ID
    256F471E
    Posts
    125
    i had the same issue. it was a hardware issue for me. when you insert the headfone into the jack, there is a switch inside that disconnects the speaker and routes the sound to the headset. sometimes when u remove the jack the switch doesnt come back to its original position. what sorted my problem was putting the jack in and out a few times and shaking it around a bit. u guys should try that. be gentle. dont break the headphone jack.

  11. #11
    DOCRAY's Avatar
    DOCRAY no está en línea Stack level 2
    Join Date
    Dec 2006
    Posts
    34

    Tried plugging the speaker jack and shaking it around

    No joy. I cant see putting more money into a 3rd 8100 since I
    got about 7.5 months each out of the first 2, and my contract is up in
    Dec'08 and the third may not make it to then. I would stay away from T-ruble
    like the plague, they suck.

  12. #12
    ronie's Avatar
    ronie no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    7

    ok this might fix your audio

    Hi Guys...
    I have that problem too..no audio and then my voice dial keeps popping out ...so what i did ..install new OS..voice dial went away but still no audio...cant find any answer here so what i did, i open my BB and check the hardware on the board and found one of those tiny resistors close to the headset jack that the solder is discolored ..so clean it and solder it again...and audio works fine now...dont know if
    all BB 8100 have same issue like mine...ok ..i will open it again and take pix on that resistor so you guys can check it .....

  13. #13
    xdremel's Avatar
    xdremel no está en línea Stack level 1
    Join Date
    Nov 2006
    Posts
    4
    thanks ronie

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •