Page 3 of 3 FirstFirst 123
Results 31 to 35 of 35

Yeah, I didnt reinstall the handheld software because I it says on my Pearl that ... BlackBerry Pearl forum

  1. #31
    hawk838's Avatar
    hawk838 no está en línea Stack level 2
    Join Date
    Dec 2006
    Posts
    63

    Re: Application Loader

    Advertisement



    Yeah, I didnt reinstall the handheld software because I it says on my Pearl that it is the latest version. 4.2...

  2. #32
    Rcbjr's Avatar
    Rcbjr no está en línea Stack Pro
    Join Date
    May 2006
    PIN/ID
    PM - Ask
    Posts
    14,848

    Re: Application Loader

    I kept trying to tell you. But know you know. Always keep the current version of the OS for your BB installed on the PC. Desktop Manager needs it for Apps Loader to recognize any additional apps.

    Rcbjr.
    You Ask, We Will Answer
    Can’t Install theme via DM?No Additional Apps Found for Your Device
    Links to Usefull KB Articles

  3. #33
    silicontrip's Avatar
    silicontrip no está en línea Stack level 1
    Join Date
    Jul 2007
    PIN/ID
    25096285
    Posts
    4
    Hi all,

    I'm having the same problem.
    "The Blackberry desktop software does not have blackberry device software for the device..."

    I have recently changed companies and the desktop software was on my old work computer that I no longer have access to.

    I've installed the desktop software on this new computer but am now stuck. I have deleted the vendor.xml file as specified earlier in this thread. But still receive the same error.

    My desktop software version is 4.2.1.6
    I'm attempting to download a newer version of the software but it's still got a few hours to go.

    Does this error mean that the blackberry version is incompatible with the desktop software, or that I don't have the applications that are installed on my blackberry on my PC or something else?

    I would really just like to delete some of the software that is installed, and update some software.

    Thanks
    Mark

  4. #34
    mercurio's Avatar
    mercurio no está en línea Stack level 1
    Join Date
    Feb 2007
    PIN/ID
    24665AEF
    Posts
    10

    SOLVED! Application loader problems

    After looking around a a bunch of other posts, I solved this problem for my issue. Maybe it will help you, too.

    I saw this error each time I tried to install anything using the Application loader:
    "The Blackberry desktop software does not have blackberry device software for the device..."
    (but OTA installs worked fine)

    Turns out that my new Blackberry 8110 wasn't specifically included in the custom Blackberry desktop software, distributed by my company (IBM). Even installing the newest Desktop software from RIM didn't solve my problem. While everything else works fine, the application loader just barfs. I found another post that talked about device.xml file, so I found a version of that file and compared it to my own. It turns out my specific device (8110) wasn't listed.

    ...so, I added it, and viola! It works!

    Here is the path to the file that i changed:
    C:\Program Files\Common Files\Research In Motion\AppLoader\Device.xml

    and here is what I added (right under 8100):

    Code:
    <!-- 8110 -->
    <os radio="GPRS" series="8100" Colour="True" Theme="Normal" JVMLevel="1.0" Camera="True" VideoRecorder="True" VoiceNotes="True" pttApp="True" KeyboardType="Reduced" MMS="True" GPS="True" Bluetooth="True" Sound="Tunes8700g" SystemSize="normal" Backdrop="68M_240x260" ThemeSupport="Enhanced" VAD="True" JPN_Input="False">0x8F000D03</os>
    There may be other configs that need to be considered, but I don't use the desktop software much, so I just needed this. Please let us know if you find out more.

    Hope this helps!
    Marc

  5. #35
    silicontrip's Avatar
    silicontrip no está en línea Stack level 1
    Join Date
    Jul 2007
    PIN/ID
    25096285
    Posts
    4
    I discovered that my issue is a *KNOWN* bug in Pocket Mac. It does not register the software properly, so the software does not show in Application loader or in the advanced options -> applications.

    The only way I could solve this was to install the Blackberry JDE on a windows
    machine and use the javaloader to force delete the application modules. Of course I was lucky enough to have that sort of access to a windows machine.

    This wouldn't help the original issue that the applications were installed in a corrupt manner. I wouldn't be able to installed the JDE on a Mac, where the *official* Mac Blackberry software was the cause of the issue.

    I had contacted Pocket Mac about this issue (being unable to uninstall the applications), but never heard a response so never knew anything was wrong until now. Which is why I've gone through this convoluted manner of asking irrelevant questions because I didn't know that my applications weren't installed properly.

    I hope you can understand my anger and frustration at this.
    Mark

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •