Quote Originally Posted by StormHowler View Post
I'm also running into this problem in seeking to upgrade my Curve 8330m from .127 to .138 OS using DM 5.0 on Win Vista. No matter what I do, it doesn't detect that there's a newer OS on my computer, waiting to be installed on my Berry.

Help appreciated.
Have you tried just running App Loader and seeing if it detects the new OS? This is of course after you have uninstalled the previous OS from the computer and deleted the Vendor.xml file as the above post as stated..