Results 1 to 11 of 11

hi... i searched, but the other threads didn't seem to help... anyway, i've had my ... BlackBerry Curve forum

  1. #1
    DanXP's Avatar
    DanXP no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    73

    phone keeps shutting off

    Advertisement



    hi...

    i searched, but the other threads didn't seem to help...

    anyway, i've had my curve for about a year and updated the software to 4.5.0.81 about 4 months ago... i also got an 8g microsd card at the same time...

    i gave my 8g card away (why, i don't know)... and shortly thereafter, my phone shuts off mid-call... it's so frustrating... only way to get it going again is to a battery pull and now most of the time that doesn't even work...

    i thought it had something to do with the sd card not being there anymore, but i just got another 1g card and same thing seems to be happening...

    i refuse to believe this could be a hardware issue...

    any advice?

    thanks.

  2. #2
    moderncowboy's Avatar
    moderncowboy no está en línea Stack Moderator
    Join Date
    May 2008
    PIN/ID
    AskMe
    Posts
    7,297
    Sounds more like a bad battery than anything else. Try going into your local carriers store and see if they have one your can use to test you device. Then if it still does it look at software issues.
    Last edited by moderncowboy; 12-28-2008 at 09:49 PM.

  3. #3
    Sirthinks's Avatar
    Sirthinks no está en línea Stack level 5
    Join Date
    Jan 2008
    PIN/ID
    2831A313
    Posts
    1,569
    Do what I would do.... Get a new phone. That one is more than 3 months old.... :-)
    If you want to make an apple pie from scratch, you must first create the universe. - Carl Sagan

  4. #4
    Trxtr75's Avatar
    Trxtr75 no está en línea Stack level 1
    Join Date
    Oct 2006
    Posts
    3
    Bad battery or sim. It happens

  5. #5
    EronRackzak's Avatar
    EronRackzak no está en línea Stack level 1
    Join Date
    Dec 2007
    Posts
    7
    That happened exactly that way to me. Bad battery after searching through different options. Tell us what happened after tryng that change

  6. #6
    WhitePearlPXL's Avatar
    WhitePearlPXL no está en línea Stack level 4
    Join Date
    Jul 2007
    Posts
    642
    No SD card in there and it still shuts off? Besides the battery, try 4.5.0.110.

  7. #7
    dacyj's Avatar
    dacyj no está en línea Stack level 1
    Join Date
    Jul 2007
    Posts
    3
    Yeah I would try reloading the OS possibly update it and then do a battery pull
    ~via BB (wap.pinstack.com)~

  8. #8
    DanXP's Avatar
    DanXP no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    73
    thanks for all the replies...

    my current os is 4.5.0.110...

    i'm beginning to believe that it is a battery issue, as has been stated... i just took a picture with flash and it shut off again even though i had a fully charged battery according to the meter...

    whew... thought i was going to have to cough up $600 on ebay for a new curve 8900 unlocked...

    thanks again

  9. #9
    moderncowboy's Avatar
    moderncowboy no está en línea Stack Moderator
    Join Date
    May 2008
    PIN/ID
    AskMe
    Posts
    7,297
    Well if you decide to go pick up a battery post back if it fixes it or not and then if not we can go from there. Hope thats all it is .

  10. #10
    DanXP's Avatar
    DanXP no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    73
    fyi...

    i put in a healthy battery from another blackberry and all is well... (for now)...

    thanks for the replies.

  11. #11
    brettxw's Avatar
    brettxw no está en línea Stack level 4
    Join Date
    Nov 2007
    PIN/ID
    Ask
    Posts
    504
    Hey guys, I've encountered this problem about 3 months ago, thought I resolved it but am now having the problem again. When it first happened my phone would shut off randomly and I would have to pull the battery. Only way it would remain on is if I had it plugged in. Called TMO, they sent me a new battery and all was fine until about 2 weeks ago. Same problems started happening. This time the phone gets all staticy when I would place calls which would then finally shut off and I could not get it back. Called them again, they are now sending me a brand new curve which I have no use for because I now have the Storm. haha. But its not the battery, it is the phone, for some reason the phone is draining the batteries.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •