Results 1 to 4 of 4

just picked one up and immediately after inserting SIM and battery, the screen is showing ... BlackBerry Curve forum

  1. #1
    terrapin's Avatar
    terrapin no está en línea Stack Pro
    Join Date
    Mar 2007
    Posts
    989

    new 8320 from T-Mobile

    Advertisement



    just picked one up and immediately after inserting SIM and battery, the screen is showing a 507 error, circle, square, triangle icons within a circle with a line through - what's up with this?

  2. #2
    agarza11's Avatar
    agarza11 no está en línea Stack level 1
    Join Date
    Sep 2007
    PIN/ID
    205c93f6
    Posts
    13

    Re: new 8320 from T-Mobile

    i would just take it back!! exchange it for another one before your 14 days are out!!
    Did it stop doing it?
    Did it load up?

  3. #3
    terrapin's Avatar
    terrapin no está en línea Stack Pro
    Join Date
    Mar 2007
    Posts
    989

    Re: new 8320 from T-Mobile

    That's what I am going to do agarza11. I tried taking the SIM out several times, using a fully charged spare battery...nothing - it doesn't boot up - it just gets stuck in that 507 screen. Even if it does/did boot up OK now (not going to try again) I'd still take it back. I'm the kinda person that for that amount of $$ if it doesn't work right out of the box, it's going back...

  4. #4
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164

    Re: new 8320 from T-Mobile

    507 means no OS...

    never seen that out of the box, but...we can fix terrapin, if you wanna try

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •