I have the same problem as the guy who has bb 8810 with beejive application.
Mine is 8820 with OS Version When using 30 day free trial version I had no problem that's why I decided to buy it. But after couple days using the paid version I problem arised. This is the message when I tried to log in.
"class java.lang.nullpointerexception,null and uncaught exception:java.lang.Nullpointerexception. I have tried following your suggestion below :

Quote Originally Posted by fritter View Post
try going to options then advance options then applications and find jivetalk once found then highlight it and click the menu button and choose edit permissions
and make sure that everything is allowed. also once done go to the app itself if you can open it once in click menu botton and choose preferences and try changing the mobile network transport from one to another. also you need to make sure that your APN settings are set in options\advance optinos\TCP
but the same message still came out and I still could not even open the application.
Please help thank you