Results 1 to 4 of 4

as of late, im experiencing a coupe of problems with my curve. it has become ... BlackBerry Curve forum

  1. #1
    hrag2k's Avatar
    hrag2k no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    6

    Few problems with my 8310

    Advertisement



    as of late, im experiencing a coupe of problems with my curve. it has become really slow and very annoying to use

    1) its really slow. anything i press on takes about 5 seconds to load up.

    2) the trackball isnt smooth anymore, and i cant use it to select things. i gotta navigate to wherever i wanna go and click ENTER

    3) im using the os 4.5.0.37, and for some reason youtube still doesnt work. i can browse for movies, but it never loads up. i get an error.

    i dont really care about the youtube, but i really want the BB trackball to work, as pressing enter gets really anoying.

    any help is greatly appreciated.
    thanks

  2. #2
    boricua's Avatar
    boricua no está en línea Stack level 3
    Join Date
    Jan 2008
    Posts
    152
    What worked for me was I Reinstalled my device software.

  3. #3
    Berryadict's Avatar
    Berryadict no está en línea Stack level 7
    Join Date
    Jul 2008
    Posts
    3,297
    ~via BB (wap.pinstack.com)~
    Try pulling the silver retaining ring, noting prongs on ring and how trackball is sitting in handheld, then turn pda upside down so that assembly falls into your hand. Then use a little rubbing alcohol on a QTip to clean the ball thoroughly, then the rollers. When it dries, roll the ball in every direction repeatedly. Blow out the assembly and aperature in handheld with compressed air. Then manipulate the ball again.
    Set the assembly back into aperature the way you found it. Align prongs on ring where they belong, and press down evenly until secure.
    Trackball should function properly.

  4. #4
    hrag2k's Avatar
    hrag2k no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    6
    another problem i found is i cant press ALT+ numbers or NUM+numbers at the same time. i gotta do them seperate.
    if ur gonna send someone a number it gets pretty annoying.
    is there a way to fix that?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •