Results 1 to 9 of 9

I just got a T-Mobile 8320. There is only one problem. It will not turn ... BlackBerry Curve forum

  1. #1
    Ge's Avatar
    Ge
    Ge no está en línea Stack level 4
    Join Date
    Jun 2008
    Posts
    738

    Dead Curve 8320?

    Advertisement



    I just got a T-Mobile 8320.

    There is only one problem.

    It will not turn on. I have tried a battery pull, a reflash of 4.5 etc.

    The unit gets detected when I plug into Desktop Manager, and I can force a flash. It even flashes successfully.

    It simply will not turn on. After a battery pull, the LED turns red for 3 seconds and then goes off.

    No response from the keyboard, nothing.

    Any ideas? Do I have a brick?

  2. #2
    GaryF's Avatar
    GaryF no está en línea Stack Moderator
    Join Date
    May 2007
    Posts
    5,432
    Has it worked at any time you had it?

    Have you tried charging the battery for a while? It is possible that the battery is completely dead and that can cause some strange behavior.
    BlackBerry® Certified Support Specialist
    The Shark Tank

  3. #3
    Ge's Avatar
    Ge
    Ge no está en línea Stack level 4
    Join Date
    Jun 2008
    Posts
    738
    It worked till I tried to flash it with the latest 4.5 OS

    The battery is fully charged. It works fine with my 8310

  4. #4
    GaryF's Avatar
    GaryF no está en línea Stack Moderator
    Join Date
    May 2007
    Posts
    5,432
    Understood. So we are dealing with a failed operating system install, correct? Please be clear what you mean when you say you force a flash and that it flashes successfully....

    Take a look at this thread:How To Re-Install OS When Computer Won't Recognize The Device Is Connected
    Last edited by GaryF; 11-06-2008 at 03:32 PM.
    BlackBerry® Certified Support Specialist
    The Shark Tank

  5. #5
    Ge's Avatar
    Ge
    Ge no está en línea Stack level 4
    Join Date
    Jun 2008
    Posts
    738
    I wouldn't call it a failed install. It actually completed with no problem.

    It just never restarted.

    I am going to try the steps in your link. Thanks for your help.

    *** Edit ***

    Well, it is still dead

    Here is the full story

    Unit was acquired on eBay

    When it was received a month ago, it worked fine. Two days ago, I decided to update to 4.5

    The update went without a hitch. But the device did not turn on. So I tried to re-flash several times and still no go.

    I am not sure if this makes a difference, but I am using Rogers firmware instead of T-Mobile.

    I tried inserting the battery at different stages of the flash and it is still dead.

    I tried a complete wipe with JL_Cmder, still no dice.
    Last edited by Ge; 11-06-2008 at 04:12 PM. Reason: Update

  6. #6
    GaryF's Avatar
    GaryF no está en línea Stack Moderator
    Join Date
    May 2007
    Posts
    5,432
    At this point I would suggest you delete the 4.5 OS from your desktop and try to install and older, 4.2 version on your device.

    Just to confirm - the device is branded TMO or Rogers? And what version of the OS are you trying to install?
    BlackBerry® Certified Support Specialist
    The Shark Tank

  7. #7
    Ge's Avatar
    Ge
    Ge no está en línea Stack level 4
    Join Date
    Jun 2008
    Posts
    738
    The device is branded T-Mobile

    I was trying to install the offical T-Mobile 4.5.0.81 firmware

    I will try to down grade and install 4.3, I just have to find it.

  8. #8
    monepolized07's Avatar
    monepolized07 no está en línea Stack level 1
    Join Date
    May 2007
    Posts
    5
    Maybe its as simple as your screen light blew out. I'm a blackberry rep and have seen this happen a couple times.

    ~via BB (wap.pinstack.com)~

  9. #9
    phatmanxxl's Avatar
    phatmanxxl no está en línea Stack level 4
    Join Date
    Feb 2008
    PIN/ID
    3M TA3
    Posts
    611
    I been running rogers OS for a few months now on my tmo phone without any problems. If its just the lights, try dialing voicemail and listen for any sounds. And yea I second the downgrade.
    Last edited by phatmanxxl; 11-08-2008 at 08:49 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •