Page 1 of 2 12 LastLast
Results 1 to 15 of 19

Noticed this today on my 8330: when plugging in any USB cable to the phone, ... BlackBerry Curve forum

  1. #1
    Hyperplex's Avatar
    Hyperplex no está en línea Stack level 2
    Join Date
    May 2008
    Posts
    22

    Curve 8330 USB jack messing up

    Advertisement



    Noticed this today on my 8330: when plugging in any USB cable to the phone, the charging indicator over the battery display only appears after jiggling/pressing/manipulating the cable. I find myself having to gently arrange the phone and cord so that contact is made and the charge continues. I hadn't noticed this for the months that I've had the phone until today. I've performed both a soft reset and a battery pull, so I don't think it's a software issue.

    Has anyone else had this issue? Is it something a quick visit to my VZW dealer might remedy?

  2. #2
    DjSmooth's Avatar
    DjSmooth no está en línea Stack Professional
    Join Date
    Jul 2007
    Posts
    2,080
    Not really a quick fix, the Device will need to be changed, are you still under warranty?

  3. #3
    Hyperplex's Avatar
    Hyperplex no está en línea Stack level 2
    Join Date
    May 2008
    Posts
    22
    I think so. I'll stop in there tomorrow and see what they say.

  4. #4
    soufdallas's Avatar
    soufdallas no está en línea Stack level 1
    Join Date
    Jul 2008
    Posts
    1

    charging problems

    This problem is within the black berry ive had my black berry curve 8330 for about 3 1/2 weeks now and ive swapped it because i had the same problems......but not with usb with the car charger. I bought a verizon car charger, it worked for few days and then i started havin problems with it, took it bak to verizon then went to SPRINT and bought one str8 from sprint and found out its doing the same thing, not charging or sometimes charging just a lil bit then not charging. I"ve even went out and bought a car inverter so that the 2 prong socket will charge my phone in my truck but even that doesn't charge fully.......i took it back to sprint and got another phone and its doing the same thing, thank God i still have my nextel blackberry 7100 and it charges with no problem all the time........so all i do is swap batteries and charge the battery with my nextel blackberry 7100.......i guess its a glitch in the phone but i use my phone all day long so i have to keep it charged at all times when i can.

  5. #5
    Hyperplex's Avatar
    Hyperplex no está en línea Stack level 2
    Join Date
    May 2008
    Posts
    22
    Upon further examination, it seems the actually plug itself in the side of the BB is loose; I can wiggle it up and down and when it is fully in, all contact is made and charging works. When loose, the contact is broken.

  6. #6
    sugarhoodie's Avatar
    sugarhoodie no está en línea Stack level 2
    Join Date
    Nov 2007
    Posts
    40
    i have had this exact issue, and am now on my fourth 8330 from vzw. it just seems to end up getting loose over about a week's time. have definitely been considering switching to the desktop charger because i am tired of having my bb switched out every few weeks.

  7. #7
    HeywoodJ's Avatar
    HeywoodJ no está en línea Stack level 3
    Join Date
    Sep 2006
    PIN/ID
    pm me
    Posts
    280
    i have experienced similar problems with the plug but its usually dirt or other debris in the cable end or the socket. the port its self does seem to have some wiggle room and i would get a can of compressed dry nitrogen and blow out the port and clean the contacts of the cable. it may be a cheaper alternative to going to a service center as that's the first thing the tech will try.
    good luck
    phil

  8. #8
    dflsam's Avatar
    dflsam no está en línea Stack level 1
    Join Date
    Oct 2006
    Posts
    2

    Thumbs up usb port

    Get a replacement Go to "CNN" DOT "CN" DOT COM

  9. #9
    Hyperplex's Avatar
    Hyperplex no está en línea Stack level 2
    Join Date
    May 2008
    Posts
    22
    At this point the wobbly jack is only a nuisance. Since finding out the cause of the shoddy connection, I've been able to maintain steady connections for syncing. I've also gotten a cradle charger so for day to day charging I don't even have to mess with the USB port.

  10. #10
    Hyperplex's Avatar
    Hyperplex no está en línea Stack level 2
    Join Date
    May 2008
    Posts
    22
    So much for it being only a nuisance; charging still works via the USB plug but now I am unable to sync with my computer. Looks like I'm either headed to VZW or to cnn.cn. For those with experience working with the guts of the BB, will I have to solder a new USB plug into the board or is it simply a plug in job?

  11. #11
    Schufly's Avatar
    Schufly no está en línea Stack level 3
    Join Date
    Jan 2007
    Posts
    471
    I recieved a warranty replacement today for the dame issue. It got so I couldn't charge it. Also recieved my Seidio 2600 mAh extended battery today.....red letter BB day for me!
    Andy

  12. #12
    NoRemorse's Avatar
    NoRemorse no está en línea Stack level 2
    Join Date
    Mar 2008
    PIN/ID
    31795d7d
    Posts
    44
    Quote Originally Posted by Hyperplex View Post
    Noticed this today on my 8330: when plugging in any USB cable to the phone, the charging indicator over the battery display only appears after jiggling/pressing/manipulating the cable. I find myself having to gently arrange the phone and cord so that contact is made and the charge continues. I hadn't noticed this for the months that I've had the phone until today. I've performed both a soft reset and a battery pull, so I don't think it's a software issue.

    Has anyone else had this issue? Is it something a quick visit to my VZW dealer might remedy?
    I had this issue on my 8830. My phone was not going to be covered under any warranty, so I bought the USB jack for $5 (and $5 shipping) and resoldered it in myself. Obviously not a fix for most people, but it's remedied my issues.

  13. #13
    Dahm's Avatar
    Dahm no está en línea Stack level 2
    Join Date
    Jun 2008
    Posts
    29
    Hey I had this issue as well. Its not really a hardware/build thing. For some reason, for a day it was doing that, and yes my jack was slightly moving up and down as well, but it wasnt the problem. It was the jack on my computer that wasn't plugged in all the way.

    It was causing me to be able to not sync, and everything. I didnt even restart my phone, but I went to class, and when I came back, it never happened again.

    Try pushing in the cable on the computer all the way, and it has a strangely high chance of fixing your problem.


    Goodluck though.

  14. #14
    Hyperplex's Avatar
    Hyperplex no está en línea Stack level 2
    Join Date
    May 2008
    Posts
    22
    Actually, my loss of sync ability turned out to be completely unrelated. Hah!
    However, I am still concerned about the loose jack. I'm wondering how much longer normal use can continue before its connection breaks altogether.

  15. #15
    Dahm's Avatar
    Dahm no está en línea Stack level 2
    Join Date
    Jun 2008
    Posts
    29
    If it helps, I noticed that when mac users running mts mobility 4.5.0.82 and PocketMac: if you try and install an uncompatible program/file, the PocketMac program will infact crash, saying you did an "unsafe removal of hardware.".

    Posting this incase anyone was experiencing that. I thought it was an interesting observation.

    ~via bb

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •