Results 1 to 9 of 9

Greetings. This is my first time posting a question. My device: T-Mobile Curve 8900. However, ... BlackBerry Curve forum

  1. #1
    inklingfoto's Avatar
    inklingfoto no está en línea Stack level 1
    Join Date
    Nov 2008
    PIN/ID
    20EF8D65
    Posts
    11

    Calendar sync & default issues.

    Advertisement



    Greetings.

    This is my first time posting a question.
    My device: T-Mobile Curve 8900. However, the following described issue was also noted on my previous AT&T Blackberry 8310.

    I have set the Default Services for my selected main email address, (xxxx@xxx.com).
    After adding appointments and schedules in Outlook I will sync with my Blackberry and all scheduled data will be displayed under the "Device Default" heading and appropriate color. Any appointments and scheduling added directly to my Blackberry via the keypad will automatically be stored under the Default Services selected email address of (xxxx@xxx.com). This will also sync perfectly with Outlook. So far, so good.

    The issues begin when adding a new email address, changing specifications on an existing address, or installing a third party app such as Facebook.
    The new email address referred to as (yyy@yyy.com) assumes "control" of my calendar and all entries added post install, change, etc. will auto store underthe new address without my awareness of such. These additions to my calendar will now NOT sync with my Outlook.
    Opening a calendar entry under (yyy@yyy.com) and attempting to change the email address that it was entered under results in nothing. Now I have many calendar entries under the (yyy@yyy.com) which I cannot sync with Outlook.
    Additionally, (yyy@yyy.com) appears to have "taken over" entries which I had previously added via Blackberry keypad. When syncing with Outlook I will have many duplicated entries causing my calendar to appear severely cramped.

    Can anyone help me to resume "control" of my calendar without having to physically delete each (yyy@yyy.com) calendar entry and subsequently re-enter each one individually under the (xxx@xxx.com) address?

    Thank you in advance to anyone with ANY input at all to my query.

    inklingfoto...

  2. #2
    RogerG's Avatar
    RogerG no está en línea Stack Administrator
    Join Date
    Nov 2006
    Posts
    21,111
    inkling,

    Since adding these addresses and installing Facebook, have the Default Services settings changed to reflect any of these additions or is it still set to what you used to sync with Outlook?

    I know when I installed Facebook, that then became the default for any calendar entries and I had to go back in and change the setting to reflect my Outlook e-mail/calendar.

    You can only change the e-mail associated with a calendar entry when you first open the appointment. Once it has been saved, you are stuck with that entry, unless you delete and re-enter it.

    Again, check your Default Services to see if has changed to any of the new entries or the Facebook entry. Options>Advanced Options>Default Services.

    And as far as I know, using Outlook and Desktop Manager only allows you to sync one e-mail/calendar, so if you are entering appointments with any other e-mail address other than the one used in Outlook, it will not sync into your Outlook calendar.

    Hope this helps.....

    Roger

  3. #3
    inklingfoto's Avatar
    inklingfoto no está en línea Stack level 1
    Join Date
    Nov 2008
    PIN/ID
    20EF8D65
    Posts
    11
    Once had to change the Default Services on my AT&T 8310 after adding Facebook. However with the T-Mo 8900 the Default Services still display as (xxx@xxx.com) but entries auto insert as (yyy@yyy.com).
    Yes I can manually change the defaulted entry prior to saving however, there are times when I will forget this step as I am pressed for time myself.
    I can delete the "offending" (yyy@yyy.com) account then all will return to its previous state. Then I would also like to ask how to re-instate the new account of (yyy@yyy.com) without having it "take control"?

    Thank you very much for your quick reply and knowledgeable input.

    inklingfoto

  4. #4
    RogerG's Avatar
    RogerG no está en línea Stack Administrator
    Join Date
    Nov 2006
    Posts
    21,111
    I hear ya on forgetting to change the default. Done that many times myself and just left it that way.

    Are you adding these e-mail addresses via the Setup Wizard on the device or through the BIS? Not that this should make any difference.....just curious. I am not aware of a setting in BIS that tells the device to utilize a particular address as the default. Since I've never used the Setup Wizard on the device, I don't know about that method either, but I'm pretty sure they are identical.

    So any new entry you create in the calendar will ALWAYS default to the yyy@yyy.com? I've seen where in many cases the device will pick the last one used as the default, at least in e-mail situations. Not so sure with the calendar, however.

    I have an 8310 myself and am not familiar with the 8900 enough to know what differences there are with settings, etc. Perhaps someone more knowledgable on this device can offer suggestions.

    Roger

  5. #5
    inklingfoto's Avatar
    inklingfoto no está en línea Stack level 1
    Join Date
    Nov 2008
    PIN/ID
    20EF8D65
    Posts
    11
    Excellent observation! One which I overlooked completely.

    I will attempt to delete the (yyy@yyy.com) account, add a temporary entry under the (xxx@xxx.com) account, re-instate the (yyy@yyy.com), make another (xxx@xxx.com) entry and hope for the best.

    This may be an OS design flaw that RIM should address...

    Will post later with any results.

    Thank you for your assistance.

    inklingfoto

  6. #6
    RogerG's Avatar
    RogerG no está en línea Stack Administrator
    Join Date
    Nov 2006
    Posts
    21,111
    The only time I've had an issue on my 8310 was when I installed Facebook and simply resetting the Default Services fixed it. I have 6 e-mail address that come to my device and adding new ones never created the issue you speak of......my defaults always remained the same.

    Are you running the 8900 on AT&T or TMO? Either way, sounds like you've had the issue on two devices. Amazing how the same device on the same carrier can behave differently.

  7. #7
    inklingfoto's Avatar
    inklingfoto no está en línea Stack level 1
    Join Date
    Nov 2008
    PIN/ID
    20EF8D65
    Posts
    11
    These are the steps that I took after RoGro's mention of the Blackberry's "last used" hierarchy possibly having an effect on my calendar.

    1. Logged into BIS and deleted the "offending" yyy@yyy.com address.
    2. double checked to ensure that the xxx@xxx.com was set as the Default Services for both Calendar and Messaging.
    3. Made a temporary Calendar entry with the Default email address (xxx@xxx.com)
    4. Re-initiated the yyy@yyy.com address.
    5. Reviewed calendar entries specifically searching for yyy@yyy.com. None were present.
    6. Calendar synchronizes without any issues.

    NOTE: If I ALTER any previous Calendar entries via my Blackberry keypad, then save them they will appear as expected for the xxx@xxx.com email and remain "syncable".
    The original issue arises again after creating another email address (or installing Facebook). The addition of a new email address will result in that email address "taking over" only those entries which were altered via the Blackberry keypad.

    These are a lot of steps to retrace in order to maintain synchronization capabilities after adding a new email address or application like Facebook.

    I still believe that this is an issue which RIM needs to address in their Operating System.

    Hope this may assist someone else.

    inklingfoto

  8. #8
    RogerG's Avatar
    RogerG no está en línea Stack Administrator
    Join Date
    Nov 2006
    Posts
    21,111
    Wow, nice work, inkling! Sure does sound like an issue, at least with the 4.6 OS on your 8900. This is obviously not the way it should work. Your default should remain the default, regardless of any introduction of a new e-mail address or associated application.

    Hats off to you for havng the patience to go through these steps and it will undoubtedly assist others experiencing this issue.

    Cheers,
    Roger

  9. #9
    pmarshall's Avatar
    pmarshall no está en línea Stack Professional
    Join Date
    Sep 2007
    Posts
    3,085
    Worked great! thanks from me and my customer!
    HAHA HERO, MY TOUCH

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •