Page 1 of 2 12 LastLast
Results 1 to 15 of 17

I'm having trouble with my brand new 8320. When I plug in the wall charger ... BlackBerry Curve forum

  1. #1
    darthdiablo's Avatar
    darthdiablo no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    4

    BB not charging with wallcharger

    Advertisement



    I'm having trouble with my brand new 8320. When I plug in the wall charger my BB recognizes it for about 3seconds and then the charging icon goes away. Ive looked all through out the settings but I don't see any battery/ charging options. My BB has no trouble charging via USB and my computer. Has anyone ran into this problem or know what my problem is?

  2. #2
    danger872's Avatar
    danger872 no está en línea Stack level 3
    Join Date
    Aug 2006
    PIN/ID
    2401D9F3
    Posts
    151
    where did you buy your new curve?.....because i had the same issue but i had to purchase a bb charger not no 3rd party charger

  3. #3
    aldie's Avatar
    aldie no está en línea Stack level 3
    Join Date
    Nov 2007
    Posts
    301
    if the usb charging is fine, then i would guess it's just the hone charger. go into a store and ask them to try out a new one for you before you buy it....better yet, call your customer care dept and ask for a new one. it doesn't hurt to try.

  4. #4
    darthdiablo's Avatar
    darthdiablo no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    4
    I bought mine from newegg. I was thinking it might be the wall charger itself since my BB charges fine on usb. It just seems odd that the BB sees the wallcharger at first then disconnects. I'd think if the wallcharger was bad the BB wouldn't see it at all.

  5. #5
    trungiie's Avatar
    trungiie no está en línea Stack level 1
    Join Date
    May 2008
    PIN/ID
    2435444A
    Posts
    16
    i find that mine only charges when its comepletely off..... o_O"

  6. #6
    darthdiablo's Avatar
    darthdiablo no está en línea Stack level 1
    Join Date
    Apr 2008
    Posts
    4
    just bought and tried another wallcharger. BB is still doing the same thing. this is silly. :/

  7. #7
    chokem's Avatar
    chokem no está en línea PINStacked!
    Join Date
    Jan 2008
    PIN/ID
    nada
    Posts
    11,481
    Ive had this issue before, and found that the only real solution is to use a BB OEM charger. I dont know why but after a few times charging a BB on all the aftermarket chargers Ive used, they quit working.

  8. #8
    chokem's Avatar
    chokem no está en línea PINStacked!
    Join Date
    Jan 2008
    PIN/ID
    nada
    Posts
    11,481
    Ive only had success using the OEM chargers. Evertime I try to use an aftermarket or generic charger it quits working after a few charges. I thing the Bb is pulling too many amps.

  9. #9
    beamolite's Avatar
    beamolite no está en línea Stack level 3
    Join Date
    Jul 2007
    PIN/ID
    23F73F86
    Posts
    107
    I haven't had a problem with my BLackberrys charging but my wife's junk Moto Razr V3 is super sensitive. You have to plug it in and turn it on and off 3-4 times before it will begin charging on any charger. BB charger will not work with it at all.

  10. #10
    aflansburg's Avatar
    aflansburg no está en línea Stack level 3
    Join Date
    May 2007
    PIN/ID
    2469F3D5
    Posts
    130
    you have to be careful with the third party chargers and chargers for other phones. we've had several pearls that will no longer charge wall or usb. there's a maximum power throughput that you cannot go over and some of those chargers are the incorrect voltage.

  11. #11
    trungiie's Avatar
    trungiie no está en línea Stack level 1
    Join Date
    May 2008
    PIN/ID
    2435444A
    Posts
    16
    ^^^yea thats true but mine is the charger that it comes with when you buy the phone so i dont get why it doesnt charge while its on and only when its off..???

  12. #12
    lexo's Avatar
    lexo no está en línea Stack level 3
    Join Date
    Jun 2007
    Posts
    259
    i use all kinds of generic chargers on my pearl and curve 8320 and so far had no problems

  13. #13
    chokem's Avatar
    chokem no está en línea PINStacked!
    Join Date
    Jan 2008
    PIN/ID
    nada
    Posts
    11,481
    my aftermarket chargers heat up a lot when I charge my BB on them, but the OEM doesnt get hot at all

  14. #14
    potthoff's Avatar
    potthoff no está en línea Stack level 3
    Join Date
    Dec 2006
    Posts
    398
    I reserve my OEM chargers for my BB only. Since I've owned a couple I have plenty to use.

    One time, at a friend's house, I used her Razr charger and it charged so slowly. I just don't want to risk messing up my Curve.
    Lis (not dead, but Berried)
    Music is feelings unspoken.

  15. #15
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    Quote Originally Posted by darthdiablo View Post
    I'm having trouble with my brand new 8320. When I plug in the wall charger my BB recognizes it for about 3seconds and then the charging icon goes away. Ive looked all through out the settings but I don't see any battery/ charging options. My BB has no trouble charging via USB and my computer. Has anyone ran into this problem or know what my problem is?
    You're not alone - I have EXACTLY the same charging problem with my 8100 except that mine never gets "recognized." It'll charge on any USB cable on my laptop and never on a wall charger. It also connects to DM fine for backup and sync - no problem.

    Quote Originally Posted by chokem View Post
    Ive had this issue before, and found that the only real solution is to use a BB OEM charger. I dont know why but after a few times charging a BB on all the aftermarket chargers Ive used, they quit working.
    The "wall chargers" that I use are ALL OEM, one of three that came with the 8100, 8120 and 8320 that I own. (I don't even own a 3d-party wall charger. The other two phones charge fine using any of the 3 wall chargers - just the 8100 won't charge.

    I can't return/replace the Pearl and every other feature on it works perfectly. My "easY" solution so far is a desktop cradle. It's a confounding problem to say the least. If you figure it out please post your solution.
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •