Results 1 to 3 of 3

So about a month ago I got my new blackberry curve. I was so excited ... BlackBerry Curve forum

  1. #1
    Reneesmoi's Avatar
    Reneesmoi no está en línea Stack level 1
    Join Date
    Oct 2010
    Posts
    1

    BB curve 8520: edge vs EDGE?

    Advertisement



    So about a month ago I got my new blackberry curve. I was so excited to get it and be able to use windows live, facebook and of course bbm. I called rogers and they hooked up my data plan which included those three features. They said it might take a day to actually turn on. I waited two days and called in. They said the "edge" in my corner should say "EDGE". They didn't know what else to do.. So for the past month I've had no features. Any suggestions on how do change it? I do in fact have the data plan so it SHOULD work but yeah.
    I have tried taking the battery out.

  2. #2
    chokem's Avatar
    chokem no está en línea PINStacked!
    Join Date
    Jan 2008
    PIN/ID
    nada
    Posts
    11,481
    Youre not getting data. Call them again and make them tell you why. It's on their end, if you have a data plan, it should of course say EDGE. If they are pushing the data to you phone, there's no reason it shouldn't work. Make them let you talk to the tech dept.
    ​Galaxy S4 Red

  3. #3
    goodadithya's Avatar
    goodadithya no está en línea Stack level 1
    Join Date
    Jun 2011
    PIN/ID
    276D5D1B
    Posts
    15
    Hey....I'm late here...but myt help sm 1 else i hope......if u have activated ur data plan but it doesn't show 'EDGE' but just "edge", wat u gotta do is go to options>advanced options>Host Routing Table>(press d bb button) nd register.
    Also, u can try to go to Cell Broadcast Settings in advanced options nd put it 'ON'....hope it helps ya.......tc

    Adithya
    276D5D1B
    Last edited by goodadithya; 07-29-2011 at 12:36 AM. Reason: New Mobile.....Bold 9780

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •