Results 1 to 14 of 14

Hey everyone, I've been having a problem for the last few days and i'll tell ... BlackBerry Curve forum

  1. #1
    jsweetser2's Avatar
    jsweetser2 no está en línea Stack level 2
    Join Date
    Feb 2008
    PIN/ID
    241EC7CA
    Posts
    42

    Battery Problem?

    Advertisement



    Hey everyone,

    I've been having a problem for the last few days and i'll tell you a little about it so perhaps we can diagnose it.

    I recently upgraded my OS to 4.5.0.81 (Platform 2.7.0.78) on my Curve 8320.
    I charge my phone via USB and wall charger, depending on where I am.

    About 6 days ago i was at half battery, on the phone with my mother and there was a bunch of static all of a sudden, then my phone died. It wouldn't respond to turning back on, so i took the battery out, waited 30 seconds, put it back in and turned it on. It didn't even finish loading and again blacked out and became unresponsive.

    I plugged it in, and it immediately turned on and began charging.

    I let it charge to full, called her back and no problem.
    I didn't bother charging it that night and while in my car the next day, i recieved a text message with the battery at about 3/4 battery, and when i tried to open it the phone died, and became unresponsive again until i plugged it in.

    Now, at about half battery, this happens every day. Yesterday it happened again and i figured my battery was messed up and didn't think about it - planning on getting another battery. I didn't plug it in. About 2 hours later my phone magically turned on again and i was able to use it until it was redzone.

    Plugged it in, let it charge to full.

    Today at half battery it died right after i sent a text and became unresponsive again.

    So i was thinking, perhaps there's a deadzone in the middle of my battery charge? The battery i'm using is the standard issue Lithium Ion battery, which is not supposed to have 'memory' like old Nicads did.

    I'm planning on reinstalling the OS just in case there's a programming error (since after the first call, it only dies when i'm texting or recieving texts).

    Any other ideas?

  2. #2
    thbassman's Avatar
    thbassman no está en línea Stack Professional
    Join Date
    Apr 2007
    PIN/ID
    ASKME4IT
    Posts
    10,235
    My first thought would be a glitch in the install. . Did anything happen to your computer during the install?? Program start, virus scan start, etc???? That release had memory leak issues when I was using it, but never had one that killed the battery, so I would guess something happened @ the install point. I would do a wipe and reinstall, just to check and be sure. . . .Hope this helps. . .

    Feel free to PM me with any other Q: issues, as I have that device and experience with that software release.
    THBASSMAN

    Carpe Diem!!

    thbassmanatpinstackdotcom

    Check this out!!! Mobiletropolis

    My TORCH Rocks!

  3. #3
    miccic's Avatar
    miccic no está en línea Stack level 1
    Join Date
    Jun 2008
    Posts
    12
    I had similar battery problems. The level indicator seemed to not know anymore how much of a charge was left. It would die after I'd done something heavy on the power, even though it said it still had over 50%. The battery was almost exactly a year old, so I replaced it and everything is fine. How old is your battery? It sounds a little bit like the story of how a battery dies.

  4. #4
    jsweetser2's Avatar
    jsweetser2 no está en línea Stack level 2
    Join Date
    Feb 2008
    PIN/ID
    241EC7CA
    Posts
    42
    Battery is about 6 months old, and it only happens now (no matter what battery life) when i do 12-13 back to back recieve/send texting. I heard there may be a memory leak so i'm going to wipe/reinstall and see if it fixes it. if not then i'll shell otu for a battery.

  5. #5
    swalker2001's Avatar
    swalker2001 no está en línea Stack level 2
    Join Date
    Jul 2008
    PIN/ID
    2461c562
    Posts
    55
    Had same problem. Definitely needs a new battery.

    ~via smartphone~

  6. #6
    thbassman's Avatar
    thbassman no está en línea Stack Professional
    Join Date
    Apr 2007
    PIN/ID
    ASKME4IT
    Posts
    10,235
    jsweetser?? any news??? did the wipe and reinstall work???
    THBASSMAN

    Carpe Diem!!

    thbassmanatpinstackdotcom

    Check this out!!! Mobiletropolis

    My TORCH Rocks!

  7. #7
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    Quote Originally Posted by jsweetser2 View Post
    Battery is about 6 months old, and it only happens now (no matter what battery life) when i do 12-13 back to back recieve/send texting. I heard there may be a memory leak so i'm going to wipe/reinstall and see if it fixes it. if not then i'll shell otu for a battery.
    js, a battery should last more than 6 months with the heaviest of use. I've never had to replace a battery because I "used it up." Probably the longest I've used one is 1 1/2 years but still and I charge my phone every night regardless of how much or little is left on the battery.

    I'd consider the possibility that you have a bad handset. Could be wrong but consider it.....
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

  8. #8
    JCG3's Avatar
    JCG3 no está en línea Stack level 3
    Join Date
    Oct 2007
    PIN/ID
    Ask
    Posts
    306
    try using 4.2 for your device and see if the battery does the same thing.... it may just be a glitch with the install packet of the OS you are trying to load. so if 4.2 uses the whole battery, then delete the install packet for 4.5 and remove the 4.5 software from the computer and re-download the 4.5 OS install packet and make sure you get the most recent on for your device.

  9. #9
    thbassman's Avatar
    thbassman no está en línea Stack Professional
    Join Date
    Apr 2007
    PIN/ID
    ASKME4IT
    Posts
    10,235
    JB is also got a possibility there, it could be the handset is defective.
    Assuming its still in warranty, I would let my carrier replace my battery before I shelled out 50$ to possibly find our the handset is bad. Just a thought bro .....
    Hope this helps. . .

    Thbassman
    ~via BB Pearl ~

  10. #10
    jsweetser2's Avatar
    jsweetser2 no está en línea Stack level 2
    Join Date
    Feb 2008
    PIN/ID
    241EC7CA
    Posts
    42
    the fresh install didn't fix the problem, when the indicator shows teh battery at about 78% the phone just shuts off.

    I use my computer to charge my battery and i've been lazy enough to not use the 'safe remove' function, it's very likely i fried a cell somewhere close to the top of the battery charge when plugging it in and out a few times in a row. Same thing happens to memory sticks if you don't take the extra second. i'll bring it into the shop to have them look at it soon.

  11. #11
    ray_1060's Avatar
    ray_1060 no está en línea Stack level 2
    Join Date
    Dec 2007
    Posts
    23
    Same problem here with the battery, I called my provider and they sent me a new battery and same problem.

  12. #12
    thbassman's Avatar
    thbassman no está en línea Stack Professional
    Join Date
    Apr 2007
    PIN/ID
    ASKME4IT
    Posts
    10,235
    Quote Originally Posted by ray_1060 View Post
    Same problem here with the battery, I called my provider and they sent me a new battery and same problem.

    Ray maybe yours is te handset as JB said above, I would check with your carrier, if it is still in warranty.

    Quote Originally Posted by jsweetser2 View Post
    the fresh install didn't fix the problem, when the indicator shows teh battery at about 78% the phone just shuts off.

    I use my computer to charge my battery and i've been lazy enough to not use the 'safe remove' function, it's very likely i fried a cell somewhere close to the top of the battery charge when plugging it in and out a few times in a row. Same thing happens to memory sticks if you don't take the extra second. i'll bring it into the shop to have them look at it soon.
    J Sorry that didn't fix you, I would get a batt to try from my carrier b4 shelling out 50$

    HTH
    thbassman
    THBASSMAN

    Carpe Diem!!

    thbassmanatpinstackdotcom

    Check this out!!! Mobiletropolis

    My TORCH Rocks!

  13. #13
    bludevil35's Avatar
    bludevil35 no está en línea Stack level 1
    Join Date
    Jan 2008
    PIN/ID
    24408caf
    Posts
    15

    Question

    same issues here, it's like the phone doesnt know how much battery is left and then it just dies. If i plug the phone into a charger it reboots as soon as i plug it in without a battery pull. as Cajun man would say "FRUSTRATION"

  14. #14
    jblackfish's Avatar
    jblackfish no está en línea PINStacked!
    Join Date
    Dec 2007
    Posts
    11,116
    Is it possible that you guys have a battery CONNECTION problem or a meter problem? I'm still skeptical on your focus on the battery itself. I don't think a battery does things like turn a device off when it's at half-charge - the device may but the battery? Does the device run perfectly when pluged in via USB cable or other charger?
    For every complex problem there is a solution, that is simple, neat, .....and wrong! (H. L. Mencken) jblackfish(at)pinstack(dot)com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •