Just thought I would post a how-to on getting UMA working on an unlocked 8900.

My device is a T-Mobile 8900
My network is Rogers Canada
Running OS v.

With another Rogers blackberry-
Go into desktop manager, hook up Rogers networked blackberry (friends blackberry) and back-up device.
Unhook device from computer
Plug in Unlocked device (my T-Mobile blackberry) and click on advanced
Open back-up file on left column
Select trusted key store and click right arrow
Select handheld key store and click right arrow

In Escreen:

Select Mobile Network Engineering Screens
>Utilities >Session Manager
Press Menu key >UMA Options
Select Factory provisioning >menu key > edit

UMA Protocol Version should be: UMA v. 1.0.3
Un-check (default address) > UNC address: hbsc.uma.rogers.com (port 14001)
Un-check (SEGW address) > SEGW address: segw.uma.rogers.com
SEGW certificate: select ca.rogers.com (should be there now from the restore)
click back (save) > back (save)

Close everything and back to main screen- UMA should be enabled in the top corner.
Hard reset just to get everything in order.