Results 1 to 5 of 5

I'm using a unlocked Storm 2 on Rogers. Its a Verizon 9550, and when I ... BlackBerry Storm forum

  1. #1
    shanedogg's Avatar
    shanedogg no está en línea Stack level 2
    Join Date
    May 2007
    Posts
    51

    Arrow Unknown Number message

    Advertisement



    I'm using a unlocked Storm 2 on Rogers. Its a Verizon 9550, and when I am receiving calls from people I know, who are in my contact list I get an 'Unknown Number' message.

    I tried calling Rogers customer service and having them remove the Name Display from my value pack,(a solution I found in a previous thread) but they told me they cannot do this. They said that they cant adjust whats in the value pack, and to break it down and separate the items would cost me considerably more than what I'm paying now.

    On my Rogers BB Bold that I was using until this week calls would show up with names and numbers.

    Does anyone have a solution to this? I tend to not answer unknown numbers as they are usually telemarketers and other idiots. But now I don't know if its someone I know calling or not.

  2. #2
    boricua's Avatar
    boricua no está en línea Stack level 3
    Join Date
    Jan 2008
    Posts
    152
    Turn off content protection.

  3. #3
    shanedogg's Avatar
    shanedogg no está en línea Stack level 2
    Join Date
    May 2007
    Posts
    51
    Could you give me more details?

  4. #4
    boricua's Avatar
    boricua no está en línea Stack level 3
    Join Date
    Jan 2008
    Posts
    152
    It seems that option is no longer available on seftware version 5.0
    You can try disabling encrytion under options > security options > encryption.

  5. #5
    Enzo10's Avatar
    Enzo10 no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    4
    call them and ask them to remove whos calling feature or name calling...but keep caller id... it will fix the problem..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •