Page 4 of 5 FirstFirst 12345 LastLast
Results 46 to 60 of 69

I have noticed a week of cycling the battery has helped. Also the .75 seems ... BlackBerry Storm forum

  1. #46
    gtvett's Avatar
    gtvett no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    4

    Advertisement



    I have noticed a week of cycling the battery has helped. Also the .75 seems to helps. I have 2 hrs of talk, and a couple of long (read slow type r) emails and at half charge.

  2. #47
    hazzmatte's Avatar
    hazzmatte no está en línea Stack level 2
    Join Date
    Dec 2008
    Posts
    67
    Changed my network setting to edvo and bat is performing well. 50% after 8 hours

    ~via BB (wap.pinstack.com)~

  3. #48
    RCode's Avatar
    RCode no está en línea Stack level 3
    Join Date
    Mar 2007
    PIN/ID
    304F0A29
    Posts
    139
    Well mine Storm would die after about 12 hours from a full charge, with little to hardly no use. I would make no phone calls, use data for about an hour or two, and it would be at 5% from a 100% in 12 hours. I charged it last night before I went to bed, and it's at 40% now, and I haven't even used it other then to check 2-3 emails.

    Has any Telus users updated there firmware? I'm running 4.0.76 which may be the latest?!?! I don't use BT either. I think I'm going to request a new battery under warranty today. Even charging everyday when I hardly use it is crazy, I want to be able to use this when I need it and not worry about my battery.

    I had the brightness of the screen at 10, and changed the network to 1XEV, so we'll see if that tweaks it abit. But I'll have to see I guess.

  4. #49
    hitdog042's Avatar
    hitdog042 no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    118
    Quote Originally Posted by RCode View Post
    Well mine Storm would die after about 12 hours from a full charge, with little to hardly no use. I would make no phone calls, use data for about an hour or two, and it would be at 5% from a 100% in 12 hours. I charged it last night before I went to bed, and it's at 40% now, and I haven't even used it other then to check 2-3 emails.

    Has any Telus users updated there firmware? I'm running 4.0.76 which may be the latest?!?! I don't use BT either. I think I'm going to request a new battery under warranty today. Even charging everyday when I hardly use it is crazy, I want to be able to use this when I need it and not worry about my battery.

    I had the brightness of the screen at 10, and changed the network to 1XEV, so we'll see if that tweaks it abit. But I'll have to see I guess.

    Battery on mine has been fine, unless you run the Garmin navigation. I went from 4 bars to 2 with just one 15 mile trip. Of course, I didn't have a lighter cord, and do now.

  5. #50
    rrife's Avatar
    rrife no está en línea Stack level 2
    Join Date
    Mar 2007
    Posts
    28
    I can go 3 days without charging (maybe more if I push it) with 30-40 minutes phone usage a day, couple dozen emails or text messages a day, morning alarm, auto on/off sleeps the system for 6 hrs at night.

  6. #51
    trevzw's Avatar
    trevzw no está en línea Stack level 1
    Join Date
    Jan 2008
    Posts
    1
    I would turn off GPS, many times its on by default. If you dont use GPS that often or want to manually turn it on with an app then change the options to ...

    Go to advanced options >GPS

    first option - leave
    second option - change to E911 only (emergency only)
    third option - disable.

  7. #52
    RCode's Avatar
    RCode no está en línea Stack level 3
    Join Date
    Mar 2007
    PIN/ID
    304F0A29
    Posts
    139
    I find it crazy I have to disable all those options to just have a phone that works....

    I don't have Garmin. I use the GPS every now and then, I haven't talked more then 5 minutes on the phone, and I've charged it about 12 times in the last 5 days. I charged it yesterday before I left work. I came home, put my phone down, didn't pick it up until this morning and it was dead again.

    I've ordered a new battery under warranty, along with another wall charger and a car charger....

  8. #53
    thymaster's Avatar
    thymaster no está en línea Stack level 3
    Join Date
    Jul 2008
    Posts
    198
    My Battery icon keeps saying the phone is charging even after 5 hours pluged in. Is anybody else phones doing this?
    ~via BB (wap.pinstack.com)~

  9. #54
    RCode's Avatar
    RCode no está en línea Stack level 3
    Join Date
    Mar 2007
    PIN/ID
    304F0A29
    Posts
    139
    Quote Originally Posted by thymaster View Post
    My Battery icon keeps saying the phone is charging even after 5 hours pluged in. Is anybody else phones doing this?
    ~via BB (wap.pinstack.com)~
    I believe it will continue to say it's charging, even if it's at 100%.

    go to Options > Status and check to see what % your battery is at.

  10. #55
    thymaster's Avatar
    thymaster no está en línea Stack level 3
    Join Date
    Jul 2008
    Posts
    198
    Status says 100%.
    Last edited by thymaster; 12-16-2008 at 01:59 PM.

  11. #56
    dean0uga's Avatar
    dean0uga no está en línea Stack level 3
    Join Date
    Dec 2008
    Posts
    415
    what do you mean says its charging? the yellow bolt is when it is charging and actually needs it, if after 10 hours (on wall charger, and completely dead) it still has this bolt, then theres something wrong... should go away after its completely charged

  12. #57
    thymaster's Avatar
    thymaster no está en línea Stack level 3
    Join Date
    Jul 2008
    Posts
    198
    The yellow bolt is not going away. I have drained out and fully charge 3 times and the bolt is still there. Compared to everyone on the forum though, I think my battery life is still better then what everyone is claiming. It last just as long as my Curve without changing any settings or doing anything different.

  13. #58
    dean0uga's Avatar
    dean0uga no está en línea Stack level 3
    Join Date
    Dec 2008
    Posts
    415
    Quote Originally Posted by thymaster View Post
    The yellow bolt is not going away. I have drained out and fully charge 3 times and the bolt is still there. Compared to everyone on the forum though, I think my battery life is still better then what everyone is claiming. It last just as long as my Curve without changing any settings or doing anything different.
    very strange, how long have you charged it for?... the max amount of time, last night, mine was on 95% for over an hour, and 100% for i think 45 minutes

  14. #59
    e-berry's Avatar
    e-berry no está en línea Stack level 3
    Join Date
    Nov 2007
    PIN/ID
    23001419
    Posts
    308
    i've noticed that as well... i charge mine seems like forever and when it reaches 100% i still have the yellow bolt to signify that it's still charging.. i thought as well that it would go away once it's done...

    since my girlfriend and I both got storms, i will ask her or check hers to see if the same thing happens.
    --
    More than meets the eye.

  15. #60
    AUmike734's Avatar
    AUmike734 no está en línea Stack level 1
    Join Date
    Jul 2008
    PIN/ID
    304978F2
    Posts
    3
    Quote Originally Posted by catstide View Post
    one thing i have changed on my storm is screen brightness. it comes default 100. i changed mine to 10. sounds like it would be hard to see but it is not. give it a try. it might be part of the reason i'm getting better battery life.
    I did the same as well as drop the dimmer settings to the lowest. Worked beautifully. Beforehand, I was having to charge a couple of times/day.

Page 4 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •