Results 1 to 10 of 10

I am reading about the os on the phones and I was wondering since alot ... BlackBerry Storm forum

  1. #1
    joenash's Avatar
    joenash no está en línea Stack level 1
    Join Date
    Sep 2008
    PIN/ID
    3050DBF9
    Posts
    6

    Smile BlackBerry OS ?????

    Advertisement



    I am reading about the os on the phones and I was wondering since alot of storms are unlocked and either on t-mobile or att, But are of course made for other european GSM carriers how can you know what os you are loading on yur phone and how will you know it work? Also when I connect my storm to my computer and do the check for updates it wants to down grade the os, The phone says when you go to the about screen it has os 4.7.0.151 , (platform 4.0.0.181) But then it wants to downgrade it to 4.7.0.148 . I dont understand that, I some how found on reserch in motions website a new os 4.7.0.203 , But it says it is for bell mobility , would that os work ? and wouldn't you want the most resent os release?
    I bought the storm from some one using it on verizon and went to a cell store and they unlocked it and for the most part it has been working okay, I just have some of the common complaints as it lagging and the EDGE turning to edge, and just for the most part the phone and e-mail works great, it is just the other stuff that lags or locks up the phone when you go to use it. I had a curve 8900 before and I loved it was fast and worked well and never locked up. Kind of dissapointed in storm and was thinking about going back to 8900 or trying G1 or G2, I downloaded BB Appworld and everything you have to pay for, on the android platform their are tons of FREE apps.
    I don't know I want to like the storm cause I had two blackberries before and I wanted a phone with a larger screen and a touch screen but sometimes it is kind of tough when it always locks up, well anybodys elses thoughts or help!
    Joenash

  2. #2
    RogerG's Avatar
    RogerG no está en línea Stack Administrator
    Join Date
    Nov 2006
    Posts
    21,111
    Joe,

    As long as the OS is for your specific device, it doesn't matter what carrier it is from. Since the 4.7.0.203 OS you found is an official RIM release, you might want to go ahead and upgrade, but if your device is running well, you also might want to consider leaving well enough alone!

    There are those of us who are truly addicted to anything "latest and greatest" and can't help themselves but upgrade to the latest release any time it comes out. Again, if you are confident in your abilities to upgrade/downgrade, go ahead and do the .203.

  3. #3
    ealvnv's Avatar
    ealvnv no está en línea Stack Professional
    Join Date
    Nov 2008
    PIN/ID
    ask me
    Posts
    3,242
    If you read carefully 4.7.0.203 is the package version but, but the software is ver 4.7.0.148 that's why it ask you to downgrade, if you look for Os 4.7.0.151 it has a higher package version

    Hope that make sense
    BlackBerry9000/5.0.0.130 Profile/MIDP-2.1 Configuration/CLDC-1.1 VendorID/102

  4. #4
    RogerG's Avatar
    RogerG no está en línea Stack Administrator
    Join Date
    Nov 2006
    Posts
    21,111
    Welcome back, Elmer.

  5. #5
    sharingheart777's Avatar
    sharingheart777 no está en línea Stack level 1
    Join Date
    Jul 2007
    PIN/ID
    20877ce9
    Posts
    14
    hello everyone, i have a brand new unlocked storm and i cant get my email to it nor can i get on the internet i have tried to downgrade it downloaded the older os and it doesnt register on the desk top manager to give the option to downgrade.. i love this phone but need my email.. any help before i just throw this thing.. lol email whatteva2001@gmail.com as i cant get my tmo on my phone and i dont get on the computer often but would love some help with this.. thanks carrie

  6. #6
    joenash's Avatar
    joenash no está en línea Stack level 1
    Join Date
    Sep 2008
    PIN/ID
    3050DBF9
    Posts
    6

    Smile yes

    Quote Originally Posted by ealvnv View Post
    If you read carefully 4.7.0.203 is the package version but, but the software is ver 4.7.0.148 that's why it ask you to downgrade, if you look for Os 4.7.0.151 it has a higher package version

    Hope that make sense
    BlackBerry9000/5.0.0.130 Profile/MIDP-2.1 Configuration/CLDC-1.1 VendorID/102

    After I posted this I just realized that their is a package version, and a platform version, too many diferent kinds of versions of software.
    I wonder why you delete the vender files? I have not done that I am afraid something will not work!
    does anyone know how to fix the EDGE edge problem on T-Mobile?
    Joenash

  7. #7
    ealvnv's Avatar
    ealvnv no está en línea Stack Professional
    Join Date
    Nov 2008
    PIN/ID
    ask me
    Posts
    3,242
    Quote Originally Posted by RoGro View Post
    Welcome back, Elmer.
    Thanks Roger, glad to be back...
    BlackBerry9000/5.0.0.130 Profile/MIDP-2.1 Configuration/CLDC-1.1 VendorID/102

  8. #8
    MStrawder's Avatar
    MStrawder no está en línea Stack Pro
    Join Date
    Jul 2008
    PIN/ID
    Ask
    Posts
    1,825
    Quote Originally Posted by joenash View Post
    After I posted this I just realized that their is a package version, and a platform version, too many diferent kinds of versions of software.
    I wonder why you delete the vender files? I have not done that I am afraid something will not work!
    does anyone know how to fix the EDGE edge problem on T-Mobile?
    Deleting the vendor.xml file was to avoid locking your device to the carrier the OS was released for. As Roger mentioned above, the OS is device specific, but not carrier specific (if you remove that file).
    "Our greatest fear is not that we are inadequate, but that we are powerful beyond measure" ~ Marianne Williamson
    Current OS list by device
    How to upgrade your OS

  9. #9
    MStrawder's Avatar
    MStrawder no está en línea Stack Pro
    Join Date
    Jul 2008
    PIN/ID
    Ask
    Posts
    1,825
    Quote Originally Posted by sharingheart777 View Post
    hello everyone, i have a brand new unlocked storm and i cant get my email to it nor can i get on the internet i have tried to downgrade it downloaded the older os and it doesnt register on the desk top manager to give the option to downgrade.. i love this phone but need my email.. any help before i just throw this thing.. lol email whatteva2001@gmail.com as i cant get my tmo on my phone and i dont get on the computer often but would love some help with this.. thanks carrie
    You're using this with T-Mo then. Are you able to place calls on the device at all? If so, then you may just to have the service books sent to your device. On your device you should see, "Setup Internet Email". Clicking that should take you to the site where you will add your email addresses for your device and a link that says 'Send (or Resend) Service Books'. If you haven't added your email addresses on that site yet, go ahead and do it, then send the service books.
    "Our greatest fear is not that we are inadequate, but that we are powerful beyond measure" ~ Marianne Williamson
    Current OS list by device
    How to upgrade your OS

  10. #10
    ealvnv's Avatar
    ealvnv no está en línea Stack Professional
    Join Date
    Nov 2008
    PIN/ID
    ask me
    Posts
    3,242
    Quote Originally Posted by MStrawder View Post
    Deleting the vendor.xml file was to avoid locking your device to the carrier the OS was released for. As Roger mentioned above, the OS is device specific, but not carrier specific (if you remove that file).
    What deleting the vendor.xml file does it allow the OS to load to your device, if you don't delete it won't load, it won't lock the device to any carrier...
    BlackBerry9000/5.0.0.130 Profile/MIDP-2.1 Configuration/CLDC-1.1 VendorID/102

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •