Results 1 to 5 of 5

Hi guys, I have recently started experiencing problems with my Bold. I can't remember making ... BlackBerry Bold forum

  1. #1
    tigerbluemusic's Avatar
    tigerbluemusic no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    167

    uncaught exception: net.rim.device.api i18n.MissingResourceException

    Advertisement



    Hi guys,

    I have recently started experiencing problems with my Bold. I can't remember making any particular changes to cause this but it seems to effect Yacta mainly. I have searched this forum and have seen another person with a similar error except the app effected was different. Yacta seems to be the only thing that won't work but I really want it fixing. I have done a full OS wipe and re-install and I have done 2 factory resets with no luck. Can anyone help? I'm wondering if it might be worth doing another full OS re-install?

    Name: MissingResourceException
    GUID: 9c3cd62e3320b498
    Time: Aug 14, 2009 20:11:19
    No detail message
    net_rim_cldc-4
    ResourceBundle
    getObject
    0x9367
    net_rim_cldc-4
    ResourceBundle
    getString
    0x939E
    net_rim_bb_appworld-7
    BlackBerryAppStoreResources
    getString
    0x1AF6
    net_rim_bb_appworld-7
    AppWorldHierarchy
    getFriendlyName
    0x496
    net_rim_bbapi_messagelist
    ApplicationMessageFolderRegistry
    <private>
    0x2048
    net_rim_bbapi_messagelist
    ApplicationMessageFolderRegistry
    setRootFolderName
    0x1D37
    Yatca-1
    YatcaMainScreen
    <init>
    0x2D46
    Yatca-1
    Yatca
    <init>
    0xF69
    Yatca-1
    Yatca
    main
    0xCD6

  2. #2
    MStrawder's Avatar
    MStrawder no está en línea Stack Pro
    Join Date
    Jul 2008
    PIN/ID
    Ask
    Posts
    1,825
    The error generated is an API function call, but I am most certainly not fluent in BB programming, so I can't say for sure what it's trying to call. When you say a full OS wipe, are you saying you cleared it with something like JL_Cmder or BBSAK and the reinstalled the OS? If you're just reinstalling the same OS from your system, you may be copying the same corrupted install over and over. I would probably backup my contacts, messages, etc., wipe the device with JL_Cmder or BBSAK and reinstall a fresh copy of the OS. By that I mean to remove any instances of it from your PC and download a fresh copy. This should alleviate the software problem.
    "Our greatest fear is not that we are inadequate, but that we are powerful beyond measure" ~ Marianne Williamson
    Current OS list by device
    How to upgrade your OS

  3. #3
    tigerbluemusic's Avatar
    tigerbluemusic no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    167
    I used BBSAK to wipe and re-install the OS. Have tried with no luck. However I've not tried clearing any traces of OS from my pc though so I will give it another go and report back.

    Having searched google a bit I can't find many instances of this cropping up for other people.

    Cheers for you help
    BlackBerry9000/4.6.0.291 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/142

  4. #4
    tigerbluemusic's Avatar
    tigerbluemusic no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    167
    I did another complete wipe using BBSAK last night.
    After the re-install, I restored my previous back up (not sure if this is a good idea). I then started to put my apps back on. The first I loaded was in fact Yacta. I then battery pulled my phone to see if I got the error message. I didn't and Yacta functioned fine (messages came in fine and went to my inbox). so I started loading my apps. However, the next time I battery pulled, I got the same error message again.

    I suspect it must be another app I am installing which corrupts my os. Question is - which one? The only solution I can think of is to wipe my phone, install an app at a time with a battery pull after each to identify the offending app then start again without that particular app. I'm surprised that no one else has this problem though.

    Just for the record, I have installed the following apps...
    BB robot scheduler
    Quickpull pro
    Bbfile scout
    Quick launch
    Zonasnap
    BB messenger 5.0 (issue started before this)
    Shrinkit
    Logmaid
    Ontocalendar
    Blackberry app store
    Google app
    Google sync
    Google chat
    Google mail
    Google maps
    Windows live messenger
    Socialscope
    Facebook
    Beejive
    Viigo
    Monilink
    Bloomberg
    Strands Music Player
    Forward, reply & edit
    Berryreview app store
    Shazam

    Not sure whether there are any known issues with the above.
    BlackBerry9000/4.6.0.221 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/142

  5. #5
    tigerbluemusic's Avatar
    tigerbluemusic no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    167
    Boy do I feel an idiot. I can't believe I tried all those things to fix this issue when the solution is outlined on the Yatca website...

    The MissingResourceException problem that a number of users have reported is caused by an incompatibility between Yatca and the latest version of App World (1.1.0.11). Installing the latter seems to change the behaviour of the message list integration APIs that are vital to the successful operation of Yatca. We have alerted RIM to the problem. If App World is uninstalled Yatca functions correctly again so we suggest you uninstall App World should you wish to continue using Yatca.

    Cheers for your concern and support MStrawder. I guess I will get the apps I want and uninstall Appstore.

    Cheers
    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •