Results 1 to 7 of 7

First off, Merry Christmas! So I've had my Bold since the day it was released ... BlackBerry Bold forum

  1. #1
    EricScott's Avatar
    EricScott no está en línea Stack level 2
    Join Date
    Feb 2007
    Posts
    80

    Question Uncaught Exception - Java.Lang.NullPointerException

    Advertisement



    First off, Merry Christmas!

    So I've had my Bold since the day it was released on AT&T....never had any problems whatsoever (still using .167 which came preloaded). Then last night in the middle of the night I got a phone call....tried to ignore it so the phone would stop ringing and I think (it was 3 am) I entered my password (usually you don't have to to silence a call)...then I get the following message:

    "Uncaught Exception: Java.Lang.NullPointerException"

    Now everytime I reboot my phone (tried a few Alt/Shift/Deletes and a battery pull) I get the error after the security check on startup.

    After I hit OK the phone seems to operate normally (although I haven't tested it a ton).

    The one thing I noticed which no longer works (no idea if it is related) is the SMS shortcut key in the message list (hit Alt S to filter just your SMS messages). When I hit that nothing happens. Alt-M (MMS), Alt-P (Calls) and Alt-V (voicemails) don't seem to work either. But the regular email related ones (Alt-O, I, and a few others I created) seem to work fine. If I go to Search / Recall all of the shortcuts are listed there and has the shortcut of S, M, etc in (). BTW I have my Messages / SMS combined rather than Theme Controlled.

    I am using the AT&T theme that came w/ the phone and the only 3rd party apps I have installed (and they have been installed for a while w/ no issues) are Google Maps, Facebook and Opera Mini.

    Anyway kind of bummed to be seeing this error. Searched around and it seems the recommended solution is to do a software upgrade? I'm not totally opposed to doing that but would prefer not to.

    Any help would be greatly appreciated.

    TIA

    Eric

  2. #2
    krosli's Avatar
    krosli no está en línea Stack level 4
    Join Date
    Dec 2007
    PIN/ID
    747101D2
    Posts
    539
    Hey Eric. I have had the same issue as you as well. I think that the OS that came pre loaded has a bug that causes that. Even called my tech support and explained to them about the issue. They told me that the best is still to upgrade. I have not done it yet.

    Not too sure about you but when I get my error messages, I have to pull the battery out at least three times in order for my berry to function properly. So far, I have not had any issues. It comes and goes. I just tough it out until I can't then I will upgrade. Sorry couldn't be much help. Feel free to add me on BB Msg.....207B2423

  3. #3
    EricScott's Avatar
    EricScott no está en línea Stack level 2
    Join Date
    Feb 2007
    Posts
    80
    Thanks for the reply. The weird thing is I have been using .167 without ANY (I mean ANY) problems for probably 50 days or so. This just happened last night. As far as I can tell the BB seems to be functioning properly (other than the message shortcut issue I describe above) but I haven't tried out that many functions so far this morning.

    I have done 3 Alt/Shift/Del resets and one battery pull and the only time I get the error is right after the bootup when I go to unlock the keyboard.

    So not a major inconvenience (so far) but just annoying that things aren't working right.

    Will keep you posted if I find anything out.

  4. #4
    krosli's Avatar
    krosli no está en línea Stack level 4
    Join Date
    Dec 2007
    PIN/ID
    747101D2
    Posts
    539
    Mine is the same. I will do a batt pull...wait a few minutes and then it is like deja vu. The error message will come on at least three times before my berry is functioning properly again. I will probably call my tech support guys and walk me through the upgrade process.

  5. #5
    jkai2188's Avatar
    jkai2188 no está en línea Stack level 5
    Join Date
    May 2007
    Posts
    752
    well im having this issue as well, i think it may have something to do with the media on the device, thats one of the things that i've read thus far searching through forums, but the only problem is, is that NO ONE KNOWS WHAT ITS GOING TO TAKE TO GET THIS TO GO AWAY. this error is actually causing major problems to my phone, i can no longer see recent calls in my call log, i can turn the call logging to show in my messages but thats a pain, and i didnt have any of these problems when i got the phone the week before it came out. i have no third party apps, i have nothing else but just the basic phone... not quite sure what to do, im calling blackberry.
    Bold - 5.0.0.93 / 8310 - 4.5.0.81 ---- AT&T
    8330 - 4.5.0.77 ---- Sprint


    Blackberry's are a lifestyle

    jeff.kaiser88@yahoo.com

  6. #6
    EricScott's Avatar
    EricScott no está en línea Stack level 2
    Join Date
    Feb 2007
    Posts
    80
    The most frustrating part about this error is that it seems like each of us are seeing different side effects. Fortunately (for me), the only issues I have noticed are the error popup whenever I reboot my BB (never see it otherwise) and the Alt-S / M shortcuts not working in my message list. Others seem to be having much more severe issues. But there doesn't seem to be any consistency.

    That being said, I am planning to install a newer version of the software on Monday when I get to the office.

  7. #7
    EricScott's Avatar
    EricScott no está en línea Stack level 2
    Join Date
    Feb 2007
    Posts
    80
    Just finished installing 210 - it's beta but has gotten pretty stellar reviews so I figured it was worth a shot. Install was incredibly easy and FAST (entire backup, restore, etc took 30 mins compared to an hour plus on my old Pearl). Everything seems to be working ok...java error hasn't appeared, my SMS shortcut works. So for the time being I'm satisfied...hopefully I won't notice any issues w/ this OS over time.

    BTW, the browser in 210 seems snappier (which others have reported as well). Lovin it so far.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •