My handset was replaced recently under warranty.

On the new one, whenever I get an incoming SMS, it creates a "shadow" entry in the e-mail in-box that reads like this;

Message status: Message included an invalid address
//+[sender's telephone #]
[sender's message]

I have tried two things;

Message options->General options->SMS and Email inboxes->Separate
Switch theme

Neither makes any difference. Any bright ideas? BTW I'm with o2 UK and use device software v4.6.0.266

Thanks in advance for the help.