Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 49

Never have had an ounce of problem with the ONE I have.... BlackBerry Bold forum

  1. #16
    sooner's Avatar
    sooner no está en línea Stack Professional
    Join Date
    Aug 2008
    Posts
    1,092

    Advertisement



    Never have had an ounce of problem with the ONE I have.

    iLord is DEAD!


  2. #17
    ealvnv's Avatar
    ealvnv no está en línea Stack Professional
    Join Date
    Nov 2008
    PIN/ID
    ask me
    Posts
    3,242
    one year, one device.... That's all I'll say

  3. #18
    Delfim's Avatar
    Delfim no está en línea Stack Moderator
    Join Date
    Mar 2007
    PIN/ID
    Nope!
    Posts
    14,886
    No problems with any Bold I've had ... Had 3 but sold them off to friends and they are running well.
    The glitches I encountered were all from downloaded applications and themes,
    Usually minor stuff which got fixed pretty quickly. The Bold never let me down ! The only gripe I have, but common to all BB's is how easy it is to get the screen
    Scratched... RIM should take a page from IPhone and improve on this !

  4. #19
    dushdavj's Avatar
    dushdavj no está en línea Stack Professional
    Join Date
    Jan 2008
    PIN/ID
    Ask Me
    Posts
    2,283
    Bold on ATT for just under a year, no problems so far

  5. #20
    Capdot's Avatar
    Capdot no está en línea Stack level 5
    Join Date
    Sep 2007
    Posts
    1,958
    On my original Bold since Feb. of this year.

  6. #21
    mrvtx's Avatar
    mrvtx no está en línea Stack level 2
    Join Date
    Aug 2007
    Posts
    53
    Got my AT&T Bold in January, still running fine.

  7. #22
    psi chick's Avatar
    psi chick no está en línea Stack level 4
    Join Date
    Mar 2007
    Posts
    465
    got my bold last december, still on my original.

    the other half is on his third however since december. the first had the battery overheating issue which turned into a white screen and the second one i don't remember what it was doing, i think it was the trackball or something silly.

  8. #23
    HyperM3's Avatar
    HyperM3 no está en línea Stack level 3
    Join Date
    Oct 2006
    Posts
    451
    I picked up my bold the day it came out last nov 4th. Upgraded it with pretty much every beta OS that came out. Even dropped it in the toilet 3 months ago. Thing is working like a tank and just won't quit. Doesn't mean I'm not looking forward to the new bold though.

  9. #24
    kayhites717's Avatar
    kayhites717 no está en línea Stack level 4
    Join Date
    Feb 2009
    PIN/ID
    Ask Me!!
    Posts
    755
    Received first Bold December of 08, on my 5th device. Received 5th device in June had no problems since. Most issues were screen issues, white screen, screen flickering on and off, getting colored lines through it. One the video didn't work, and two of those devices had browser issues as well, but, this one is working good for the most part. Will be UG to the 9700 as soon as I can, tho.

  10. #25
    Allwin's Avatar
    Allwin no está en línea Stack level 2
    Join Date
    Jul 2008
    Posts
    58
    Did you go through ATT to get your replacement or RIM?

  11. #26
    swtmango's Avatar
    swtmango no está en línea Stack level 2
    Join Date
    Jun 2007
    PIN/ID
    22f00895
    Posts
    82
    Just yesterday I posted that I haven't had a problem with my bold...this morning I accidently dropped it on concrete and now I have a gray square blocking blocking 1/4 of my screen..what a bummer! Guess i have to get a replacement now!

  12. #27
    jag257's Avatar
    jag257 no está en línea Stack level 3
    Join Date
    Dec 2007
    Posts
    237
    Quote Originally Posted by OzzieDog View Post
    I am on number 8 on AT&T. They have all had random restarts, screen freezing, white screen and dropped calls. I have no third party software on them. It didn't matter what version of OS they were running. Even the new AT&T .297 is not working for me.
    .297 is working fine on my Bold and my wifes. All other issues mentioned above we've experienced.
    JAG257
    iPhone4
    " Losers try their best, WINNERS do what ever it takes"

  13. #28
    GregGebhardt's Avatar
    GregGebhardt no está en línea Stack level 4
    Join Date
    Jun 2007
    PIN/ID
    No Way
    Posts
    680
    I bought three Bolds for my upper employees and not one has had a single problem.
    Greg
    in Jax, FL

  14. #29
    kayhites717's Avatar
    kayhites717 no está en línea Stack level 4
    Join Date
    Feb 2009
    PIN/ID
    Ask Me!!
    Posts
    755
    Quote Originally Posted by Allwin View Post
    Did you go through ATT to get your replacement or RIM?
    I went through ATT with the warranty department. I told ATT that I wanted to go directly to RIM, they gave me some crap story about since I was under contract with ATT, I had to only go thru warranty at ATT, of course, later I found out that was a load.

  15. #30
    Morgase's Avatar
    Morgase no está en línea Stack Professional
    Join Date
    May 2008
    PIN/ID
    ASKME4IT
    Posts
    1,118
    I'm on number two. My first bold had a battery issue and I turned it in 2 days after I bought it. Got this one in March and problems until yesterday when I was doing batt pulls almost every 30 minutes. Used bbsak to wipe it and friends sent me the links to dl .314. Minor problems with it but I might have gotten a bad download. I can deal with for now since I'm getting the Bold 9700 as soon as its released.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •