I have upgrade the Massenger 5.0 on my OS 4.6.282, but everytime when I start my DM (5.01), it is asking me to upgrade the 4.6 core...when I do that, it will remove my Blackberry Messanger 5.0...and if I don't do that, it's annoying asking me to upgrade. Also, I noted that eveytime if I shutdown the DM with Outlook running, my outlook will get an error saying some program has terminated...and I end up having to shutodwn and restart outlook. Any help would be much appreciated.