Every time I get a text message my 2 day old torch tells me the sim card is full. I know how to turn that off on my old phone the bold and I did the same thing and the on/off for sim messages is not there. I went to support at blackberry and it said to do this for my phone.
On the Home screen, click the Messages icon.
Press the key > Options > Text Messaging.
Change the Leave Messages On SIM Card field to Yes.
Press the key > Save.

Its still not there. I see other people posted on other sites about this problem with no real good answer. Any thoughts?