Results 1 to 10 of 10

How does one fix this issue? Whilst tryping on the physical and virtual keyboards, I ... BlackBerry Torch forum

  1. #1
    sk1d's Avatar
    sk1d no está en línea Stack level 2
    Join Date
    Jun 2007
    Posts
    84

    Post keyboard showing special characters

    Advertisement



    How does one fix this issue? Whilst tryping on the physical and virtual keyboards, I usually have characters like ű when I hit the U key and Ó when I hit the O key.

    Now, I understand you can have said special characters by holding on to a key and scrolling with the trackpad to change them, but I don't do this and it changes itself.


    I only have two languages on my phone and these are English and French and these characters aren't used in those languages.

    What am I doing wrong, if anything? I have wiped my phone several times and reset its settings to no avail.
    Any help will be greatly appreciated.

  2. #2
    RayZ's Avatar
    RayZ no está en línea Stack level 5
    Join Date
    Sep 2007
    Posts
    1,573
    It's the encoding...should be set to UTF-8. If you nedd directions on how to set this let me know.

  3. #3
    sk1d's Avatar
    sk1d no está en línea Stack level 2
    Join Date
    Jun 2007
    Posts
    84
    Thanks RayZ. I would very much appreciate the directions on how to go about it.
    Thanks again.

    Quote Originally Posted by RayZ View Post
    It's the encoding...should be set to UTF-8. If you nedd directions on how to set this let me know.

  4. #4
    RayZ's Avatar
    RayZ no está en línea Stack level 5
    Join Date
    Sep 2007
    Posts
    1,573
    This is what I did on my 9700 to fix this issue:
    open browser>menu>options>scroll to default text encoding>UTF-8 and save changes
    When I would text I would get the same strange characters and this solved it, let me know if it works on the Torch.

  5. #5
    sk1d's Avatar
    sk1d no está en línea Stack level 2
    Join Date
    Jun 2007
    Posts
    84
    I have followed your instructions to the leter. Shall monitor it for a couple of days and report back
    Thanks.

    Quote Originally Posted by RayZ View Post
    This is what I did on my 9700 to fix this issue:
    open browser>menu>options>scroll to default text encoding>UTF-8 and save changes
    When I would text I would get the same strange characters and this solved it, let me know if it works on the Torch.

  6. #6
    sk1d's Avatar
    sk1d no está en línea Stack level 2
    Join Date
    Jun 2007
    Posts
    84
    That has certainly helped with the frequency. However, it did not get rid of the problem.
    Any other tips?
    Quote Originally Posted by RayZ View Post
    This is what I did on my 9700 to fix this issue:
    open browser>menu>options>scroll to default text encoding>UTF-8 and save changes
    When I would text I would get the same strange characters and this solved it, let me know if it works on the Torch.

  7. #7
    lespend's Avatar
    lespend no está en línea Stack level 2
    Join Date
    Jun 2007
    PIN/ID
    22DOE92E
    Posts
    21
    My Torch did this the other night, and started moving the curser all over the screen on its own... I did a better pull and it has fixed it so far...

  8. #8
    sk1d's Avatar
    sk1d no está en línea Stack level 2
    Join Date
    Jun 2007
    Posts
    84
    Same happens to me too.

    Quote Originally Posted by lespend View Post
    My Torch did this the other night, and started moving the curser all over the screen on its own... I did a better pull and it has fixed it so far...

  9. #9
    RayZ's Avatar
    RayZ no está en línea Stack level 5
    Join Date
    Sep 2007
    Posts
    1,573
    Quote Originally Posted by sk1d View Post
    That has certainly helped with the frequency. However, it did not get rid of the problem.
    Any other tips?
    Try following the same instructions to encoding, but choose "windows 1253" instead...let me know if that stops the special characters.

  10. #10
    RayZ's Avatar
    RayZ no está en línea Stack level 5
    Join Date
    Sep 2007
    Posts
    1,573
    http://blogs.msdn.com/b/shawnste/arc...15/396312.aspx this article talks about not using default encoding. You could try using UTF-16BE or UTF-16LE. Just keep trying the different encodings that are native, and you'll find the one that does the best job.
    Native encodings:
    UTF-8
    UTF-16
    UTF16BE or LE
    windows 1252, 1253,1256,1258, 1254,1250,1255
    *note: the UTF encoding will have a more uniform result....good luck, any other questions just ask.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •