Page 7 of 14 FirstFirst ... 23456789101112 ... LastLast
Results 91 to 105 of 208

Originally Posted by jtekt I have a bottom hidden dock going for the Bold right ... Software & Theme Development forum

  1. #91
    holster27's Avatar
    holster27 no está en línea Stack level 3
    Join Date
    Aug 2007
    PIN/ID
    303721d5
    Posts
    392

    Advertisement



    Quote Originally Posted by jtekt View Post
    I have a bottom hidden dock going for the Bold right now and I have one simple question. I have some 3rd party apps in my JScroll and my theme is set up (through themebuilder) so that when you scroll over an application, the name of it shows up on the screen. This works for all of my buttons except for the third party apps.

    Like I said before, in composer all of my buttons are set up as "device order" except for two which are set as specific 3rd party applications (it's like this because I customized how they look, didn't like the original application icons because they don't match the rest of the icons in the theme.)

    Any idea how to fix this?
    There's an easier way, you can setr the third party app, but don't put in the app name, that way it will set up with the icon picture that you want. Then you go into the code and just input the next "slot" in the appropriate place and then it should show up on your status text. If you have figured out how to do third party apps, you should be to the point you can do this, if u have any problems, PM me.
    ~via smartphone mobile.pinstack.com~

  2. #92
    chottomatte's Avatar
    chottomatte no está en línea Stack level 1
    Join Date
    May 2009
    Posts
    14
    I'm hoping I can get a lil more help with this hidden dock thing please. More specifically, as this applies to a storm, the part with including an area for the dock to slide down and the activation of this area.

    I have my 5 icons set up along the bottom. I have animation set for all 5 icons. What I'm wanting to do is to have the icons slide down when not in focus, and using an image on my homescreen, upon focus in (or even just click/activation) have the icons slide up to their position. Then perform their animations based on focus in, then when I focus in on this image again (the one chosen to activate the dock) have all 5 icons slide back down off screen.

    Like I said, I've made my icon dock. Made the animations. I've made a large tab/area extending over the icons and going down what I believe to be a far enough distance off screen. I've made it transparent, sent it to back and made it a "non button". Thing is, this is where I get stuck. I don't know if it matters, but the image I want to make a button to activate the hidden dock, is also covered by the transparent "dock area". Don't know if this is relevant or not?

    Should this "activation button" be on a different layer? And then I'm still not sure I understand how to connect everything.

    Do I need to use different layers for the hidden dock part and activation button so as not to interfere with the icon animations? And then connecting them?

    I've got like a dozen threads open atm with tutorials and threads but still not sure I understand what it is I need to do.

    Any help would be most appreciated.

  3. #93
    holster27's Avatar
    holster27 no está en línea Stack level 3
    Join Date
    Aug 2007
    PIN/ID
    303721d5
    Posts
    392
    Quote Originally Posted by chottomatte View Post
    I'm hoping I can get a lil more help with this hidden dock thing please. More specifically, as this applies to a storm, the part with including an area for the dock to slide down and the activation of this area.

    I have my 5 icons set up along the bottom. I have animation set for all 5 icons. What I'm wanting to do is to have the icons slide down when not in focus, and using an image on my homescreen, upon focus in (or even just click/activation) have the icons slide up to their position. Then perform their animations based on focus in, then when I focus in on this image again (the one chosen to activate the dock) have all 5 icons slide back down off screen.

    Like I said, I've made my icon dock. Made the animations. I've made a large tab/area extending over the icons and going down what I believe to be a far enough distance off screen. I've made it transparent, sent it to back and made it a "non button". Thing is, this is where I get stuck. I don't know if it matters, but the image I want to make a button to activate the hidden dock, is also covered by the transparent "dock area". Don't know if this is relevant or not?

    Should this "activation button" be on a different layer? And then I'm still not sure I understand how to connect everything.

    Do I need to use different layers for the hidden dock part and activation button so as not to interfere with the icon animations? And then connecting them?

    I've got like a dozen threads open atm with tutorials and threads but still not sure I understand what it is I need to do.

    Any help would be most appreciated.
    sounds like you are on the right track, what you may want to do is create an invisible image somewhere on the screen that will close the dock and then once it is closed, you have the image there that opens it. That way, the only code you need to move the dock is the code for the two icons. You will want to make sure that the icon you have to "open" the dock is on another layer, so that way when the dock slides down, the "open" button doesn't go with it. If you want, I can take a look at it for ya. PM if you want me to. I would need the .cp file, .svg file and the images folder that goes with it. It seems that you are a-l-m-o-s-t there. Storms are trickier because they don't have a scroll wheel or ball.

    Hope that helps in some way.

  4. #94
    holster27's Avatar
    holster27 no está en línea Stack level 3
    Join Date
    Aug 2007
    PIN/ID
    303721d5
    Posts
    392
    AHHH, i see what you are trying to do, just reread your question again. If you want the icon to open and close the dock, there is a "trick" you have to do, but I can't tell you, it's much easier to show you.

  5. #95
    chottomatte's Avatar
    chottomatte no está en línea Stack level 1
    Join Date
    May 2009
    Posts
    14
    Yep its the same button that I want to use to open and close the hidden dock. Problem is is that I probably can't pm yet, this being only my 6th post.

    And you say you need to show me? The writing only going to serve to confuse the hell out of me then? :d lol probably will....but I'm game if you are.

    So one thing is confused. This logo image that I want to use as the activator for the hidden dock (to open and close it) has to be on its own layer. Was thinking that but wasn't quite sure.

    How many posts do I need btw to be able to pm? 10?

  6. #96
    chottomatte's Avatar
    chottomatte no está en línea Stack level 1
    Join Date
    May 2009
    Posts
    14
    One other thing just came to mind....thought I'd make new post to shamelessly bump my posts up.

    When I did the animations for my 5 icons, and copy/pasted the code from the todayplus.svg over to my svg, in preparation for the hidden dock, that went fine. But when I added in the transparent "non-button" area, sent to back and all that jazz....saved it and exported it....I noticed that the code (that I previously copy/pasted) seemed to disappear.

    Hmm....think I might have to start over...the practice couldn't hurt I guess.

    Anyways...get back to me if you can please Holster....really want to come to grips with this stuff.

  7. #97
    holster27's Avatar
    holster27 no está en línea Stack level 3
    Join Date
    Aug 2007
    PIN/ID
    303721d5
    Posts
    392
    I tell you what, get everything put together and email me at holster27@vzw.blackberry.net
    ~via smartphone mobile.pinstack.com~

  8. #98
    chottomatte's Avatar
    chottomatte no está en línea Stack level 1
    Join Date
    May 2009
    Posts
    14
    Thanking you holster. I appreciate the help.

    Just found out I have some friends coming over, so I won't have any time till later tonight. But will post it to you later this evening with some more detail about what it is I've done so far and attempting to do.

    Thanks again

  9. #99
    chottomatte's Avatar
    chottomatte no está en línea Stack level 1
    Join Date
    May 2009
    Posts
    14
    Ok holster, email sent to you with files, images folder and so on. Thanks

  10. #100
    becmc's Avatar
    becmc no está en línea Stack level 2
    Join Date
    Sep 2008
    PIN/ID
    Pls Ask
    Posts
    76
    Great tutorial. Thanx for your hard work and time.
    ~via smartphone mobile.pinstack.com~

  11. #101
    9of13's Avatar
    9of13 no está en línea Theme Pro
    Join Date
    Apr 2007
    PIN/ID
    ask me
    Posts
    1,105
    more thanks goes out to holster for the help hes been giving. My comp is going thru issues again and havent been able to really do anything. And i only get time here at work to reveiw posts. man i miss making themes. I was working on a good one too!

    Once again, Holster, you are the MAN!!!!
    For my theme blog, remember....
    Resistance Is Futile

  12. #102
    yaclexx's Avatar
    yaclexx no está en línea Stack level 1
    Join Date
    Jun 2009
    Posts
    3

    Question

    hi to all,
    Im new in the forum< i was trying the tutorial but im getting this error when I export in the Theme Builder:
    ---------------------------------------------------------------
    Errors in homescreen.svg:
    Error: A parse error has occurred at line 337 column 178 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 338 column 181 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 340 column 178 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 341 column 181 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 343 column 178 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 345 column 181 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 347 column 178 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 349 column 181 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 351 column 178 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 353 column 181 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 355 column 178 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    Error: A parse error has occurred at line 357 column 181 (cvc-complex-type.3.2.2: Attribute 'Fill' is not allowed to appear in element 'animateTransform'.).
    12 error(s) were encountered.
    ---------------------------------------------------------------
    im using plazmic 4.7<
    i cant see what im doing wrong

    thx!

  13. #103
    somdfisher's Avatar
    somdfisher no está en línea Stack level 1
    Join Date
    May 2009
    Posts
    12
    I have been working on animation for close to a month ( well kind of, I took a break for a while ) and still get errors.

  14. #104
    vernon804's Avatar
    vernon804 no está en línea Stack level 1
    Join Date
    Jun 2009
    Posts
    4

    i need help creating a hidden dock theme for pearl 8130

    i followed the instructions at the beginning of the thread starting with the composer application, saved the svg file, edited the svg file (with "Buttons" and the copy and paste text from the zip file), i tried changing the coordinates (not 0,0 but the other ones) and when that didn't work i tried again while leaving the coordinates alone, i saved the newly altered svg file but everytime i start a new project in theme builer and then try to upload the svg file i keep getting error messages saying somthing is wrong with the duration and my navigation menu is nothing like the one in the picture from the start of this thread.

    i noticed in the thread something about placing a new button in the svg file before saving it, if that is what i need to do then i am not sure how to go about it. i am new to theme building (started last week) but i have a fairly capable understanding how theme builder works, it's the composer and svg files that i don't fully understand.

    i am using theme builder 4.7 with the composer that came with it.
    my phone is a pearl 8130.

    i know it's possible to have a today plus theme with the hiding dock on my phone, i just can't seem to make my own.

    if anybody can help then i would really appreciate it. thankyou in advance.

  15. #105
    holster27's Avatar
    holster27 no está en línea Stack level 3
    Join Date
    Aug 2007
    PIN/ID
    303721d5
    Posts
    392
    Quote Originally Posted by vernon804 View Post
    i followed the instructions at the beginning of the thread starting with the composer application, saved the svg file, edited the svg file (with "Buttons" and the copy and paste text from the zip file), i tried changing the coordinates (not 0,0 but the other ones) and when that didn't work i tried again while leaving the coordinates alone, i saved the newly altered svg file but everytime i start a new project in theme builer and then try to upload the svg file i keep getting error messages saying somthing is wrong with the duration and my navigation menu is nothing like the one in the picture from the start of this thread.

    i noticed in the thread something about placing a new button in the svg file before saving it, if that is what i need to do then i am not sure how to go about it. i am new to theme building (started last week) but i have a fairly capable understanding how theme builder works, it's the composer and svg files that i don't fully understand.

    i am using theme builder 4.7 with the composer that came with it.
    my phone is a pearl 8130.

    i know it's possible to have a today plus theme with the hiding dock on my phone, i just can't seem to make my own.

    if anybody can help then i would really appreciate it. thankyou in advance.

    Are you saving the composer file as well, after you export the svg, make sure you save your work, it will save the composer working file and that way you can make changes in it. If you try to upload an svg into composer, it just gets all screwed up.

Page 7 of 14 FirstFirst ... 23456789101112 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •