Page 14 of 14 FirstFirst ... 91011121314
Results 196 to 208 of 208

This was a great tutorial, got a slide-up dock working great on my storm with ... Software & Theme Development forum

  1. #196
    greenemage's Avatar
    greenemage no está en línea Stack level 1
    Join Date
    Nov 2009
    Posts
    1

    Advertisement



    This was a great tutorial, got a slide-up dock working great on my storm with one minor problem... everytime I touch one of my dock icons the entire dock slides down a few pixels and then back up. Overall it's functional but annoying... I'd rather it stay completely fixed until I hide it. I've seen reference to "jiggle" or "shaking" and I'm not sure if this is the same thing. Any suggestions?

  2. #197
    StaticFX's Avatar
    StaticFX no está en línea Stack level 1
    Join Date
    Dec 2009
    Posts
    4
    Ok, after reading this ENTIRE thread like 6 times (THANK YOU) I am so very close to making this work

    This is on a storm2 running 5.0 using TB5.0
    I have a button on layer 2 that when clicked slides out my "dock"

    its the slide back part that needs tweaking. I would LOVE to have the same button do it, although I saw a few posts saying you can.. i cant figure it out. My other choice is onfocusout - which would work fine if it could be delayed?

    So, is there a way to delay the onfocusut? meaning this:

    I click the button
    dock slides out
    I click to launch the app
    doc slides back in

    wait.... i might have just figured this out while typing lol... brb

    Edit:Yes it works... added the "hide" code to the activate on the other 6 buttons!

    Now, one more question... is there a way to make the dock just appear instead of sliding in?

  3. #198
    9of13's Avatar
    9of13 no está en línea Theme Pro
    Join Date
    Apr 2007
    PIN/ID
    ask me
    Posts
    1,105
    inthe part of code that you edit-----> dur="0.5s" try changing it to something quicker. like -----> dur="0.01s" just make sure you never put----> dur="0.0s" itll bring up an error
    For my theme blog, remember....
    Resistance Is Futile

  4. #199
    StaticFX's Avatar
    StaticFX no está en línea Stack level 1
    Join Date
    Dec 2009
    Posts
    4
    Yeah found that out. Lol
    I also found that u can use the show/hide right in composer! No slide, just appears! Thanks!
    Mozilla/5.0 (iPod; U; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7D11 Safari/528.16

  5. #200
    trumansnare's Avatar
    trumansnare no está en línea Stack level 1
    Join Date
    Feb 2009
    Posts
    2
    Hey,
    Thanks a lot for the tutorial. It is very very helpful.

    I had no trouble following the tutorial. But I am having trouble getting it to work for the storm.

    I read that I have to create a blank button. Then go into the svg and edit the name to the same thing as the first button?

    This is the part that I am confused about. I know how to add a blank button, but I am not quite sure what you mean when you say to change the name to the same thing as the first button.

    Is there any way that you could clarify this for me?

    Thank you so much 9of13,
    Tsnare

  6. #201
    trumansnare's Avatar
    trumansnare no está en línea Stack level 1
    Join Date
    Feb 2009
    Posts
    2
    Ok,

    I got it. After hours and hours of toying with the blank button I was able to get it to work.

    My dock slides in and out just fine, and all the icons are working.

    I have one issue that I hope that you can help me with........

    I have all the icons in the .svg set to "use device application order" and they are working fine. If I have "messages" set as my first icon, then "messages" shows up first on the dock. The problem is, there is no focus icon on the .svg icons. I want the dock icons to take the order of the first 5 icons in the applications list, but I also want them to use the same focus image.

    Do you know how to do this?

    Thanks a lot

  7. #202
    9of13's Avatar
    9of13 no está en línea Theme Pro
    Join Date
    Apr 2007
    PIN/ID
    ask me
    Posts
    1,105
    Quote Originally Posted by trumansnare View Post
    Ok,

    I got it. After hours and hours of toying with the blank button I was able to get it to work.

    My dock slides in and out just fine, and all the icons are working.

    I have one issue that I hope that you can help me with........

    I have all the icons in the .svg set to "use device application order" and they are working fine. If I have "messages" set as my first icon, then "messages" shows up first on the dock. The problem is, there is no focus icon on the .svg icons. I want the dock icons to take the order of the first 5 icons in the applications list, but I also want them to use the same focus image.

    Do you know how to do this?

    Thanks a lot
    Check out holster27's "hidden dock with highlighter icon" tutorial. He figured out that.

  8. #203
    JaredPress's Avatar
    JaredPress no está en línea Stack level 1
    Join Date
    Apr 2010
    Posts
    3

    Hope someone is still monitoring this thread...issues with hidden dock

    I hope this thread is still being watched.

    I am trying this tutorial with Theme Builder 5.0 and composer 5.0 but am having difficulties.

    One I cannot get simulator to run properly (Vista)...is there a specific folder that it should ne loaded into?

    Also when trying to import SVG I get an error message reading "Duration not specified". Will this tutorial work work with 5.0 versions?

    Thanks

  9. #204
    9of13's Avatar
    9of13 no está en línea Theme Pro
    Join Date
    Apr 2007
    PIN/ID
    ask me
    Posts
    1,105
    JaredPress, sorry for the late responce. I havent been on here in a while. For the simulator, i too am having problems since i recently switched to vista. tryin to find that out myself. As far as "Duration not specified", check your svg code. be sure that the layer name in the code you add matches the actual name of the same layer in composer. If the layer that contains your dock is "Layer 2" in Composer, the code on your svg should be for "Layer_2".
    For my theme blog, remember....
    Resistance Is Futile

  10. #205
    Paratheo's Avatar
    Paratheo no está en línea Stack level 1
    Join Date
    Jan 2009
    Posts
    1

    Question Thanks for the help but need more help.

    Hi. Thanks a lot. This really helped me. But I'm wondering if u could tell me how I would code something where when you trackball or whatever left, other icons slide in and then also when u move right, new icons slide in from the right. And just to clarify there is a dock in the middle of these two sliding things so when one slides in, the main one slides out the other direction. Do u know what I mean? Thanks in advance

  11. #206
    sykko's Avatar
    sykko no está en línea Stack level 1
    Join Date
    Jul 2010
    Posts
    1

    Question k...

    so it works great up untill im supposed to open it in notepad... then i get jibber jabber... same result with notepad++ and textpad and word... please help!!!!!!
    Attached Files Attached Files

  12. #207
    9of13's Avatar
    9of13 no está en línea Theme Pro
    Join Date
    Apr 2007
    PIN/ID
    ask me
    Posts
    1,105
    Quote Originally Posted by sykko View Post
    so it works great up untill im supposed to open it in notepad... then i get jibber jabber... same result with notepad++ and textpad and word... please help!!!!!!
    are you opening the .svg file, or the .thm file???? It looks like the .thm file. Open the .svg in notepad
    For my theme blog, remember....
    Resistance Is Futile

  13. #208
    Everlasting's Avatar
    Everlasting no está en línea Stack level 1
    Join Date
    Jun 2013
    Posts
    1
    hi im newbie in here , i follow you tutorial sir but everytime i move to another icon the dock always bounce like jinggle something like that please how to fixed this ?

Page 14 of 14 FirstFirst ... 91011121314

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •