Results 1 to 10 of 10

I have spent hours making sure I have all the right files and programs to ... Software & Theme Development forum

  1. #1
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Having trouble with exporting theme

    Advertisement



    I have spent hours making sure I have all the right files and programs to start building themes. I went to work building a theme. Once I was done I saved it and then tried to export it. There was a message saying it had been successfully exported, but the file is non-existant. I have tried the various combos of .alx/.jad and Target O/S versions and nothing has worked out. What am I missing here?
    In relation to this, when I export an .alx file from the Theme Builder, is there also supposed to be a .cod file created? I thought this was something that is needed when you load a theme with the BB Download Manager. Any help would be greatly appreciated. I have a theme that is finished that I would love to try out, but I can't get it exported to use the simulator. I knew it was going to well....lol. Just when I thought I was done, then I run into problems. Can someone steer me in the right direction here? I couldn't find my answer on the forum, so I apologize if this has been covered. Thanks!

    David
    Last edited by 589Outlaw; 02-12-2008 at 12:13 PM. Reason: typo

  2. #2
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164

    Re: Having trouble with exporting theme

    david,
    where did you save it?
    did you try to browse to that location and add the alx file?

    when you export alx (desktop download) you will produce 1 alx file and 1 cod file. when you go to load the theme using DM, you will NOT see the cod file as it is hidden.

    when you export jad (for OTA download) you will produce 1 jad file and many cod files (cods depend on your images and how many you have)

    so, with all of that said ^^ what do you mean 'non-existent'? are you exporting to 4.2.0? you must export to that version or the theme won't work.

    instead of loading it into the simulator, have you just tried loading it on your own bb using DM? i have never once used the simulator. i just use my own bb to test it

  3. #3
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Re: Having trouble with exporting theme

    I created a folder specifically to store themes in. After exporting it to that folder, it remains empty. I even did a system search for all .alx files and it was not on that list either. I am exporting it to 4.2.0, so I guess at least that is correct.

    I wanted to test it in the simulator since it was my first attempt at a theme, but it can't even find the files. So, that is a non-issue for now anyway. I tried finding it on the DM, but it didn't show up when I browsed for the file.

    I am guessing the export is just not happening even though it is saying it is successful. There are no .axl and no .cod files being created as far as I can tell. I am not a moron, but this is starting to make me feel like one. lol

    Thanks for helping me out!

    David
    8100 Pearl Newbie
    v4.2.1.107 (Platform 2.3.0.83)

  4. #4
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164

    Re: Having trouble with exporting theme

    ~via BB (wap.pinstack.com)~

    So when you hit export a window pops up. You choose alx, 4.2.0, you click the folder and browse to the folder you want to save and choose. It brings you back to export window. Choose ok.

    Is that what you are doing?

  5. #5
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Re: Having trouble with exporting theme

    That's it exactly. Once I hit OK, it has a "working" window. When it is done I get the message saying it was successful. No files to speak of though.
    8100 Pearl Newbie
    v4.2.1.107 (Platform 2.3.0.83)

  6. #6
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Re: Having trouble with exporting theme

    Would someone be interested in checking out my .thm file? I would like someone to look at it and try exporting it. If you can create .alx and .cod files out of it then I know where I need to start looking.
    8100 Pearl Newbie
    v4.2.1.107 (Platform 2.3.0.83)

  7. #7
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Re: Having trouble with exporting theme

    Anyone? I think I am just screwed here...
    8100 Pearl Newbie
    v4.2.1.107 (Platform 2.3.0.83)

  8. #8
    cherrichiodo's Avatar
    cherrichiodo no está en línea PINStacked!
    Join Date
    Aug 2006
    PIN/ID
    ATA
    Posts
    17,164

    Re: Having trouble with exporting theme

    ~via BB (wap.pinstack.com)~

    Outlaw -- send it to me.
    Me at cherrichiodo dot com

    One thing I noticed when re-reading was that you said you got a window that said it was successful. Are you sure? Bc the ONLY popup window I've gotten would be if there was an error.

  9. #9
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Re: Having trouble with exporting theme

    I should have clarified that. It is a window that pops up with the message, "Theme was exported successfully, but some warnings were logged." When I view the details it has this: "Warning: Banner Battery Meter: The battery meter height is larger than the default height (36 pixels). On applications with a thin banner, the battery meter may display incorrectly." I wouldn't think that would be the problem since it says it was still exported. I guess I should try to change the meter anyway and try it.

    Ok, I sent you the theme file. I am keeping my fingers crossed. Thanks!
    8100 Pearl Newbie
    v4.2.1.107 (Platform 2.3.0.83)

  10. #10
    589Outlaw's Avatar
    589Outlaw no está en línea Stack level 1
    Join Date
    Feb 2008
    Posts
    12

    Re: Having trouble with exporting theme

    And just to update....I did try changing the battery meter to the default height. I no longer get the pop up window. There is also still no file appearing in the folder I export it to.
    8100 Pearl Newbie
    v4.2.1.107 (Platform 2.3.0.83)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •