Results 1 to 3 of 3

First and foremost, I know absolutely nothing (unfortunately) about the code part of the svg ... Software & Theme Development forum

  1. #1
    JavaBratt's Avatar
    JavaBratt no está en línea Stack Professional
    Join Date
    Apr 2011
    Posts
    548

    Question Composer question... need help ASAP please

    Advertisement



    First and foremost, I know absolutely nothing (unfortunately) about the code part of the svg and what I do is strictly copy & paste from a tutorial where all I have to do is change some dimensions. That being said, here's my problem....

    The theme I am working on is going to have an 18-icon scrolling dock, weather slot in the banner as well as clickable meters. Unfortunately, I can't get the clickable meters to work by the time I get it all put together and they work fine in the beginning.

    What I've done is created a new composer, placed all my icons (one in banner and 18 across the bottom). Then I proceed to import my images for the clickable meters, convert them to buttons etc. At this point everything works fine (clickable meters, focus icons etc), but the dock doesn't scroll because I haven't yet added the code to the svg. Once everything looks how I want it, I add the code to my svg file and a few problems occur...

    One, the weather slot in the banner slides with the rest of the dock which its obviously not supposed to do and its focus shows all the time even though its set up like the other icons, which work as intended (and it worked fine prior to the code being inserted).

    Two, the clickable meters don't show their focus icon when hovered over.

    So I'm wondering how to fix these problems? Should I put the weather slot and clickable meters on a second layer?

    Any advice that can be offered will be greatly appreciated and thanks in advance to those who reply!
    iPhone 5C | iOS 7.0.4
    iPad 3 - 32GB | iOS 7.0.4

    Theme Support Info

  2. #2
    PapaMag's Avatar
    PapaMag no está en línea Stack Professional
    Join Date
    Apr 2006
    PIN/ID
    Nadda
    Posts
    5,722
    I have not built anything like this but my first bit of advise would be to use multiple layers, put your scrolling dock in the first, weather slot in second and you clickable meters in a third. One may be sending the wrong signal in the coding. I just have never done clickable meters so that I'm not sure about

    Samsung Galaxy S4
    Asus Nexus 7
    Nook Color







  3. #3
    JavaBratt's Avatar
    JavaBratt no está en línea Stack Professional
    Join Date
    Apr 2011
    Posts
    548
    Quote Originally Posted by PapaMag View Post
    I have not built anything like this but my first bit of advise would be to use multiple layers, put your scrolling dock in the first, weather slot in second and you clickable meters in a third. One may be sending the wrong signal in the coding. I just have never done clickable meters so that I'm not sure about
    I've tried splitting things up between layers and it didn't work either. So for now I have given up on using the scrolling dock because it's really just to big of a pain when it literally throws everything else out of whack. For now I'm just going to stick with the 6-icon hiding dock, so I can keep the other features and actually have them work.

    BUT now I've noticed a different set of issues...
    For one, the focus icon for the weather slot shows when the theme is first loaded, which is something I've never had a problem with before. The only thing I did any different this time was to use smaller icons so it would match in size with the banner profiles icon, but I see no reason why its size would cause this problem. Moreover I don't know how to get it to stop.

    The other thing... after loading the theme on my device it worked fine aside from the above WS focus icon showing (which does go away once you hover over it), but then after a while the navigation just stops working. My father was checking it out when he handed it back to me and said he couldn't move to anything and sure enough it would only move between the banner date and today text.

    So I'm not sure what to do to be honest. I'm setting things up like I have a dozen times before only I'm getting different results, which makes no sense to me
    iPhone 5C | iOS 7.0.4
    iPad 3 - 32GB | iOS 7.0.4

    Theme Support Info

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •