Results 1 to 5 of 5

So i went through all the steps to unlock my 8800 from O2. Got the ... C Spire/Cellular South forum

  1. #1
    bipit's Avatar
    bipit no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    3

    Unlocked 8800 from O2 gives "Insert SIM Card" Error

    Advertisement



    So i went through all the steps to unlock my 8800 from O2. Got the code, unlocked the BB and verified via the menus that it SIM lock was disabled etc. But when i put in a SIM from another provider (I've tried 3 different ones) it just says "Inset SIM Card" and under SIM Card in the menu it says "Invalid SIM".

    Now I've tried wiping, policy.bin, jloader and everything else I can think of but it still doesn't work. Note the SIM works fine in an unlocked 8100 right now so it isn't the SIM card.

    Cheers.

  2. #2
    bipit's Avatar
    bipit no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    3

    image of errora

    image of errora
    Attached Images Attached Images

  3. #3
    bipit's Avatar
    bipit no está en línea Stack level 1
    Join Date
    May 2008
    Posts
    3
    bump, would love some help here, spent a ton of money on this thing and now doesn't work. GSMPhonesource is no help either for some reason

  4. #4
    bwell2004's Avatar
    bwell2004 no está en línea Stack level 1
    Join Date
    Jun 2008
    Posts
    4

    im hoping someone could help me

    o2 are telling me that they arent going to release the pay as you go settings for the pearl for ages, ive just paid £100 for one and cant use the mms/internet/ E-mail is there anyway i can activate them while staying on o2 pay as you go?
    help would be really greatful.

  5. #5
    Thyth's Avatar
    Thyth no está en línea Stack level 3
    Join Date
    Sep 2007
    Posts
    273
    Quote Originally Posted by bipit View Post
    bump, would love some help here, spent a ton of money on this thing and now doesn't work. GSMPhonesource is no help either for some reason
    Do you have an O2 Sim to test the phone with?

    Since it says "Insert SIM Card" instead of "Invalid SIM Card", I'm inclined to think it isn't detecting inserted cards, rather than being an issue with the unlock. Try examining the 8800's metallic SIM contacts for dirt/corrosion, and make sure the card is coming into contact with all 6 contacts.

    Otherwise, it sounds like a hardware issue with the 8800 itself.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •